Publishing – automatically not working in MyEcplise/Weblogic

  1. MyEclipse IDE
  2.  > 
  3. Installation, Configuration & Updates


Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #679199 Reply


    I have multiple projects which I am working in development mode.
    I deploy these as packaged war files in MyEclipse and Weblogic

    I chose the automatically publish setting when resources change option in Weblogic, so that when I change any java file or a jsp/script file, it will get deployed. I also tried the other option of Automatically publish after a build event of 5 secs.

    None of them deploys the changes and I keep seeing a message on the weblogic servers tab – Republish.
    I had googled it and seen messages that if you do project clean or change a resource – it will get deployed on its own.
    I am now being forced to restart the server every time I make some change and want to view the changes.
    Can anyone advise me on if this is something which is resolved in MyEclipse Version: 2021.5.24
    Build id: 16.0.0-20210524

    Thanks for all your help

    #679200 Reply



    Sorry that you are seeing this issue.

    1. Does the jsp/script file changes also requiring you to restart the server to reflect?
    2. Do you see the timestamp for the .class file change in the deployment location when you save your changes?

    For the hot deployment to work in MyEclipse, Weblogic should be started in Debug mode and the application should be deployed in Exploded mode.
    Right click on the Weblogic server entry in the Servers view, select ‘Debug’ and then add your project for deployment in exploded format.

    If this doesn’t work, then please share more details about the type of project, version of EJB classes if any. Also share the .log file located at workspace dir/.metadata/.log (rename the extension to .txt and attach it here) to help us investigate further

    Do let us know how it works for you.

    Genuitec Support

    #679306 Reply


    Swapna : Thanks for the reply back.
    Yes, it requires restart for JSP/java files.
    I have to deploy it as packaged since the exploded format is not working and it gets stuck on the weblogic start at the resuming stage. The only way I could get all of the applications to work on a windows 10 machine is by going with a packaged deployment approach. I have multiple projects where it only works in packaged format and its very frustrating to wait for the server stop/restart for every single change done in the code. This is taking a lot of time away from actual development.

    Also – Could you please clarify that automatic publishing does not work for packaged deployments in myeclipse. I attached a screenshot for that window.

    #679307 Reply


    Attaching the screenshot for the issue

    You must be logged in to view attached files.
    #679313 Reply



    I ran few tests with exploded deployment in Weblogic in MyEclipse 2021 and do not see any issues with deploying or automatically publishing the changes.

    1. Did the exploded deployment ever work for you? Can you create a simple project with one jsp and java file and check if the exploded deployment works? This is to rule out project related issues.

    2. Attempt the exploded deployment once again and share the Console output as well as the .log file located at workspace dir/.metadata/.log (rename the extension to .txt and attach it here) to help us check if any errors are logged during exploded deployment.

    3. What type of projects are you working with? Please elaborate.

    Genuitec Support

Viewing 5 posts - 1 through 5 (of 5 total)
Reply To: Publishing – automatically not working in MyEcplise/Weblogic

You must be logged in to post in the forum log in