Reports designed in report designer had issues in runtime

Home Forums Archived Forums MyEclipse Archived MyEclipse Reports Reports designed in report designer had issues in runtime

This topic contains 6 replies, has 5 voices, and was last updated by Profile photo of Maturin Maturin 3 years, 10 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #294786
    Profile photo of Ed ross
    Ed ross
    Member

    I design reports in the MyEclipse report designer, then take the rtpdesign file and use is as part of my ant task.

    Started getting this issues when using reports designed with the MyEclipse designer.

    Any ideas how to resolve this?

    thx

    
      [CCIAnt] Feb 13, 2009 8:25:42 AM org.eclipse.birt.report.model.metadata.ExtensionLoader handleError
       [CCIAnt] SEVERE: Message:The class [org.eclipse.birt.report.engine.api.script.EngineScriptableClassInfo] can not be instantiated. Error code:FAILED_TO_CREATE_INSTANCE 
       [CCIAnt] Feb 13, 2009 8:25:46 AM org.eclipse.birt.data.engine.odaconsumer.Driver doGetDriverManifest
       [CCIAnt] SEVERE: Cannot process data source extension configuration.
       [CCIAnt] java.lang.IllegalArgumentException: com.genuitec.eclipse.reporting.oda
       [CCIAnt]     at org.eclipse.datatools.connectivity.oda.util.manifest.ManifestExplorer.getExtensionManifest(ManifestExplorer.java:200)
       [CCIAnt]     at org.eclipse.birt.data.engine.odaconsumer.Driver.doGetDriverManifest(Driver.java:147)
       [CCIAnt]     at org.eclipse.birt.data.engine.odaconsumer.Driver.findDataSourceExtensionConfig(Driver.java:123)
       [CCIAnt]     at org.eclipse.birt.data.engine.odaconsumer.Driver.getDriverExtensionConfig(Driver.java:78)
       [CCIAnt]     at org.eclipse.birt.data.engine.odaconsumer.Driver.getExtensionConfig(Driver.java:60)
       [CCIAnt]     at org.eclipse.birt.data.engine.odaconsumer.Driver.getDriverHelper(Driver.java:93)
       [CCIAnt]     at org.eclipse.birt.data.engine.odaconsumer.DriverManager.getDriverHelper(DriverManager.java:97)
      
    #294791
    Profile photo of Loyal Water
    Loyal Water
    Member

    edross,
    Can you please give me a more detailed explanation of what exactly you did when you ran into this issue.

    #294825
    Profile photo of Ed ross
    Ed ross
    Member

    I design the reports using MyEclipse report designer. I then take the rpt design and move it into a reports directory.
    I have created an ant task that sets up the report engine (Using the Runtime from the eclipse page) and wish to generate pdf reports.

    This worked ok in MyEclipse 6.x, but I get the above error in MyEclipse 7.
    If I use the “all in one package” from the Eclipse download to design the report I don’t seem to encounter this problem. I prefer to use the MyEclipse version to keep all of my datasources and definitions in one place.

    #294870
    Profile photo of Riyad Kalla
    Riyad Kalla
    Member

    Ed,

    MyEclipse Reports was upgraded in the MyEclipse 7.0 release to the latest BIRT platform, it’s possible the APIs have changed for that class (possibly deprecated?) It’s hard to tell, not really a usage scenario I’ve tried before.

    #294892
    Profile photo of rmcvay
    rmcvay
    Member

    BIRT does not suffer gladly report designs from an earlier version.

    #295107
    Profile photo of Ed ross
    Ed ross
    Member

    The problem is that your reports have
    com.genuitec.eclipse.reporting.oda

    Normal birt reports use a more generic datasource/driver

    I think If you could just tell me which jar(s)& data resource files to copy to the reportEngineHome from eclipse this might work.

    #319388
    Profile photo of Maturin
    Maturin
    Member

    Hi Edross,

    Sorry posting on this old post but I also want to schedule MyEclipse Birt reports tu run and I am having the same error…

    I am not sure this is fixable easilty as MyEclipse reports are not standard BIRT reports!
    I was wondering did you ever get it to work?

    Cheers

Viewing 7 posts - 1 through 7 (of 7 total)

The forum ‘MyEclipse Reports’ is closed to new topics and replies.