Session invalidated when using Spring Security 3.2.5 with Scaffold Wizard

This topic contains 1 reply, has 2 voices, and was last updated by  support-swapna 3 years, 9 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #471799 Reply

    Rick Frey
    Participant

    I am interested in using the Scaffold Spring Security Wizard with MyEclipse 2016. Found that my session is lost/invalidated when using Spring Security 3.2.5 (and Spring 4.1) for my project.

    Issue occurs with my project and also with the MyEclipse tutorial project CustomersApp. If Spring Security 3.1 (and Spring 3.1) are selected in the Scaffold wizards, the login/session work fine. However, if I select newer versions of Spring Security 3.2.5 (and Spring 4.1), the application security does not function correctly.

    I am prompted for a login, but then lose my session ID when returning to the dashboard. Still digging in to the differences when selecting different versions of the Spring libraries, but so far unable to determine why my session is not retained after login. It appears the MyEclipse Scaffold Spring Security wizard is not working correctly with the later version of Spring Security.

    #471862 Reply

    support-swapna
    Moderator

    Rick,

    Thank you for reporting this issue. I could replicate it at my end and filed a bug with the dev team.
    They are looking into it. We will keep you posted about the fix.

    Sorry for inconvenience caused.

    –Swapna
    MyEclipse Support

Viewing 2 posts - 1 through 2 (of 2 total)
Reply To: Session invalidated when using Spring Security 3.2.5 with Scaffold Wizard

You must be logged in to post in the forum log in