Shortcuts in Typescript IDE

This topic contains 8 replies, has 3 voices, and was last updated by  Brian Fernandes 1 week, 1 day ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #534066

    olihd
    Participant

    Would be really nice if the Typescript IDE had the same shortcuts like the other IDE. I reconfigured some shortcuts for editors but Typescript IDE still uses the default ones – and those are not changeable. E.g.: “Find references”

    #534075 Reply

    support-swapna
    Moderator

    olihd,

    Sorry that you are seeing issues with shortcuts in AngularIDE.

    Can you please share with us more details about the key combination you set for “Find References”?
    If possible, please share with us the screenshot of Window > Preferences > General > Keys ( use the filter box to bring up the relevant line for ‘Find References’ and send us the screenshot). If your binding conflicts with another binding, you will see a “C” in the User column for the line.

    Please also give us details about the other shortcuts for editors which you are trying to reconfigure to help us investigate further. Also share with us the OS and version details.

    Apologies for inconvenience caused.

    –Swapna
    MyEclipse Support

    #534253 Reply

    olihd
    Participant

    No conflicts (see screenshot). Changed “References in workspace” to both Alt+F7. But Typescript Editor shows still on right click “Find References” = Cmd+Shift+G -> seems like I cannot change those keys at all? Why don’t you use just the same as the other IDE?

    Attachments:
    You must be logged in to view attached files.
    #534274 Reply

    support-swapna
    Moderator

    olihd,

    Thank you for the screenshot and details.I could replicate the problem with key binding in ts files at my end.
    I have filed a bug for the dev team to investigate further. We will keep you posted when the fix is out.

    Apologies for inconvenience caused.

    –Swapna
    MyEclipse Support

    #593208 Reply

    olihd
    Participant

    It happens again – now every time I open Eclipse the shortcuts (Javascript and Java) for “Open Type” are empty!!! Very annoying! (Using latest Versions of Webclipse, Angular IDE, CodeMix))

    #593219 Reply

    Brian Fernandes
    Moderator

    Oliver,

    First, sorry to hear you’re running into this – we have a few questions:

    1) Can you please let us know whether you’re running Eclipse Oxygen or Photon?
    2) Also give us the versions of Angular IDE/Webclipse and CodeMix – you can find these on the Preferences > Webclipse and Preferences > CodeMix pages.
    3) From your description, I’m assuming you bind them, it works as expected for that session, and then the bindings are lost on restart? Did anything change in your environment, did you just install CodeMix, or did you update to a newer version?
    4) While the above should definitely not happen, can you go to Preferences > CodeMix > Bindings and uncheck the Open Types on Ctrl + Shift + T checkbox – does that help?
    5) Could you share with us your workspace error log please?

    If #4 doesn’t help – can you please share with us a screenshot of your Keys preference page, filtered to open type?

    #593334 Reply

    olihd
    Participant

    1) Photon
    2) Angular 2017 CI 12a, CodeMix CI 2018.6.27
    3) Yes. No changes – just like always the regular updates.
    4) Already did this. No solution.
    5) attached

    Screenshots of both Open Types also.

    Attachments:
    You must be logged in to view attached files.
    #593339 Reply

    olihd
    Participant

    If I temporarily disabled CodeMix functionality and it’s still configured after restart – so running fine. So please stop messing around with the standard key assignments. I also had a issue once (see my issues) with Webclipse key bindings doing similar things!

    #593384 Reply

    Brian Fernandes
    Moderator

    Oliver,

    The newer functionality bound to Ctrl + Shift + T would give you a workspace wide symbol search, which includes all the Java symbols you would see in the regular Open Type dialog, in addition to symbols from other languages. We believe this to be an improvement over Open Type, which is why we’ve made the change to the existing bindings.

    At the same time, I understand that many might not like this behavior, which is why you can turn it off on the bindings page. The fact that you seem to be unable to turn it off is a bug that we would definitely like to fix – if you can help us do this, that will be great! The Eclipse preference mechanism does exhibit some odd behavior, and in your case, I believe the Oomph preference recorder (which I can see in your logs) is incorrectly restoring the older settings, and this is unfortunately out of our control:(

    If you would like to re-enable CodeMix, you can take the following steps to disable the Oomph preference restoration, and hopefully get the bindings you want back.

    1) Go to Preferences > Oomph > Setup Tasks > Preference Recorder and uncheck Record into if not already unchecked – it’s possible that preferences were recorded at some time in the past though.
    2) Shut down Eclipse
    3) Go to [user_home]/.eclipse and move / delete the folders named *oomph* – this will make the (bad) saved preferences inaccessible.
    4) Restart Eclipse
    5) Open Preferences, go to the CodeMix > Bindings page & Uncheck the Ctrl + Shift + T option
    6) Click Apply & Close to close the dialog. If you go to the Keys page before this stage, a bug in how Eclipse handles preferences will still show the older state – so don’t bother checking before reopening.

    Quite a few steps, but they should be straightforward, and I hope this resolves the problem.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.