SonarQube plugin installation error

This topic contains 1 reply, has 2 voices, and was last updated by  support-swapna 6 months, 2 weeks ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #560894 Reply

    mohansubbusamy
    Participant

    Hi,
    I’m getting below error while installing SonarQube, could you please take a look at it and let me know wheat is wrong?
    ==========================================================================================================
    Cannot complete the install because one or more required items could not be found.
    Software being installed: SonarQube 3.4.0.20140404-0949-RELEASE (pack.popular-pack.1226.feature.group 3.4.0.20140404-0949-RELEASE)
    Missing requirement: SonarQube 3.4.0.20140404-0949-RELEASE (pack.popular-pack.1226.feature.group 3.4.0.20140404-0949-RELEASE) requires ‘org.sonar.ide.eclipse.pydev.feature.feature.group [3.4.0.20140404-0949-RELEASE]’ but it could not be found
    =========================================================================================================
    Here is myeclispe details:

    *** System properties:
    OS=Windows7
    OS version=6.1.0
    OS arch=amd64
    Profile arch=x86_64
    Window system=win32
    Java version=1.8.0_112
    Workspace=file:/C:/MyEclipse2017/Workspaces/
    VM Args=-Xms1024m
    -Xmx2048m
    -XX:+UseG1GC
    -XX:+UseStringDeduplication
    -Dosgi.requiredJavaVersion=1.8
    -Dosgi.nls.warnings=ignore
    -jar

    *** Subscription information
    Product Id: E3MS (MyEclipse for Spring Subscription)
    License version: 3.0
    Full Maintenance Included
    Subscription expiration date (YYYYMMDD): 20181106
    Number of users: 6

    *** Eclipse details:
    MyEclipse Enterprise Workbench

    Version: 2017 Stable 1.0
    Build id: 15.0.0-20170329

    Thanks,
    Mohan

    #560917 Reply

    support-swapna
    Moderator

    Mohan,

    Sorry that you are seeing this issue. I could install the SonarQube 3.4 successfully at my end from Eclipse Marketplace to 2017 Stable 1.0 (go to Help > Install from Catalog and search for SonarQube).

    How exactly are you installing the SonarQube plugin?
    Please note that MyEclipse 2017 is based on Eclipse 4.6 and SonarQube is officially compatible only with Eclipse 4.5 as per this page : http://downloads.sonarsource.com/eclipse/eclipse/

    I also suggest you check in SonarQube or development related forums like stackoverflow.com about the SonarQube + Eclipse install problem to get better support from the developer community.

    Apologies for inconvenience caused. Please let us know how you get on with this problem.

    –Swapna
    MyEclipse Support

Viewing 2 posts - 1 through 2 (of 2 total)
Reply To: SonarQube plugin installation error