Spring Support for MyEclipse 16

This topic contains 4 replies, has 3 voices, and was last updated by  Brian Fernandes 1 week, 1 day ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #636732 Reply

    daveONE
    Participant

    I am using JAVA 11 and I am experiencing variety issues with “Spring Support for MyEclipse 16”.

    MYEclipse Version: 2019.12.5 installed

    Some issues:
    * Unable to edit Application.yml using Spring YAML editor
    * Perform a Maven – Update – I see this in console – “Error occurred while runing post bean processor”

    I tried to update using Spring STS – springsource-tool-suite-3.9.11.RELEASE-e4.13.0-updatesite.zip to correct issue
    but Update would not work since it conflicts with “Spring Support for MyEclipse 16”

    #636778 Reply

    support-swapna
    Moderator

    Dave,

    Sorry that you are seeing issues.

    1. Are you starting MyEclipse IDE with Java 11 or working with a Java 11 project?

    2. I could edit a .yml file using YAML editor. Can you please clarify what exact issue you are seeing w.r.t editing Application.yml file? Does editing any other .yml file using YAML editor work?

    3. Can you please share with us the complete stacktrace for the error logged in the Console for Maven > Update?

    4. Please also share with us the .log file located in the workspace dir/.metadata/.log (change the extension to .txt and attach it here)

    Apologies for inconvenience caused.

    –Swapna
    Genuitec Support

    #637045 Reply

    daveONE
    Participant

    MyEclipse support,

    1 . – Here is excerpt from MyEclipse.ini – which shows I am starting MyEclipse with Java 11
    -vm
    F:\Program Files\Java\jdk-11.0.5\bin\javaw.exe

    2. – MyEclipse IDE provides support to Spring via “Spring Support for MyEclipse 16” plugin which also includes Spring Properties YAML Editor, Unfortunately the latest version MyEclipse produces an error
    I was experimenting with Locking to MyEclipse CI 2019 v4 update -and I was able to open application.yaml file so the latest version of Myeclipse introduced this error.
    Please see Error1 attached image

    3. Maven -> Update Project
    Please see Error2 attached image
    Please note the stack trace is not my code but something internal to MyEclipse IDE integration with Spring

    I noticed that this error only appears when projects are using latest version of Spring 5.x and with application which are Spring 4.x based – this error does not happen.
    So this error appears to happen only on the most current version of Spring.

    Attachments:
    You must be logged in to view attached files.
    #637071 Reply

    support-swapna
    Moderator

    Dave,

    Thank you for the details and the screenshot.
    I could replicate the problem with the Spring YAML Properties editor at my end with MyEclipse 2019.12.5.
    I have filed a bug report for the dev team to look into it. We will keep you posted when the fix is out.

    Regarding the Maven > Update Project error I tried with Spring 5.0.5 libs, but do not see the issue. Is it possible for you to share with us a zipped sample project to help us replicate the problem at our end? Also share with us the .log file located in the workspace dir/.metadata/.log to help us get complete stacktrace of the errors (screenshots of the error does not give us the complete stacktrace)

    Apologies for inconvenience caused.

    –Swapna
    Genuitec Support

    #637325 Reply

    Brian Fernandes
    Moderator

    Dave,

    Were you able to move past the maven update issue? We would like to see the stack trace that Swapna requested so that we’re able to say more about the error.

    I will say that due to incompatibilities with versions of Java > 8, there are some libraries in Maven based projects that won’t play nice in Eclipse / MyEclipse when the IDE is running Java 11. The only recommended fix for this is running the IDE with Java 8, or upgrading the library. I’m not sure if this is what you’re experiencing, would possibly be able to say more with the log.

Viewing 5 posts - 1 through 5 (of 5 total)
Reply To: Spring Support for MyEclipse 16

You must be logged in to post in the forum log in