Status of Matisse in MyEclipse 2019 CI 4

Tagged: 

This topic contains 1 reply, has 2 voices, and was last updated by  Brian Fernandes 4 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #617744 Reply

    rzc1
    Participant

    Hi MyEclipse team,

    I just tested Matisse with MyEclipse 2019 CI 4. This gave me some issues. Here is what I have done:

    Test 1

    • I created a new workspace
    • I used the Matisse wizard to create a new JPanel => the panel “.form” File was created but not the “.java” file => error see attached .log file

    Test 2

    • I opened a .form file from an existing project.
    • Matisse Editor opened, palette is showing, outline is showing (correctly populated).
    • Preview area is empty
    • blindly clicking in the preview area select components in the outline

    This gives me some questions:

    Is Matisse still supported with 2019 CI 4?
    If so please have a look at this issue and create a fix.
    If not – why is Matisse still integrated in 2019 CI4 4?

    With regards
    Stefan

    Attachments:
    You must be logged in to view attached files.
    #617774 Reply

    Brian Fernandes
    Moderator

    Stefan,

    Apologies, somehow this passed through our testing net. Matisse normally requires you to change the version of Java that MyEclipse runs with from Java 11 to Java 8, but it would appear that in the recent Eclipse integration, that is no longer sufficient either. We’ve filed this as a bug and we should be able to fix this in the next MyEclipse release.

    Not sure if it helps (and perhaps you are already aware), if you downgrade to 2018.12 (from the Help > Check for Updates wizard) – and change to running with Java 8, Matisse should work.

Viewing 2 posts - 1 through 2 (of 2 total)
Reply To: Status of Matisse in MyEclipse 2019 CI 4

You must be logged in to post in the forum log in