Suddenly, Spring 3 schema validation is broken?

This topic contains 1 reply, has 1 voice, and was last updated by Profile photo of David David 3 years, 3 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #326210
    Profile photo of David
    David
    Member

    I have an incredibly frustrating problem. I have workspace with several spring capabilities enabled projects in them. I have been building them in the IDE for a couple months, no problems. Suddenly this morning, they all generate the following error:

    cvc-elt.1: Cannot find the declaration of element ‘beans’.

    Huh? Eventually I created a new Java project in a new, empty workspace, and enabled spring capabilities, and let MyEclipse generate a new, empty applicationContext.xml file for me, which looks like this:

    <?xml version="1.0" encoding="UTF-8"?>
    <beans
        xmlns="http://www.springframework.org/schema/beans"
        xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
        xmlns:p="http://www.springframework.org/schema/p"
        xsi:schemaLocation="http://www.springframework.org/schema/beans http://www.springframework.org/schema/beans/spring-beans-3.0.xsd">
    
    </beans>

    Exact same problem. If I change “3.0.xsd” to “2.5.xsd”, the problem goes away, but I am using Spring 3, not 2.5. I have tried everything I could think of, including completely uninstalling and re-installing MyEclipse. No difference. I have checked and the schemas exist in:

    AppData\Local\MyEclipse for Spring\MyEclipse for Spring 10\configuration\org.eclipse.osgi\bundles\.cp\catalog-xsd

    I have tried to force the “beans” namespace to use the 3.0 schemas in MyEclipse Preferences,Project Capabilities,Spring. Just nothing works. Yet this was all working for months in the same installation on the same computer. My license is valid until March 2013, and MyEclipse recognizes it as such (no idea why that would matter).

    This is a clean install of 10.1. What do I do now?

    Dave

    #326241
    Profile photo of David
    David
    Member

    And just as suddenly, this afternoon, it works again. I hate problems like this. I made no changes to either source or configuration since it was faiing this morning.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.