SWTError MOZILLA_FIVE_HOME not set

This topic contains 12 replies, has 3 voices, and was last updated by  support-tony 7 months, 3 weeks ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #544397 Reply

    Sylvain Bonnemaison
    Participant

    Hi,
    I just update MyEclipse to 2017 CI 9 and the log show this error:

    The application is running on Arch Linux x86_64.
    How to solve this problem ?
    This problem happen with GTK2 configuration only. It work fine with GTK3 but still have problem with graphic item position with this configuration.
    Thanks

    #544409 Reply

    Sylvain Bonnemaison
    Participant

    After downloading XulRunner 1.9.2.19 and adding the following option to myeclipse.ini
    -Dorg.eclipse.swt.browser.XULRunnerPath=/opt/xulrunner-1.9.2

    the log files shows the following messages

    Creating a new workspace works fine. Re-opening the new one generate the same problem.

    #544420 Reply

    Sylvain Bonnemaison
    Participant

    I have tested with xulrunner version 1.9.2 (x86), 1.9.2.19 (x86), 2.0 (x86_64), 36.0.4 (x86_64) and 41.0.2 (x86_64) with a small difference in the result :

    There is not such behavior with Eclipse Oxygen.

    #544464 Reply

    support-swapna
    Moderator

    Sylvain,

    Sorry that you are seeing this issue. Thank you for the detailed info. We could replicate the problem at our end and the dev team is looking into it. We will keep you posted about the fix details.

    Thank you for reporting it. Apologies for inconvenience caused.

    –Swapna
    MyEclipse Support

    #545115 Reply

    Sylvain Bonnemaison
    Participant

    Any fix yet to solve the problem ?
    I can’t use the IDE since more 10 days.

    #545150 Reply

    support-tony
    Keymaster

    Silvain,

    Apologies for the delay as we tried to replicate the issue and figure a workaround.

    Fortunately, we’ve managed to see the issue with a version of Arch Linux (Anarchy linux), though only when the webkit2gtk package was not installed. Could you check that you have that package installed? If not please install it and check with GTK2.

    If you have the package installed and are still seeing the issue, could you please let us know how you are switching MyEclipse to using GTK2? You can either set the environment variable SWT_GTK3=0 before starting MyEclipse:

    SWT_GTK3=0 [path to MyEclipse install]/myeclipse

    or by adding the following two lines, above the vmargs, to myeclipse.ini:

    Also, if you continue getting the error, please let us know the windows manager/desktop environment you’re using to help us replicate.

    Either way, please let us know how you get on.

    #545261 Reply

    Sylvain Bonnemaison
    Participant

    “webkit2gtk-2.18.3-3” is already installed on the system.

    The configuration is using de vmargs in myeclipse.ini.

    The system is running Gnome 3.26.2.

    Just after, the last log file content after launching myeclipse twice. There no error and the IDE start to show and then disappear. (It runs with GTK3 with graphic item position problem)

    #545263 Reply

    support-tony
    Keymaster

    Sylvain,

    That’s disappointing. I have the same versions of webkit2gtk and gnome but don’t see an issue with GTK 2, although I do see the “no more handles” problem with GTK 3 when trying to shift views around the workbench.

    For some eclipse users who’ve seen this, sometimes using a different JDK has solved the issue. As I can’t replicate the problem, I don’t know if that will work in this case but you can try commenting out the -vm and following lines in your myeclipse.ini file, so that the system installed JDK is picked up, and this will replicate what Oxygen is picking up also (you mentioned that you don’t see the issue with Oxygen).

    If you still see the issue, could you let us know exactly when the error occurs (that is, what you are doing at the time the error occurs) and attach your myeclipse.ini file to help us replicate your setup. Also, since you don’t see it with Oxygen, could you try with a Neon install, to check if it’s a problem that got fixed in Oxygen.

    Something else occurs to me. Your opening post suggests that you were running with MyEclipse CI 8 without a problem. If this is so, you can revert to CI 8 and, hopefully, get up and running. Go to Help->Check for Updates. The resulting dialog should show no updates but will also give you the option of locking to CI 8. Just click the Lock button and then OK, to have the installation revert to CI 8.

    Please let us know how you get on and sorry for the continuing problems.

    #545578 Reply

    Sylvain Bonnemaison
    Participant

    I still have the same problem by reverting to version CI8. Even using a different JDK.

    See attached MyEclipse configuration file.

    #545579 Reply

    Sylvain Bonnemaison
    Participant

    Here is the configuration file content:

    #545580 Reply

    support-tony
    Keymaster

    Sylvain,

    Thanks for those pieces of information.

    So, to be clear, are you saying that you didn’t see the problem with CI 8 but after updating to CI 9 you did see the problem, but now, after reverting to CI 8, you still see the problem? Is that right?

    You may need to launch MyEclipse once with the -clean flag to ensure the plug-in cache is cleared after reverting to CI 8. You can do this by launching myeclipse from the command line and adding the flag, such as:

    ./myeclipse -clean

    Please also check my previous reply for suggestions about trying eclipse neon and asking for details on when the problem occurs. Additionally, you can try downloading and installing the older 2017 Stable 1.0 release (which can be downloaded from our site), which would give you a cleaner MyEclipse install without the updates (though it is a much older release).

    #545581 Reply

    Sylvain Bonnemaison
    Participant

    Running from the console :
    ./myeclipse -clean
    I get the following error message :

    with the attached error log file.

    The IDE start with a new blank workspace.

    Attachments:
    You must be logged in to view attached files.
    #545644 Reply

    support-tony
    Keymaster

    Sylvain,

    Sorry for the delay in responding (we had some internal technical issues).

    It’s disappointing that the clean didn’t help. I’ve now checked with both Gnome and Mate desktop manager in an install of Antergos (a derivative of Arch Linux). I do see the issue with Mate and did get some initial problems with Gnome (though not the problem you see). However, in the case of Mate, using GTK2 and the UseWebKitGTK property did solve the issue after a settings change though the NO_MORE_HANDLES issue did appear when trying to open an internal browser but that didn’t affect further use of the IDE. With Gnome, I didn’t see that issue at all. Installing xulrunner and setting the xulrunner path property did cause much more problems. So, I have the following questions and suggestions:

    1. Which window manager are you using (for example, Gnome, KDE, Mate)?
    2. If you aren’t able set the option on the MyEclipse dashboard to prevent its showing up in subsequent launches, add the following line to the com.genuitec.eclipse.dashboard.prefs file, found in the .metadata/.plugins/org.eclipse.core.runtime/.settings folder of your workspace:
      com.genuitec.eclipse.dashboard.uidashboard.startup=false
      With Mate, it is the attempt to open this view that is causing the NO_MORE_HANDLES issue for me.
    3. Remove the xulrunner path property from your myeclipse.ini file
    4. Start with a fresh workspace and see if the above settings work.
    5. If you still see the issue, when does it occur and how does it affect other use of the IDE?
    6. Which release of MyEclipse were you using before updating to CI 9 and started to see the problem?

    Please try to answer all questions, if the suggestions don’t help; they will help us investigate it further. However, this sort of issue is related to underlying problems with the eclipse base, so we may not be able to provide a solution until MyEclipse 2018, which will be based on eclipse Oxygen, which you wrote doesn’t show the problem.

Viewing 13 posts - 1 through 13 (of 13 total)
Reply To: SWTError MOZILLA_FIVE_HOME not set

This topic is marked as closed to new replies, however your posting capabilities still allow you to do so.