Trying to insert spaces for tabs

This topic contains 4 replies, has 2 voices, and was last updated by  support-swapna 3 months, 1 week ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #591133 Reply

    klingmachine
    Participant

    In eclipse, I have Preferences > General > Editors > Text Editors > “Insert spaces for tabs” set. Unfortunately, this seems to interfere with tabbing through snippets in CodeMix. Is there a way to do this in CodeMix instead, that won’t interfere with snippets? Or do you have any suggestions?

    #591174 Reply

    support-swapna
    Moderator

    David,

    You can change the tab size and inserting spaces for tabs settings for CodeMix editors from the User Settings preferences page here : Window > Preferences > CodeMix > User Settings. If you want to configure the properties at workspace level, then please use the Workspace Settings page under CodeMix.

    Type ‘editor’ in the filter box and modify the value for the property accordingly. Please also set editor.detectIndentation to false in User Settings.

    If settings don’t seem to be being picked up, please close and reopen the editor and/or restart eclipse (this shouldn’t be necessary but it is worth trying if there are problems). We have noticed some inconsistencies in some editors so please let us know how you get on.

    –Swapna
    Genuitec Support

    #591261 Reply

    klingmachine
    Participant

    Thanks for your help – I’m still not getting it to use spaces instead of tabs. I tried restarting eclipse with the new changes picked up. It sets the tab size to be two spaces in length, but the tab is not made up of spaces. Though this means inconsistent indentation in my code going forward, I think it’ll be worth it for having greater snippets functionality. That said, I’m attaching some screenshots, in case they can help you think of what could be going on.

    Attachments:
    You must be logged in to view attached files.
    #591266 Reply

    klingmachine
    Participant

    Oh wait I didn’t test carefully enough – it is actually working correctly!
    Maybe restarting eclipse helped, or maybe it was something else. Anyway, I’m very happy to have this working – thanks again for your help.

    #591314 Reply

    support-swapna
    Moderator

    David,

    Glad that it works. Thank you for getting back to us.
    Let us know if you see any other issues.

    –Swapna
    Genuitec Support

Viewing 5 posts - 1 through 5 (of 5 total)
Reply To: Trying to insert spaces for tabs

This topic is marked as closed to new replies, however your posting capabilities still allow you to do so.