TypeScript

This topic contains 4 replies, has 3 voices, and was last updated by  melartin 4 months, 1 week ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #593417 Reply

    melartin
    Participant

    How can I disable the “Open TypeScript Symbol Window”?

    I want pressing shft-ctrl-T to open “Java Open Type Window” as it did before you brought TypeScript to MyEclipse!

    In Key-bindings there is only one binding for shft-ctrl-T!

    Version: 2017 CI 10
    Build id: 15.0.1-20171220

    #593421 Reply

    support-swapna
    Moderator

    melartin,

    The dialog that opens when you press Ctrl+Shift+T depends on the type of the file that is in focus in the editor area or if the editor area is empty/out of focus, then it depends on the selection in the Explorer view. So unless you have a TypeSript file open or a TypeScript project selected, you should not be seeing the Open TypeScript Symbol dialog.

    Can you please clarify for us when you are seeing TypeScript Symbol dialog – do you happen to have a TS file open or in a project with has the TypeScript facet enabled (right click on the project > Properties > Project Facets) is selected in the Explorer view? If possible, please share with us a screenshot of the IDE to help us get more details including the Perspective you are in.

    The Open Type dialog can also be accessed from the Navigate menu or from the toolbar – I’m afraid there’s no way to currently disable the Open TypeScript Symbol dialog, but we’re looking into this problem – with your notes we should be able to get it to behave correctly.

    Apologies for inconvenience caused.

    –Swapna
    Genuitec Support

    #593423 Reply

    melartin
    Participant

    Hi!

    The Open TypeScript Symbol -window opens every time unless focus is on a java class file (.java)! That is, when the focus is on a explorer, javasrcipt (.js), .html, .jsp, etc. file!

    And I’m not using TypeScript at all, so there’s no ts-files and even no TypeScript compiler in my project!

    But your reply did give the correct answer already: I removed the TypeScript facet and now it works fine again!

    Thank You!

    Juha

    #593427 Reply

    Brian Fernandes
    Moderator

    Juha,

    Glad you got it sorted out. I just wanted to follow up though, you had the TypeScript facet installed in your Java project? Did you do that intentionally while testing something or you’re not sure how it got there?

    #593430 Reply

    melartin
    Participant

    I have never used TypeScript in this or any other project!

    I installed new version of MyEclipseIde (Version: 2017 CI 10). But I think the problem started earlier, maybe with the first version of 2017 CI).

Viewing 5 posts - 1 through 5 (of 5 total)
Reply To: TypeScript