Unable to load Oracle Enterprise Pack for Eclipse via SDC

This topic contains 4 replies, has 3 voices, and was last updated by Profile photo of ignaciom ignaciom 3 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #520975 Reply
    Profile photo of nlxtasy
    nlxtasy
    Participant

    running into dependency conflicts when trying to install Oracle enterprise pack. I have Myeclipse 2016. Trying to install via SDC

    #520977 Reply
    Profile photo of nlxtasy
    nlxtasy
    Participant

    Sample of errors received:

    Apr 21, 2017 10:56:52 AM com.genuitec.pulse.server.delivery.ws.promote.PromotePackageJob run
    INFO: Beginning post-promote processing of 2688-uvj-1325
    Apr 21, 2017 10:57:16 AM com.genuitec.pulse.common.delivery.model.logging.DeliveryErrorService handle
    SEVERE: Package EHIMyEclipse 2016 could not be resolved
    –Unable to resolve [EHIMyEclipse 2016] for [WINDOWS_X86]; requirements can not be satistifed
    —-Cannot complete the install because of a conflicting dependency.
    ——Software being installed: MyEclipse Enterprise Workbench 14.0.0.me201609221908 (com.genuitec.myeclipse.enterprise.workbench.feature.group 14.0.0.me201609221908)
    ——Software being installed: Oracle WebLogic Server Tools 8.5.1.201601071755 (oracle.eclipse.tools.weblogic.feature.group 8.5.1.201601071755)
    ——Only one of the following can be installed at once:
    ——–Common URI Resolver Framework 1.2.100.me201407280157 (org.eclipse.wst.common.uriresolver 1.2.100.me201407280157)
    ——–Common URI Resolver Framework 1.2.200.v201505132009 (org.eclipse.wst.common.uriresolver 1.2.200.v201505132009)
    ——Cannot satisfy dependency:
    ——–From: MyEclipse Base 14.0.0.me201609221908 (com.genuitec.myeclipse.base.feature.group 14.0.0.me201609221908)
    ——–To: com.genuitec.myeclipse.webtools.feature.group [14.0.0.me201609221908]
    ——Cannot satisfy dependency:
    ——–From: MyEclipse Enterprise Workbench 14.0.0.me201609221908 (com.genuitec.myeclipse.enterprise.workbench.feature.group 14.0.0.me201609221908)
    ——–To: com.genuitec.myeclipse.base.feature.group [14.0.0.me201609221908]
    ——Cannot satisfy dependency:
    ——–From: MyEclipse Web Tools Integration 14.0.0.me201609221908 (com.genuitec.myeclipse.webtools.feature.group 14.0.0.me201609221908)
    ——–To: org.eclipse.wst.web_ui.feature.feature.group [3.7.1.me201609221908]
    ——Cannot satisfy dependency:

    #523319 Reply
    Profile photo of nlxtasy
    nlxtasy
    Participant

    Any takers from Genuitec???

    #523323 Reply
    Profile photo of timwebb
    timwebb
    Participant

    Sorry for this post getting lost — I’ll make sure that this issue is updated here shortly with the status of the investigation and hopefully some answers too.

    Cheers and apologies!
    Tim

    #523328 Reply
    Profile photo of ignaciom
    ignaciom
    Participant

    nlxtasy,

    After a short investigation, this is what we’ve found. MyEclipse 2016 CI 7 seems to be what you are trying to promote on your Admin Console, which is based on Mars 1 (4.5.1).

    The oracle OEPE has a specific site for Mars based installs, the catch here is that it is expecting 4.5.2, so we will do a work around to get this installed on your package.

    1. Import a Third Party Library from http://download.oracle.com/otn_software/oepe/mars
    2. I’ve selected the following features:
    – GlassFish Tools
    – GlassFish Tools Source
    – Oracle WebLogic Scripting Tools
    – Oracle WebLogic Server Tools
    3. Don’t select any of the options on the dialog.
    4. Select the only “Referenced Sites” option available.
    5. Remove your old Oracle software and add the new imported Software to your MyEclipse package.
    6. Close your Admin Console, and from inside the package install location you’ll find the following path, you’ll need to find the proper guid of this package “local-storage/metavc/packages/${PACkAGE_GUID}”/package.xml we want to edit this file and add the following before the end of the root xml element:

    7. On your Delivery Hub install location we want to edit the content.jar file of the imported update site, you’ll find it at ${DeliveryHubPath}/Data Files/third-party/${LIBRARY_GUID}/15.9.0.201612160740/site/content.jar. Extract this file to find the content.xml file, and rename the content.jar to content.jar-back, open the content.xml and find the following line:

    <required namespace='osgi.bundle' name='org.eclipse.wst.common.uriresolver' range='[1.2.200,2.0.0)'/>

    Change it to:

    <required namespace='osgi.bundle' name='org.eclipse.wst.common.uriresolver' range='[1.2.100,2.0.0)'/>

    7. Reopen your admin console and try to commit and promote your package, you will not have the same exception.

    Let us know how this works for you.

    Best Regards
    Ignacio
    SDC Support

Viewing 5 posts - 1 through 5 (of 5 total)
Reply To: Unable to load Oracle Enterprise Pack for Eclipse via SDC