Undefined exploded archive location

  1. MyEclipse Archived > Application Servers and Deployment

This topic contains 9 replies, has 3 voices, and was last updated by  Loyal Water 13 years ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #280402 Reply

    John Fischer
    Member

    I have recently upgraded to MyEclipse 6.0.1 and Tomcat 6.0.14. I have enabled the Tomcat 6.x application server, but when I try to deploy my project I see an error that says:

    Undefined exploded archive location.

    I tried to go back to Tomcat 5.0.28, and receive the same message. Any ideas?

    I have another Eclipse workspace, which allows me to deploy an exploded archive to Tomcat 6.x and Tomcat 5.x, so the problem is workspace related.

    Any ideas?

    #280404 Reply

    Loyal Water
    Member

    Try restarting MyEclipse using -clean and see if the deployments works:
    http://www.myeclipseide.com/PNphpBB2+file-viewtopic-t-10280.html

    #280405 Reply

    John Fischer
    Member

    Thanks for the quick reply!

    The -clean flag didn’t seem to fix the problem.

    #280417 Reply

    Loyal Water
    Member

    In that case, you will have to switch to a brand new workspace and import your projects into the new workspace from the old worksapce. That should get you going.

    #280425 Reply

    John Fischer
    Member

    Ok, I just started with a brand new workspace, and I have the same problem. After a little more investigation, I see that my Web-root folder under the Web section of the MyEclipse preferences is wrong. It’s set to ‘Webroot’, and it should be ‘Web Content’. Where does this get set? Why can’t I change it?

    #280427 Reply

    John Fischer
    Member

    I changed the webrootdir in the .mymetadata file and I’m back on track. My project is being deployed properly.

    #280441 Reply

    Loyal Water
    Member

    Glad you got it to work. Thanks for letting me know.

    #281697 Reply

    I had the undefined archive location message when trying to explode my web application. There were two problems: I hadn’t informed well two fields.
    1) Window -> Preferences -> MyEclipse -> J2EE Project -> Web Project -> Web root folder name: [I put web which is the name of my super WEB-INF folder]
    2) Package Explorer -> [right click project] -> MyEclipse -> Web -> Web Context root: [I put the name of my application: WHATEVER] (will be the name of the folder under the tomcat’s webapps folder where the application will be exploded).

    Hope helps someone.

    #281708 Reply

    Loyal Water
    Member

    sergikirchner,
    Thanks for taking time out to post this info.

    #281709 Reply

    Loyal Water
    Member

    sergikirchner,
    Thanks for taking time out to post this info. We appreciate it.

Viewing 10 posts - 1 through 10 (of 10 total)
Reply To: Undefined exploded archive location

You must be logged in to post in the forum log in