Updating indexes never ends – maven repo

This topic contains 1 reply, has 2 voices, and was last updated by  support-swapna 1 week, 6 days ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #551407 Reply

    jeantovar
    Participant

    How can I disable the updating indexes ? It is always updating from https://repo.maven.apache.org/maven2 and never stop, if I try to cancel it, never works too

    #553086 Reply

    support-swapna
    Moderator

    jeantovar,

    Sorry that you are seeing this issue.

    You can uncheck/disable the “Download repository index updates on startup” option in Preferences (Window–>Preferences–> Maven) so that it does not attempt to download an update each time – once for a given workspace will make sure you have an updated index unless you are looking for brand new additions to the repository. Attached is the screenshot for your reference.

    If you are behind a proxy/firewall then you should configure your proxy settings here : Window > Preferences > General > Network Connections.

    Proxy information is needed for Maven to download dependencies. You can create a file called settings.xml in [user home]/.m2 directory and add in the proxy details : http://maven.apache.org/settings.html
    done, go to MyEclipse, open Window > Preferences > Maven > User Settings and ensure that ‘User Settings’ field is pointing to the right settings.xml file.

    Hope this helps. Please let us know how it works for you.

    –Swapna
    MyEclipse Support

    Attachments:
    You must be logged in to view attached files.
Viewing 2 posts - 1 through 2 (of 2 total)
Reply To: Updating indexes never ends – maven repo