Upgraded to CI 2018 and no getting this: "Error in JDT Core during AST creation

This topic contains 9 replies, has 2 voices, and was last updated by  jewellcj 4 days, 22 hours ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #598018 Reply

    jewellcj
    Participant

    I upgraded to MyEclipse CI 2018 on 08/27/18 and everything seemed fine (opeing the exact same workspace as for my prior version 2017). Now, after a recent update (I think last week), I have been getting this error:

    org.eclipse.jdt.core.manipulation
    Error
    Mon Sep 10 09:28:09 PDT 2018
    Error in JDT Core during AST creation

    java.lang.NoClassDefFoundError: org/eclipse/jdt/internal/core/search/matching/MatchLocator$AjcClosure3 (wrong name: org/eclipse/jdt/internal/core/search/matching/MatchLocator)

    I have attached the full stack trace.

    I have also attached my installation details.

    This error seems to occur consistently when I double click on a search result.It also always occurs on start up.

    I have tried looking online for a solution and I only found two possible solutions – deleting the workbench.xml in my workspace, which I did and that didn’t fix it (so I re-instated). Also I have been unable to start eclipse with a -clean option as when I do that I get an error ‘MyEclipse was unable to find its companion files’.

    Please fix this ASAP.

    Attachments:
    You must be logged in to view attached files.
    #598032 Reply

    jewellcj
    Participant

    So I was able to fix this by using teh alternate method of cleaning the workspace which is to insert ‘-clean’ at the beginning of the eclipse.ini and the issue now seems to have gone away.

    #598033 Reply

    jewellcj
    Participant

    So now I’ve started getting this whenever I perform a search and no results are displayed:

    An internal error occurred during: “Java Search”.
    org/eclipse/jdt/internal/core/hierarchy/HierarchyResolver$AjcClosure5 (wrong name: org/eclipse/jdt/internal/core/hierarchy/HierarchyResolver)

    So there is still an issue with JDT in my environment. The Error Details with stacktrace is attached.

    I’m beginning to wish I didn’t upgrade as the latest release seems to me to be buggy.

    Attachments:
    You must be logged in to view attached files.
    #598058 Reply

    support-tony
    Keymaster

    jewellcj,

    Thanks for letting us know you fixed the first problem, though hitting the second problem must be frustrating. Although we do extensive testing before release, we do occasionally see issues which appear to be highly specific to certain setups.

    I’ve tried to recreate the issue without being able to, though we don’t have your specific version of OS X immediately available to check. However it’s hard to see how that could affect this.

    A couple of things to try, to get extra information on the problem:

    1. Switch to a new workspace, import your projects from the olds workspace and then try the search again.
    2. Point the -vm setting in your eclipse.ini file to a JDK for Java 8, perhaps to the JDK that came with MyEclipse 2017, if it’s still available. You’d also have to revert your change to the osgi.requiredJavaVersion property in the ini file (I did try your change also, but still couldn’t replicate).

    Please let us know how you get on with either of these suggestions. Also, if you still see the problem, please clear the error log, reproduce the problem and then export the error log to a text file, from the Error Log view and attach it to your reply (there may be related errors in there which will help investigation). In addition, if you could let us know the exact search steps you’re taking, that would be useful.

    #598060 Reply

    support-tony
    Keymaster

    jewellcj,

    Checking this again, it seems more likely to be a corrupt installation. You may want to try running the installer again and selecting the repair option (the installer will give various options if it detects an existing install). However, another technique is to downgrade to the previous release (CI 2018.8.0) by going to Help>Check for updates and then locking to the older release, after which you can try taking the update again. If you have the latest installer, then using that to repair is the simplest option.

    It’s up to you; you may want to try the other suggestions, mentioned in my last reply, first, or try the repair first.

    Whatever you decide, please let us know how you get on.

    #598113 Reply

    jewellcj
    Participant

    Thanks for your responses – I have not yet tried any of these suggestions as I cleaned my workspace for a second time this morning and the new issue seems to have gone away, thankfully. Prior to cleaning for a second time, a JDT error was being displayed both as described above, and also (mostly) every time I tried activating code completion in the editor.

    I believe this started occurring after my most recent update of MyEclipse. I will let you know if it starts happening again.

    #598127 Reply

    support-tony
    Keymaster

    That’s very odd. The clean option should just need to be specified once, to clean up the cache.

    Thanks for letting us know and please try the suggestions if you see something like this happening again.

    #598278 Reply

    jewellcj
    Participant

    Well I’m getting issues with JDT again (I tried cleaning again to no avail).

    The now error consistently occurs whenever I use code completion (typing code and eclipse should by giving me suggestions to complete), instead I get a ‘Problem Occurred’ dialog pop up with this message:

    An internal error occurred during: “Computing additional info”.
    org.eclipse.jdt.internal.core.SearchableEnvironment.<init>(Lorg/eclipse/jdt/internal/core/JavaProject;Lorg/eclipse/jdt/core/WorkingCopyOwner;)V

    This is very frustrating and annoying. I see below that the scalaide is involved – this happens when I code-complete Java code, although the project does have Scala code also.

    Here are the Error Event details:

    eclipse.buildId=16.0.0.CI-001
    java.version=10.0.1
    java.vendor=Oracle Corporation
    BootLoader constants: OS=macosx, ARCH=x86_64, WS=cocoa, NL=en_US
    Framework arguments: -keyring /Users/cjewell/.eclipse_keyring
    Command-line arguments: -os macosx -ws cocoa -arch x86_64 -clean -keyring /Users/cjewell/.eclipse_keyring

    org.eclipse.core.jobs
    Error
    Fri Sep 14 12:56:26 PDT 2018
    An internal error occurred during: “Computing additional info”.

    java.lang.NoSuchMethodError: org.eclipse.jdt.internal.core.SearchableEnvironment.<init>(Lorg/eclipse/jdt/internal/core/JavaProject;Lorg/eclipse/jdt/core/WorkingCopyOwner;)V
    at org.scalaide.core.internal.compiler.LocateSymbol.findPath$1(LocateSymbol.scala:53)
    at org.scalaide.core.internal.compiler.LocateSymbol.findSourceFile$1(LocateSymbol.scala:70)
    at org.scalaide.core.internal.compiler.LocateSymbol.findCompilationUnit(LocateSymbol.scala:75)
    at org.scalaide.core.internal.compiler.LocateSymbol.findCompilationUnit$(LocateSymbol.scala:18)
    at org.scalaide.core.internal.compiler.ScalaPresentationCompiler.findCompilationUnit(ScalaPresentationCompiler.scala:54)
    at org.scalaide.core.internal.compiler.Scaladoc.parsedDocComment(ScalaDoc.scala:48)
    at org.scalaide.core.internal.compiler.Scaladoc.parsedDocComment$(ScalaDoc.scala:45)
    at org.scalaide.core.internal.compiler.ScalaPresentationCompiler.parsedDocComment(ScalaPresentationCompiler.scala:54)
    at org.scalaide.core.internal.compiler.ScalaPresentationCompiler.$anonfun$mkCompletionProposal$7(ScalaPresentationCompiler.scala:420)
    at org.scalaide.ui.internal.completion.ScalaCompletionProposalImpl.getAdditionalProposalInfo(ScalaCompletionProposalImpl.scala:109)
    at org.eclipse.jface.text.contentassist.AdditionalInfoController$Timer$2$1.run(AdditionalInfoController.java:113)
    at org.eclipse.core.internal.jobs.Worker.run(Worker.java:60)

    Here is the scala installation:

    org.scala-ide.scala212.feature – 4.7.1.201801021322
    org.scala-ide.sdt.feature – 4.7.1.v-2_12-201801021323-2dfe808
    org.scala-ide.sdt.weaving.feature – 4.7.1.v-2_12-201801021323-2dfe808
    org.scala-ide.zinc.feature – 4.7.1.201801021322
    org.scala.tools.eclipse.search.feature – 0.6.0.v-2_12-201801021356-5a19344
    org.scalaide.worksheet.feature – 0.8.0.v-2_12-201801021348-8ec1baf

    #598331 Reply

    support-tony
    Keymaster

    jewellcj,

    I could replicate the error when trying code completion in a scala source file. I could also replicate it with the Scala-IDE installed in a plain eclipse installation. Given the Scala-IDE version number, it looks like 4.7.x was designed for eclipse 4.7, whilst MyEclipse 2018 is built on eclipse 4.8. Checking the Scala-IDE changelog seems to confirm the support for eclipse 4.7 (Oxygen) with no mention of eclipse 4.8 (Photon).

    The issue doesn’t seem to have anything to do with MyEclipse, so there is nothing we can do, I’m afraid. However, you could report the bug via the Scala-IDE Web site.

    #598371 Reply

    jewellcj
    Participant

    Thank you for investigating this, tony. I will report the bug to the ScalaIDE folks.

Viewing 10 posts - 1 through 10 (of 10 total)
Reply To: Upgraded to CI 2018 and no getting this: "Error in JDT Core during AST creation

This topic is marked as closed to new replies, however your posting capabilities still allow you to do so.