Validation and Completion do not work out-of-the-box

This topic contains 28 replies, has 3 voices, and was last updated by  Brian Fernandes 3 months, 2 weeks ago.

Viewing 15 posts - 1 through 15 (of 29 total)
  • Author
    Posts
  • #534057

    olihd
    Participant

    I have e.g.:
    page-xy.component.ts
    page-xy.component.html
    and linked via templateUrl.

    But neither completion nor validation is working in the HTML for Angular – e.g. in ngModel=…
    Are there any prerequisites that must be fulfilled to get this working?

    #534058 Reply

    olihd
    Participant

    I assume the problem is that Angular IDE uses Terminal+ which is not able to run properly on my machine since I am using zsh shell:
    “/bin/zsh: no such option: rcfile”

    #534063 Reply

    olihd
    Participant

    Ok, I switched default terminal back to bash – now at project import everything is executed fine in Terminal+ But unfortunately there is still no validation and completion available.

    #534090 Reply

    support-swapna
    Moderator

    olihd,

    Sorry that you are seeing this issue.

    Can you please clarify if you are working with AngularJS tags (ng-*) like ng-if in the template file ? AngularIDE has very limited support for AngularJS and there is a known issue with validation and content assist not working for AngularJS tags.

    If you are seeing different issue, then please share with us a screenshot of the editor highlighting the line for which the validation and content assist are not working to help us investigate further. Also share with us the .log file located at workspace dir/.metadata/.log.

    Apologies for inconvenience caused.

    –Swapna
    MyEclipse Support

    #534157 Reply

    olihd
    Participant

    I am using Angular 4 with e.g. *ngIf= or value=”{{… – nothing is working at my machine with completion/validation.

    #534164 Reply

    support-swapna
    Moderator

    olihd,

    I see code completion and validation working, for example with the below code in the template file :

    If I press Ctrl+Space after typing *ng, I do see the proposals *ngFor,*ngIf,*ngPluralCase,*ngSwitchCase etc listed. If I press Ctrl+Space after typing *ngF, it does complete as *ngFor.

    Can you please check if the code completion and validation work in a newly created angular project using File > New > Angular Project?

    If the issue persists with the new project as well, then please share with us the project’s Node.js and NPM versions, the package.json file along with the contents of the xxx.component.html and xxx.component.ts files for further investigation. Also let us know what exact problem with validation you are seeing. It helps if you can share the screenshot.

    If the issue is with the imported project, then please send us the .zip of the project excluding the node_modules folder (right click on the project > Export > General > Archive File > expand the project folder and uncheck node_modules.) to help us replicate the problem at our end.

    –Swapna
    MyEclipse Support

    #534256 Reply

    olihd
    Participant

    It’s working for new projects – but not for existing ones. I attached the package.json – I cannot attach my sources since those should not by given to the “outside world”.

    Attachments:
    You must be logged in to view attached files.
    #534367 Reply

    support-swapna
    Moderator

    olihd,

    Thank you for sharing the package.json contents.

    Can you please let us know which tsconfig.json your project is using? Right click on the project > Properties > TypeScript and check if correct tsconfig.json is selected (tsconfig.app.json extends the tsconfig.json which is in the root of the project). If the TypeScript property page does reference the correct tsconfig.json, then please share with us the contents of the tsconfig.json.

    Also share with us @Component annotation fragment from the TS file and @NgModule fragment from the module.ts file which includes that component for further investigation.

    –Swapna
    MyEclipse Support

    #534473 Reply

    olihd
    Participant

    Attached the tsconfig, module and component.ts

    Attachments:
    You must be logged in to view attached files.
    #534489 Reply

    support-swapna
    Moderator

    olihd,

    I am afraid you cannot attach .ts files. Please change the extension to .txt and attach them.
    Sorry for inconvenience caused.

    –Swapna
    MyEclipse Support

    #534496 Reply

    olihd
    Participant

    now attached

    Attachments:
    You must be logged in to view attached files.
    #534608 Reply

    support-swapna
    Moderator

    olihd,

    Thank you for the files. I am afraid we are unable to replicate the problem at our end.

    In recent Angular projects, there are several tsconfig files in the project. The tsconfig.json in the root of the project and tsconfig.app.json in the src folder which extends this file. The tsconfig.app.json is the configuration file for the Angular app. We’re presuming you have such a project (though our support will work with a single *tsconfig file* as well)

    For IDE support to work, the tsconfig.app.json should be selected, while the file you shared looks like the base, tsconfig.json file.

    Could you please confirm which file is selected on the TypeScript property page (Right click on the project > Properties > TypeScript)? If tsconfig.json is selected, then use the browse button to select tsconfig.app.json and check if the content assist works.

    If you are still seeing issues, then do share the project relative paths of both the tsconfig files along with the contents of the tsconfig.app.json file for further investigation.

    Apologies for inconvenience caused.

    –Swapna
    MyEclipse Support

    #534694 Reply

    olihd
    Participant

    I tried a new import – project chooses correctly “tsconfig.app.json”. Without success.

    I attached the tsconfig.app.json also.

    I also attached a screenshot of our project structure. Hope this is solved soon since I paid money and are still looking forward to using it 🙂

    Attachments:
    You must be logged in to view attached files.
    #534838 Reply

    Brian Fernandes
    Moderator

    oilhd,

    We’ll definitely fix it – as soon as we figure out what the problem is (which we are determined to!) From everything you have shared so far, there doesn’t seem to be a reason why content assist and validation would not work.

    The last suggestion I have, is for you to try a new workspace, if you haven’t tried that already. Create a new workspace, import the project into it and see if there’s any change in behaviour. If not, please send us the log from this workspace – you can find it at [workspace_location]/.metadata/.log
    This should contain errors that might explain what’s going wrong with this project.

    #535136 Reply

    olihd
    Participant

    Ok – I attached it. Completion/validation is also not working there.

    Attachments:
    You must be logged in to view attached files.
Viewing 15 posts - 1 through 15 (of 29 total)

You must be logged in to reply to this topic.