VSS AND MYECLIPSE

Home Forums Archived Forums MyEclipse Archived General VSS AND MYECLIPSE

This topic contains 10 replies, has 5 voices, and was last updated by Profile photo of support-swapna support-swapna 3 years, 4 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #269858
    Profile photo of Aditya04
    Aditya04
    Member

    I have Myeclipse 5.1 and I want it to configure with Microsoft VisualSourceSafe 6.0 .How do i do that and what do i need to have.What plugins and how do we extract those plugins into Myeclipse IDE.

    YOUR PROMPT REPLY WILL BE APPRECIATED…

    tHANKS,
    Meena

    #269864
    Profile photo of Aditya04
    Aditya04
    Member

    With coontinution..I don’t want to use CVS …i want VSS

    Please reply…i know you can’t speak on VSS but please let me know..what plugins and all i can use to make my development area work….

    #270066
    Profile photo of Scott Anderson
    Scott Anderson
    Participant

    There is a VSS plugin for Eclipse here: http://sourceforge.net/projects/vssplugin/

    That should get you the connection to SourceSafe that you’re looking for.

    #321882

    How do I install vss for ME10.0? I put an unzipped vssplugin folder into dropIn folder in ME10 but it did not work.

    Joe

    #321978
    Profile photo of support-swapna
    support-swapna
    Moderator

    joehuangathome,

    Sorry that you are seeing this issue.

    Can you answer some more questions for us ?

    1) Can you share your Build ID from Help > About MyEclipse Enterprise Workbench > Build ID ? Also share your OS and version details.

    2) Is your MyEclipse installation a 32 bit or 64 bit one ?

    3) Can you clarify if the plugin version is compatible with Eclipse 3.7 which is the base Eclipse version for MyEclipse 10 ? Also share the link from where you have downloaded the plugin.

    4) Please make sure you copy the relevant plugins/features to [MyEclipse directory]/dropins. Make sure you have folder named Plugins and Features under dropins(if not already present, please create these folders). You need to copy plugins and features to the relevant folder. Also recheck if you see the plugin in the installed plugins list at Help > About MyEclipse Enterprise Workbench > Installation Details > Plugins.

    5) Also let us know what exact issue you are seeing after dropping the unzipped file into the Dropins directory.

    6) There might be issues in getting the VSS plugin work in Eclipse 3.7. Take a look at this link :
    http://sourceforge.net/tracker/index.php?func=detail&aid=3340114&group_id=54205&atid=473011

    #322018

    @support-swapna wrote:

    joehuangathome,

    Sorry that you are seeing this issue.

    Can you answer some more questions for us ?

    1) Can you share your Build ID from Help > About MyEclipse Enterprise Workbench > Build ID ? Also share your OS and version details.
    Build id: 10.0-20111028. OS: XP Professional2) Is your MyEclipse installation a 32 bit or 64 bit one ?
    323) Can you clarify if the plugin version is compatible with Eclipse 3.7 which is the base Eclipse version for MyEclipse 10 ? Also share the link from where you have downloaded the plugin.
    I used to have base Eclipse but I was not able to find Eclipse3.7 on my machine after downloading MyEclipse104) Please make sure you copy the relevant plugins/features to [MyEclipse directory]/dropins. Make sure you have folder named Plugins and Features under dropins(if not already present, please create these folders). You need to copy plugins and features to the relevant folder. Also recheck if you see the plugin in the installed plugins list at Help > About MyEclipse Enterprise Workbench > Installation Details > Plugins.
    I rechecked but did not find vss under Plugins tab. And I got a ‘Fetching Elements’ error.
    5) Also let us know what exact issue you are seeing after dropping the unzipped file into the Dropins directory.
    The vss menu used to appear on my previous MyEclipse version failed to appear in MyEclipse 10
    6) There might be issues in getting the VSS plugin work in Eclipse 3.7. Take a look at this link :
    http://sourceforge.net/tracker/index.php?func=detail&aid=3340114&group_id=54205&atid=473011

    #322040
    Profile photo of support-swapna
    support-swapna
    Moderator

    joehuangathome,

    1) Did you install MyEclipse 10 on top of base Eclipse 3.7 using the update site ?

    2) If you can get the version of VSS which works in Eclipse 3.7 then try it on MyEclipse 10. If you have issues getting vss plugin work on Eclipse 3.7 then post on Eclipse forums for better support.

    #322067

    @support-swapna wrote:

    joehuangathome,

    1) Did you install MyEclipse 10 on top of base Eclipse 3.7 using the update site ?
    No. I downloaded myeclipse-10.0-offline-installer-windows.exe
    2) If you can get the version of VSS which works in Eclipse 3.7 then try it on MyEclipse 10. If you have issues getting vss plugin work on Eclipse 3.7 then post on Eclipse forums for better support.

    I used to drop vss plug in Eclipse3.X plugin folders. But I cannot find Eclipse3.7 on my PC. Is 3.7 a must?

    Thanks,

    Joe

    #322146
    Profile photo of AtmelCorp
    AtmelCorp
    Member

    Hi,

    I am also interested in a VSS plugin which work fine with MyEclipse10 . Do you get some result about that ?

    Thanks for your Help

    #322161

    @AtmelCorp wrote:

    Hi,

    I am also interested in a VSS plugin which work fine with MyEclipse10 . Do you get some result about that ?

    Thanks for your Help

    AtmelCorp,
    I have found why it did not work before. Yes, using MyEclipse10’s /dropins folder IS the correct approach. VSS has been too old that nobody cares about making an update site for it at sourceforge.com. The bad thing about the org.vssplugin_1.6.1 zip file is that, when unzipped, it will create a redundant folder structure like this:
    org.vssplugin_1.6.1\org.vssplugin_1.6.1
    So what you need to do is to only copy the inner folder(do not drop the zip directly into your ME dropins folder) and paste the copied folder into MyEclipse10.0’s dropins folder and it will work like a charm!!

    Please let me know if it still does not work for you.

    Joe

    #322221
    Profile photo of support-swapna
    support-swapna
    Moderator

    joehuangathome,

    Thank you for posting the steps to install VSS to MyEclipse. It will certainly help other users.

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.