Web project. Runs on Tomcat but not Jboss! [Closed]

  1. MyEclipse Archived
  2.  > 
  3. Web Development (HTML, CSS, etc.)
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #222362 Reply


    ME 383 on 3.0.1 on WinXP sp2.
    Test j2ee servers: Tomcat 5 versus Jboss 4.01
    ME Web project, containing ONE file, either index.html or index.jsp.
    Deploy: To Tomcat: Ok. To JBoss: OK.
    Run: On Tomcat via: http://localhost/1webB/index.jsp, OK.
    Run: On Jboss via http://localhost:8080/1webB/index.jsp *ERROR 404*.

    Both servers are up and running other previous deployed apps ok.

    Also a mention, just by calling the root, even on the Tomcat it gives me the directory listing, with the 1 index.jsp, and runs after clicking on it.

    here is the simple web.xml:

    <?xml version="1.0" encoding="UTF-8"?>
    <web-app version="2.4" 

    After going nuts with jboss on a ejb/war project, I finally reduced it to this simple scenario. What the heck am I missing?


    #222364 Reply


    Just tested on JBoss 3.26, also the same as 4.0.1. FAILS with same error.

    #222366 Reply


    And here is the simple war file, as deployed on jboss 3.26.


    #222392 Reply

    Scott Anderson


    Are there any errors in the JBoss console? If the application didn’t deploy (or did) there should be a message. Also, you’re using a version 2.4 web project. Can you create a duplicat project, but with version 2.3 (specified in the project creation wizard) and see if that behaves differently? I’m unsure if JBoss 4 supports 2.4 and I”m positive that 3.26 does not.

    #222426 Reply


    There are no errors, and as said, it deploys properly. (The console message is the same as any good deployment.)
    Now, listen to this… These projects’ root name begin with a digit,1. (1webb, 1web, etc.) I tried deleting the web.xml and deploying, and the jboss deployer on the console logged, “web.xml not found, using default settings for webb”. I noticed that the message dropped the ‘1’ from the name. Lo and behold when I try the url …./webb (and not …./1webb) it works! Not only this, but even with a web.xml, even inside the war that begins with a 1, it works with a url sans the 1. Unlike Tomcat which works only with the ‘1’! -For the SAME war-.

    I didn’t try all combinations of research on this, but maybe someone at ME should do some testing and write up a faq.
    As far as I am concerned, you can close out this issue, but others might save quite a bit of anxiety with this little tidbit.

    #222433 Reply

    Scott Anderson


    Thanks for letting us know. It appears that JBoss simply does not like contexts that begin with a digit. Peculiar to say the least.

Viewing 6 posts - 1 through 6 (of 6 total)
Reply To: Web project. Runs on Tomcat but not Jboss! [Closed]

You must be logged in to post in the forum log in