[Workaround] XML Validation failing with Schema (XSD)

Home Forums MyEclipse IDE Java EE Development (EJB, JSP, Struts, XDoclet, etc.) [Workaround] XML Validation failing with Schema (XSD)

This topic contains 1 reply, has 2 voices, and was last updated by Profile photo of WriteExpress WriteExpress 8 years ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #238194
    Profile photo of Riyad Kalla
    Riyad Kalla
    Member

    This message has not been recovered.

    #272891
    Profile photo of WriteExpress
    WriteExpress
    Member

    I also have validation errors both the MyEclipseIDE Version 5.5.1 GA and the latest MyEclipseIDE Full Stack Installer. Eclipse error markers appear to the left of every xmlns declaration (see code below).

    I can make them disappear if I click MyEclipse > Preferences > MyEclipse > Validation and click “Allow projects to override these preference settings” and uncheck all the Build Validator checkboxes.

    The odd thing is that I don’t get the errors in my local copy of JBoss-Seam-2.0.0.BETA1 examples–especially the bookings example. I can copy the code below into one of an .xml file in that project and I don’t get the validation errors.

    Is my problem project specific and how can I fix it correctly?

    Here is my header:

    <!DOCTYPE composition PUBLIC “-//W3C//DTD XHTML 1.0 Transitional//EN”
    “http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd”>
    <ui:composition xmlns=”http://www.w3.org/1999/xhtml”
    xmlns:c=”http://java.sun.com/jstl/core”
    xmlns:s=”http://jboss.com/products/seam/taglib”
    xmlns:ui=”http://java.sun.com/jsf/facelets”
    xmlns:f=”http://java.sun.com/jsf/core”
    xmlns:h=”http://java.sun.com/jsf/html”>

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.