Angular IDE does not use project local TSLint version

Tagged: 

This topic contains 3 replies, has 2 voices, and was last updated by  support-swapna 1 week, 4 days ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #554176

    Anthony
    Participant

    I am trying to set a project-specific TSLint version for my project since the “embedded” one in Angular IDE is not recent enough for new rules.

    When I run ‘ng lint’, I have no issues. Everything is fine and I have no lint issues.
    However, Angular IDE is not recognizing the newer rules in my TSLint version (5.9.1).

    In my project properties, I have the following options set under the “TypeScript” category:
    Enable TSLint validation if tslint.json is present (checked)
    TSLint version: Project Local (5.9.1)

    However, when I hover over a new rule, I see (for example):

    Implementation of rule “newline-per-chained-call” cannot be found. Try running ‘npm install’, upgrading TSLint (currently running with embedded TSLint 5.6.0) and/or ensuring that you have all necessary custom rules installed. If TSLint was recently upgraded, you may have old rules configured which need to be cleaned up.

    So Angular seems to be using the embedded TSLint version despite my settings.

    Is Angular IDE not capable of using TSLint versions newer than what’s embedded, or am I missing something else?

    #555096 Reply

    support-swapna
    Moderator

    Anthony,

    Sorry that you are seeing this issue. I tried to replicate the problem at my end but I see the validation error for the new rule only when I set the TSLint to a different version other than Project Local 5.9.1. Project Local 5.9.1 setting works for me.

    Can you please clarify if you have rebuild the project after setting the TSLint version to Project Local 5.9.1? If the rebuild does not work, then please restart the IDE, rebuild the project and check if it works.

    If none of the suggestions work, then please share with us the package.json and the tslint.json of the project to help us investigate further.

    Apologies for inconvenience caused. Please let us know how it works for you.

    –Swapna
    MyEclipse Support

    #555112 Reply

    Anthony
    Participant

    Thanks for your quick reply.

    I have tried combinations of rebuilding the project, restarting the IDE, turning off linting, and changing the linting version back and forth, all without success.

    I’ve attached the requested files as .txt files.

    Attachments:
    You must be logged in to view attached files.
    #555371 Reply

    support-swapna
    Moderator

    Anthony,

    Thank you for the files. We could replicate the problem at our end but not consistently. While we continue to investigate it, can you please import the project to a new workspace and check if you still see the problem?

    We just released CI 11. If you have not yet updated to CI 11, then please go to Help > Check for Updates and update.

    Please let us know how it works for you.

    –Swapna
    MyEclipse Support

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.