Angular IDE issue: Angular CLI is not installed properly

This topic contains 5 replies, has 2 voices, and was last updated by  Jidehem 1 year, 2 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #598645 Reply

    Jidehem
    Participant

    Since latest update of angular-ide (0.9.44), we are not anymore able to launch the Angular CLI server.
    It worked well up to version 0.9.39 (included).
    Running manually ng serve works perfectly, thus it seems it’s an angular-ide issue.
    It seems that it doesn’t use the correct base path (see ng-location.png).

    Is it possible to force use of version 0.9.39 to still be able to work ?

    Attachments:
    You must be logged in to view attached files.
    #598653 Reply

    support-tony
    Keymaster

    Jidehem,

    Sorry you’re seeing this behavior. We’ve been unable to replicate this so far but we did have a report of a similar problem a few months ago. For that problem, the user resolved it by starting eclipse with a fresh workspace and, presumably, importing the project from the old workspace. Unfortunately, that developer didn’t get back to us with further information so we weren’t able to track down the initial cause of the problem. It may be that the workspace wasn’t used just as an eclipse workspace and contained some files that may have come into play during the server start.

    Please try a fresh workspace and let us know how you get on. If that works, perhaps you could get back to us with more details on your workspace folder? In any case, please let us know how you get on.

    #598656 Reply

    Jidehem
    Participant

    Tony,

    I tried to use a new workspace, import the project, run as Angular Web Application : the exact same error occurs. Thus the workspace corruption seems not to be the cause here.

    Then I tried on the old workspace, but deleted the .settings folder. This fixed the issue.

    #598661 Reply

    Jidehem
    Participant

    Complement: another cause is using a resource filter on node_modules folder to exclude all of its content (as explained in https://stackoverflow.com/questions/2272237/how-to-exclude-specific-folders-or-files-from-validation-in-eclipse).
    We did this because the node_modules folder gets validated and shows thousands of errors.
    Is there a working simple way to prevent node_modules content from being validated ?

    #598704 Reply

    support-tony
    Keymaster

    Jidehem,

    I’m glad you managed to sort out the problem. I don’t suppose you have a copy of the .settings folder that you could zip up and send us? We’d like to figure out what caused this strange behavior.

    As far as validation goes, you seem to have discovered the way we keep the node_modules folder from being validated. However, the setting for that should already be there, so it’s odd that this wasn’t the case but may be related to your deleting the .settings folder; it would have been recreated but may not have been done correctly.

    For reference, the relevant page is not only in Window>Preferences>Validation (for the whole workspace) but also in the project properties at the Validation page; for project specific settings, the “Enable project specific settings” option needs to be checked. In both cases, use the “JavaScript Syntax Validator – JSjet” settings button. The default settings are as shown in the attached screenshot, showing that the node_modules folder is in the exclude group. Note that clicking the Restore Defaults button should give you the default setting.

    Thanks for letting us know you fixed the problem and I hope this explains the validation settings. If you still have the .settings folder that caused the problems (perhaps in the Recycle Bin or a backup), please send it to us if you can (attach it to a reply or send it via private message).

    Attachments:
    You must be logged in to view attached files.
    #598712 Reply

    Jidehem
    Participant

    For the record, I had to disable the XML Validator in addition to the JavascriptValidation to make all errors on node_modules disappear.

    (I don’t have anymore the .settings that caused problem.)

Viewing 6 posts - 1 through 6 (of 6 total)
Reply To: Angular IDE issue: Angular CLI is not installed properly

You must be logged in to post in the forum log in