Angular IDE not working properly after updating to CodeMix

This topic contains 47 replies, has 10 voices, and was last updated by  aaronlonin 8 months ago.

Viewing 15 posts - 16 through 30 (of 48 total)
  • Author
    Posts
  • #599770 Reply

    Brian Fernandes
    Moderator

    Alejandra,

    Based on the log you sent in, a very basic sanity check – can you confirm that CodeMix is enabled? You will find this setting on Window > Preferences > CodeMix page, a checkbox saying, “Temporarily disable CodeMix functionality”.

    #599772 Reply

    Brian Fernandes
    Moderator

    Alejandra,

    I forgot to ask earlier – have you installed as Adminstrator? Also, what is your install location for Angular IDE?

    This is a really weird situation so we’ve upped the level of logging. You can apply this fix in the same way as the last fix, but this time there’s no engine replacement, for clarity, I’m repeating the instructions here (cecereslafan, will follow up with you separately)

    1) Shut down Angular IDE
    2) Delete your [user_home]/.codemix/engine folder if it exists
    3) In your Angular IDE installation directory, under the plugins folder, find the following resources and delete them.
    com.genuitec.eclipse.code.ui_2.0.0.201809272129.jar
    com.genuitec.eclipse.code.core_2.0.0.201809271825.jar
    4) Download: http://downloads.genuitec.com/downloads/partners/misc/AngularIDE-2018.9.25a-fix3.zip
    5) Unzip the zip into your plugins folder from where you earlier deleted the resources.
    7) Edit your angularide.ini file and add
    -clean
    to the first line of the file, on a line by itself.
    8) Start Angular IDE.
    9) Wait for about 5 minutes before shutting down the IDE and then please send us the log file. Hopefully this log will now have enough information to tell us what is going wrong.

    #599775 Reply

    alopezfdez
    Participant

    Hello,

    So CodeMix is running, it was indeed disable, after ticking the box I was able to start the engine up, thanks a lot for your help!
    The engine started and I was able to build a new project, the only issue I am having is on Terminal+ I tried to run my projects with ng serve and I got an error:

    $ ng serve
    C:\Users\alejandra_lopez\Workspaces\Angular IDE 2017 CI\elasticsearch-dashboard\node_modules\rx\dist\rx.js:77
    throw e;
    ^

    TypeError: Cannot read property ‘run’ of undefined
    at AnonymousObserver.getRunningInstallations.subscribe.installations [as _onNext] (C:\Users\alejandra_lopez\Workspaces\Angular IDE 2017 CI\elasticsearch-dashboard\node_module
    s\angular-ide\addon\commands\serve.js:415:39)
    at AnonymousObserver.Rx.AnonymousObserver.AnonymousObserver.next (C:\Users\alejandra_lopez\Workspaces\Angular IDE 2017 CI\elasticsearch-dashboard\node_modules\rx\dist\rx.js:1
    828:12)
    at AnonymousObserver.Rx.internals.AbstractObserver.AbstractObserver.onNext (C:\Users\alejandra_lopez\Workspaces\Angular IDE 2017 CI\elasticsearch-dashboard\node_modules\rx\di
    st\rx.js:1762:31)
    at AnonymousObserver.tryCatcher (C:\Users\alejandra_lopez\Workspaces\Angular IDE 2017 CI\elasticsearch-dashboard\node_modules\rx\dist\rx.js:63:31)
    at AutoDetachObserverPrototype.next (C:\Users\alejandra_lopez\Workspaces\Angular IDE 2017 CI\elasticsearch-dashboard\node_modules\rx\dist\rx.js:5883:51)
    at AutoDetachObserver.Rx.internals.AbstractObserver.AbstractObserver.onNext (C:\Users\alejandra_lopez\Workspaces\Angular IDE 2017 CI\elasticsearch-dashboard\node_modules\rx\d
    ist\rx.js:1762:31)
    at InnerObserver.next (C:\Users\alejandra_lopez\Workspaces\Angular IDE 2017 CI\elasticsearch-dashboard\node_modules\rx\dist\rx.js:5409:14)
    at InnerObserver.Rx.internals.AbstractObserver.AbstractObserver.onNext (C:\Users\alejandra_lopez\Workspaces\Angular IDE 2017 CI\elasticsearch-dashboard\node_modules\rx\dist\r
    x.js:1762:31)
    at InnerObserver.tryCatcher (C:\Users\alejandra_lopez\Workspaces\Angular IDE 2017 CI\elasticsearch-dashboard\node_modules\rx\dist\rx.js:63:31)
    at AutoDetachObserverPrototype.next (C:\Users\alejandra_lopez\Workspaces\Angular IDE 2017 CI\elasticsearch-dashboard\node_modules\rx\dist\rx.js:5883:51)
    at AutoDetachObserver.Rx.internals.AbstractObserver.AbstractObserver.onNext (C:\Users\alejandra_lopez\Workspaces\Angular IDE 2017 CI\elasticsearch-dashboard\node_modules\rx\d
    ist\rx.js:1762:31)
    at AnonymousObserver.readFile.subscribe [as _onNext] (C:\Users\alejandra_lopez\Workspaces\Angular IDE 2017 CI\elasticsearch-dashboard\node_modules\angular-ide\lib\utils.js:18
    2:22)
    at AnonymousObserver.Rx.AnonymousObserver.AnonymousObserver.next (C:\Users\alejandra_lopez\Workspaces\Angular IDE 2017 CI\elasticsearch-dashboard\node_modules\rx\dist\rx.js:1
    828:12)
    at AnonymousObserver.Rx.internals.AbstractObserver.AbstractObserver.onNext (C:\Users\alejandra_lopez\Workspaces\Angular IDE 2017 CI\elasticsearch-dashboard\node_modules\rx\di
    st\rx.js:1762:31)
    at AnonymousObserver.tryCatcher (C:\Users\alejandra_lopez\Workspaces\Angular IDE 2017 CI\elasticsearch-dashboard\node_modules\rx\dist\rx.js:63:31)
    at AutoDetachObserverPrototype.next (C:\Users\alejandra_lopez\Workspaces\Angular IDE 2017 CI\elasticsearch-dashboard\node_modules\rx\dist\rx.js:5883:51)

    I don’t know if the log would be of any use but i am attaching it.

    Best,
    Alejandra

    Attachments:
    You must be logged in to view attached files.
    #599779 Reply

    Brian Fernandes
    Moderator

    Alejandra,

    Great! Do you remember disabling CodeMix yourself earlier – perhaps you had it installed before the recent update?

    As far as the error is concerned, please open a Terminal+ console for your project. Let us have the output of the following commands

    which ng
    which ngide
    ng --version (let us know what version is reported)
    Finally, you could try updating the angular-ide module using
    npm update angular-ide
    Let us know if the update fixes your problems.

    Thanks!

    #599786 Reply

    Salvador Cabrera
    Participant

    Hi Alejandra,

    We have released a new version of angular-ide npm package with improved debugging, please install this latest version so we can have a better diagnostic of your problem.

    Here are the instructions:

    – Open up a new Terminal+ tab for your project.
    – Install the latest angular-ide node module test version by running npm i -D angular-ide@next.
    – Create a file named angular-ide.debug in the project root directory. (This will enable debug mode)
    – Run ng serve.

    Please attach the output generated by ng serve,

    Best regards.

    #599807 Reply

    alopezfdez
    Participant

    Hello again,

    No, I didn’t have codemix before, just on thursday/friday I installed the update, but since it wasn’t working I tried reverting to the previous state and then I tried updating again but that didn’t seem to help either.

    About the error, this was the output:

    $ which ng
    C:\Users\alejandra_lopez\Workspaces\Angular IDE 2017 CI\lbd-production\node_modules\.bin\ng.CMD

    $ which ngide
    C:\Users\alejandra_lopez\Workspaces\Angular IDE 2017 CI\lbd-production\node_modules\.bin\ngide.CMD

    $ ng –version

    _ _ ____ _ ___
    / \ _ __ __ _ _ _| | __ _ _ __ / ___| | |_ _|
    / △ \ | ‘_ \ / _| | | | |/ _ | ‘__| | | | | | |
    / ___ \| | | | (_| | |_| | | (_| | | | |___| |___ | |
    /_/ \_\_| |_|\__, |\__,_|_|\__,_|_| \____|_____|___|
    |___/

    Angular CLI: 1.7.4
    Node: 9.7.0
    OS: win32 x64
    Angular: 4.4.7
    … common, compiler, compiler-cli, core, forms, http
    … platform-browser, platform-browser-dynamic, router

    Angular CLI: 1.7.4
    Node: 9.7.0
    OS: win32 x64
    Angular: 4.4.7
    … common, compiler, compiler-cli, core, forms, http
    … platform-browser, platform-browser-dynamic, router
    … tsc-wrapped

    @angular/cdk: 6.2.1
    @angular/cli: 1.7.4
    @angular/material: 6.2.1
    @angular-devkit/build-optimizer: 0.3.2
    @angular-devkit/core: 0.3.2
    @angular-devkit/schematics: 0.3.2
    @ngtools/json-schema: 1.2.0
    @ngtools/webpack: 1.10.2
    @schematics/angular: 0.3.2
    @schematics/package-update: 0.3.2
    typescript: 2.2.2
    webpack: 3.11.0

    After, I ran the command npm i -D angular-ide@next and I created the debug file. Finally I ran the ng serve but it is still not working I attached the output.

    Best regards,
    Alejandra

    Attachments:
    You must be logged in to view attached files.
    #599816 Reply

    Salvador Cabrera
    Participant

    Hi Alejandra,

    Thanks for the output, i have pushed a new package version that should help to solve your problem.

    You just need to:
    – Open a new Terminal+ tab for your project.
    – Running npm rm -D angular-ide && npm i -D angular-ide@next

    Running ng serve again should bring up your application without errors.

    Best regards,
    Sal

    #599828 Reply

    alopezfdez
    Participant

    Thanks for that! It is up and running without errors.
    Best,
    Alejandra

    #599876 Reply

    cereslafan
    Participant

    Hi.

    I’m glad Alejandra has fixed her problem with the software. In my case the problem is still present, even though I have followed the instructions that they have proposed. The software presents the same faults that Alejandra has.

    Following his recommendations i did the following:
    1. Delete the [user_home]/.codemix/engine folder.
    2. Replace the corresponding plugins with the FIX3 -> AngularIDE-2018.9.25a-fix3.zip
    com.genuitec.eclipse.code.ui_2.0.0.201809272129.jar
    com.genuitec.eclipse.code.core_2.0.0.201809271825.jar
    3. Edit the file angularide.ini and add -clean.
    4. Run as administrator Angular IDE.

    The problems continued, but now the error is shown:

    ‘Initializing CodeMix Engine’ has encountered problem.
    An internal error occurred during: “Initializing CodeMix Engine”.
    Unresolved compilation problems:
    The method log(String, int) is undefined for the type CodeService
    The method log(String, int) is undefined for the type CodeService
    The method log(String, int) is undefined for the type CodeService

    On Help > CodeMix Extensions > “CodeMix is currently not connected”
    On Window > Preferences > CodeMix The checkbox “Temporarily disable CodeMix funcionality” is unchecked.
    The folder [user_home]/.codemix/engine it does not regenerate.

    Attach my log.

    #599877 Reply

    cereslafan
    Participant

    Attach my log.

    Attachments:
    You must be logged in to view attached files.
    #599888 Reply

    ignaciom
    Moderator

    Hey,

    Thanks for the log and the shared details, right now we are looking on it. Will get back to you shortly.

    Best Regards
    Ignacio

    #599895 Reply

    ignaciom
    Moderator

    cereslafan,

    I’m now attaching you a re-exported version of the patch, just to double check that you have the right files, please follow the same steps as before.

    1) Shut down Angular IDE
    2) Delete your [user_home]/.codemix/engine folder if it exists
    3) In your Angular IDE installation directory, under the plugins folder, find the following resources and delete them.
    com.genuitec.eclipse.code.ui_2.0.0.201809272129.jar
    com.genuitec.eclipse.code.core_2.0.0.201809271825.jar
    4) Download: the attached file
    5) Unzip the zip into your plugins folder from where you earlier deleted the resources.
    7) Edit your angularide.ini file and add
    -clean
    to the first line of the file, on a line by itself.
    8) Start Angular IDE.
    9) Wait for about 5 minutes before shutting down the IDE and then please send us the log file.

    As an additional information could you share the following directory as a zip archive? C:\Users\Luis Fdo Aguilar\AppData\Local\Angular IDE\p2\org.eclipse.equinox.p2.engine\profileRegistry

    Let us know how it runs this time.

    Best Regards
    Ignacio

    • This reply was modified 1 year, 2 months ago by  ignaciom.
    #599896 Reply

    ignaciom
    Moderator

    In here you’ll find the patch archive file. 🙃

    Cheers
    Ignacio

    #599900 Reply

    cereslafan
    Participant

    ¿Download: the attached file? I do not see the attachment.

    #599903 Reply

    ignaciom
    Moderator

    Hey, somehow the forum system did not like the size of my attachment, here you can find the patch: http://downloads.genuitec.com/downloads/partners/misc/AngularIDE-2018.9.25a-fix4.zip

    Ignacio

Viewing 15 posts - 16 through 30 (of 48 total)
Reply To: Angular IDE not working properly after updating to CodeMix

You must be logged in to post in the forum log in