Angular IDE – problem starting 'Angular CLI' server

  1. CodeMix & Angular IDE > Webclipse 1.x Help

This topic contains 49 replies, has 14 voices, and was last updated by  support-tony 1 year, 10 months ago.

Viewing 15 posts - 1 through 15 (of 50 total)
  • Author
    Posts
  • #508681 Reply

    alx90
    Participant

    Hello,
    I just installed AngularIDE standalone package few days ago and so far I’m very happy with it, anyway I’m facing some troubles when starting my Angular2 app using the embedded ‘Angular CLI’ server (Run As -> Angular Web Application).
    The app I’m working on has been generated with angular-cli 1.0.0-beta.24 and then successfully imported into AngularIDE as ‘Angular 2 Project’, no errors or problems are shown and actually the app works absolutely fine running ‘ng serve’ using both the standard ubuntu system terminal and the embedded ‘Terminal+’.

    Anyway I’d like to start the app using the embedded ‘Angular CLI’ server (in order to use javascript debug) but here is what happens:
    1. I Right click the project -> Run As -> Angular Web Application
    2. ng serve command is launched and the app starts correctly and shows fine at http://localhost:4200/, here is Terminal+ output

    3. Server remains in ‘Starting’ status and progress bar stays stuck waiting for the server to be completely started
    4. After few minutes the following error message is displayed:

      ‘Launching myApp on Angular CLI server’ has encountered a problem.
      Timed out waiting for server to start. Please ensure you have angular-ide NPM plugin installed in your project. Run npm install –save-dev angular-ide.

    Obviously I executed the suggested command from the project root and ‘angular-ide’ npm package is now installed, but nothing seems to change.
    Here is the output for the command ‘npm list angular-ide’ executed from project root folder:

    Could you please help me to make this work? It would be great to use typescript debug directly from Angular IDE,

    Thanks in advance, Alessio

    #508684 Reply

    alx90
    Participant

    Sorry, just to be precise, in the ‘ng serve’ command the environment is ‘dev’ 🙂

    #509015 Reply

    Salvador Cabrera
    Participant

    Hi!

    We’re having a hard time trying to replicate this issue with no luck, do you have any extra info that could be relevant?
    What about generating a new Angular 2 project using the wizard ? (File>New>Angular 2 Project.)
    Do you get the same behavior ?

    Best regards,
    Sal.

    #509120 Reply

    alx90
    Participant

    Hi and thanks for your reply,

    I generated a couple new Project using ‘File>New>Angular 2 Project’ using 2 different angula-cli versions: 1.0.0-beta.24 and 1.0.0-beta.22-1.
    I tried to run every project both in development and in production mode, anyway I try I keep getting the same behavior:

    1. ng serve is launched and the app displays fine in the browser, here is an example terminal+ output:

    2. Progress view stays stuck at 73% showing this message:
    Starting testApp on Angular CLI Server…
    Preparing launch delegate…: waiting for server to start…

    I can’t debug the app if i put any breakpoint in typescript files from AngularIDE. In particular I tried to put a breakpoint in app.component.ts from AngularIDE and debug does not work, same breakpoint placed from chrome browser dev console works fine.

    3. After few minutes Angular IDE shows this error
    Starting testApp on Angular CLI Server…
    has encountered a problem
    Timed out waiting for server to start. Please ensure you have angular-ide NPM plugin installed in your project. Run npm install –save-dev angular-ide.

    ‘npm list angular-ide’ output always confirms angular-ide npm package is installed:

    I’m running ubuntu 14.04 LTS, system is up to date and so is Angular-IDE.
    IDE is installed in my home directory and started with my own user.
    I’m thinking about reinstalling the IDE and see what happens, anyway I’d be glad to avoid that because I already configured all my preferences and plugins in it.
    For the installation I followed the standard command line guide using these commands:

    Let me know if any other specific information could be helpful.
    Regards, Alessio

    #509154 Reply

    Salvador Cabrera
    Participant

    Hi Alessio!

    Thanks for the info! We have successfuly replicated this issue and working on fix for this.
    For the meantime, as a workaround, you can do this:

    1.- Make sure AngularIDE is not running.
    2.- Please remove the “.webclipse/angular-ide.locations” file.
    e.g. $ rm ~/.webclipse/angular-ide.locations

    This should make the issue disappear next time you run AngularIDE.

    Best regards,
    Sal

    #509229 Reply

    alx90
    Participant

    Hi Sal,

    many thanks for your reply, the workaround you suggested works great! I can happily debug from Angular IDE now! 🙂

    I’ll keep listening for any news about the final fix, for now keep on the good work and congratulations for this great IDE!

    Regards, Alessio

    #510057 Reply

    Jon
    Participant

    Hi Sal,

    I am experiencing the similar issues to Alessio from Eclipse Neon.2 Release (4.6.2) on a MacBook Pro running MacOS Sierra 10.12.2. I have tried deleting the server configuration under the Servers tab, shutting down Eclipse, and removing the angular-ide.locations as you mention above. When I restart, I recreate the server with Angular CLI proxy support added. The “ng serve” operation successfully compiles my application, yet never finishes starting. I can access the server in this state, but it is not sensitive to any change I make.

    You mentioned a forthcoming fix for this issue. When do you expect to release it? Is there a chance to get this fix in BETA form?

    Thanks so much, Jon

    #510060 Reply

    Salvador Cabrera
    Participant

    Hi Jon,

    The fix is coming REAL soon but i think you might be experiencing a different issue, which version of angular-cli is installed on your project?

    Regards,
    Sal.

    #510067 Reply

    Jon
    Participant

    Hi Sal,

    Thanks for your incredibly fast response!

    I am running angular-cli 1.0.0-beta.26, having updated yesterday from 1.0.0-beta.22-1.

    And, angular-ide is 0.9.10 as you recommended. I, however, have its version specified using carat format (^0.9.10).

    Thanks,
    Jon

    #510227 Reply

    Salvador Cabrera
    Participant

    Hi Jon,

    Thanks for the info!
    There are some changes in angular-cli@1.0.0-beta.25 that broke our support for angular-cli, that is the reason why you are experiencing this issue.
    The good news is that we already working on a fix for this and should be landing in the upcoming release that will be available pretty soon :).

    Best Regards,
    Sal.

    #510991 Reply

    support-swapna
    Moderator

    Jon,

    Webclipse 2017 CI 2 is out. Please update and check if you are still seeing issues with embedded Angular CLI server.

    Please let us know how it works for you.

    –Swapna
    MyEclipse Support

    #511646 Reply

    Stefan
    Participant

    Hi Sal,

    I have a completely fresh eclipse and webclipse installation and the same issues. My system is running on Mac. Installed Node v7.4.0 and npm 4.1.2. I deleted file discribed in the post before. Nothing…
    After timeout I get the message: Timed out waiting for server to start. Please ensure you have angular-ide NPM plugin installed in your project. Run npm install –save-dev angular-ide.

    Have you any idea?
    Stefan

    #511648 Reply

    Jon
    Participant

    Hi Swapna,

    What version of angular-cli does Webclipse 2017 CI 2 require?

    Thanks,
    Jon

    #511738 Reply

    Salvador Cabrera
    Participant

    Hi Stefan,

    What version of Angular CLI are you using?
    Are you by any chance using the “@angular/cli” package ?
    We currently support only the “angular-cli” package from “1.0.0-beta.16” until “1.0.0-beta.28” which should also respond to Jon’s question.
    There’s already progress to support the latest Angular CLI versions (“@angular/cli” package) and we are expecting to deliver this pretty soon.

    Best Regards,
    Sal.

    #514187 Reply

    javafun
    Participant

    I haven exact same issue. ng serve gets stuck on 73%. I can’t debug, app is running on browser.
    After several minutes getting error
    “Timed out waiting for server to start. Please ensure you have angular-ide NPM plugin installed in your project. Run npm install –save-dev angular-ide.
    Timed out waiting for server to start. Please ensure you have angular-ide NPM plugin installed in your project. Run npm install –save-dev angular-ide.”

    Environment:
    OS: Windows 10
    Neon.2 Release (4.6.2) Build id: 20161208-0600
    Webclipse 1.7.2.201703011717

    Manually created new Angular2 app (couldn’t do that with “File > New ? Angular2 Project” because ng init command was removed from Latest Angular CLI v: 1.0.0-rc.0)

    devDependencies created:

    “devDependencies”: {
    “@angular/cli”: “1.0.0-rc.0”,
    “@angular/compiler-cli”: “^2.4.0”,
    “@types/jasmine”: “2.5.38”,
    “@types/node”: “~6.0.60”,
    “angular-ide”: “^0.9.17”,
    “codelyzer”: “~2.0.0”,
    “jasmine-core”: “~2.5.2”,
    “jasmine-spec-reporter”: “~3.2.0”,
    “karma”: “~1.4.1”,
    “karma-chrome-launcher”: “~2.0.0”,
    “karma-cli”: “~1.0.1”,
    “karma-jasmine”: “~1.1.0”,
    “karma-jasmine-html-reporter”: “^0.2.2”,
    “karma-coverage-istanbul-reporter”: “^0.2.0”,
    “protractor”: “~5.1.0”,
    “ts-node”: “~2.0.0”,
    “tslint”: “~4.4.2”,
    “typescript”: “~2.0.0”
    }

    • This reply was modified 3 years, 4 months ago by  javafun.
Viewing 15 posts - 1 through 15 (of 50 total)
Reply To: Angular IDE – problem starting 'Angular CLI' server

This topic is marked as closed to new replies, however your posting capabilities still allow you to do so.

You must be logged in to post in the forum log in