Angular IDE – problem starting 'Angular CLI' server

  1. CodeMix & Angular IDE > Webclipse 1.x Help

This topic contains 49 replies, has 14 voices, and was last updated by  support-tony 1 year, 10 months ago.

Viewing 15 posts - 16 through 30 (of 50 total)
  • Author
    Posts
  • #514241 Reply

    Salvador Cabrera
    Participant

    Hi javafun,

    Can you paste the output of ng serve when running the server ? (Terminal+ -> [ng serve]).
    Screenshots would be great too.

    Cheers,
    Sal

    #514276 Reply

    javafun
    Participant

    Hello Salvador,
    Thank you for fast reply.

    My ng serve output is

    Thanks.

    #514320 Reply

    javafun
    Participant

    Attaching screenshot of Terminal+ and Progress.

    Attachments:
    You must be logged in to view attached files.
    #514322 Reply

    Salvador Cabrera
    Participant

    Hi javafun,

    Thanks a lot for the data, we are going to investigate issue and come up with a response as soon as we can.

    Sal

    #514626 Reply

    Salvador Cabrera
    Participant

    Hi javafun,

    One more thing, can you create a new terminal for the project using Terminal+ and paste the output of running echo $PATH ?

    Thanks!

    #514633 Reply

    javafun
    Participant

    Hi Sal,

    Here is an output:

    #518153 Reply

    xyan5
    Participant

    Same problem here. Stuck at 73%. The server is started however the communication seems broken and says waiting for server to start.
    Right click on AngularCLI’s project and using my global NodeJS (6.10.1) instead of 7.8.0 and trying again worked.

    #518562 Reply

    Salvador Cabrera
    Participant

    Hi xyan5,

    I’m trying to replicate the issue, what OS are you using ?.

    Regards,
    Sal

    #518589 Reply

    xyan5
    Participant

    Hi Salvadore.

    I run on Win 10 Pro x64, Eclipse Neon.3, Node (global) 6.10.1.
    When I import or create new angular 2 project and if I choose node 7.7.4 the AngularCLI starts the project just fine. The only problem is if I choose node 7.8.0. If I then go in the properties of the AngularCLI project and change to global or other node version it runs fine.

    This is the log in ng serve:
    Node.js version: v7.8.0
    NPM version: 4.2.0
    ng serve –port=4200 –live-reload=true –environment=dev –webclipse-launch-id=722103677284764199
    The option ‘–webclipse-launch-id’ is not registered with the serve command. Run ng serve --help for a list of supported options.
    ** NG Live Development Server is running on http://localhost:4200 **
    Hash: 6fd49791e12643328a1f
    Time: 16302ms
    chunk {0} polyfills.bundle.js, polyfills.bundle.js.map (polyfills) 158 kB {4} [initial] [rendered]
    chunk {1} main.bundle.js, main.bundle.js.map (main) 3.69 kB {3} [initial] [rendered]
    chunk {2} styles.bundle.js, styles.bundle.js.map (styles) 9.77 kB {4} [initial] [rendered]
    chunk {3} vendor.bundle.js, vendor.bundle.js.map (vendor) 2.37 MB [initial] [rendered]
    chunk {4} inline.bundle.js, inline.bundle.js.map (inline) 0 bytes [entry] [rendered]
    webpack: Compiled successfully.

    Although the messages are similar to the ones with node 7.7.4 the AngularCLI is not aware of the completion and says [Starting].

    Let me know if you need more info. Thank you.

    #518684 Reply

    Salvador Cabrera
    Participant

    Hi xyan5,

    Thanks for the info, will investigate what’s going on here.

    regards,
    Sal

    #519599 Reply

    jeffreycuigmail-com
    Participant

    I have a question on the latest AngularIDE as of April 13, 2017. Didn’t find a way to post my question so just post it here.
    I started my Angular 4 app in “Servers” tab by right click and choose “Start Server”. When right click on the started server and choose “Debug application in Chrome”, the Chrome is launched and my app shows up. Works well.
    But I want the Chrome to be launched with arguments:

    “–disable-web-security –user-data-dir=c:\Temp”

    My question is how I can set the arguments when launching Chrome.
    Thanks

    #519666 Reply

    support-swapna
    Moderator

    Jeffrey,

    I am afraid launching Chrome with arguments is not yet supported. I have filed an enhancement request for the dev team. We will keep you posted when the support is added.

    As a workaround, you can follow the below steps to launch Chrome with custom arguments :

    1. Launch the Debug session as usual.
    2. Switch to the Debug view, right click on the Chrome process entry and choose Properties.Copy the arguments listed in the Command Line section.
    3. Close Chrome
    4. Go to the path pointed by --user-data-dir and create me-port file. The content of the me-port file should be the port number mentioned in the --remote-debug-port param. Only port number should be specified.
    Example :
    64225
    If you want to use a different path for --user-data-dir, then create the me-port file in that location.
    5. Launch Chrome from the command line with custom args --disable-web-security, --user-data-dir, --remote-debug-port and --no-default-browser-check copied from the one launched by Webclipse.
    6. Launch debug session as before – the externally launched Chrome will be used for any new sessions – remember to keep it open.

    Hope this helps. Let us know how it works for you.

    –Swapna
    MyEclipse Support

    #522006 Reply

    support-swapna
    Moderator

    Jeffrey,

    Webclipse 2017 CI 5 is out and it supports launching Chrome with arguments. Please update to CI 5 from menu Help > Check for Updates and let us know how it works for you.

    –Swapna
    MyEclipse Support

    #523900 Reply

    subratdash8
    Participant

    I am getting this error while using
    I have already installed angular-ide globally
    ngide install ~/Development/angular-ide

    Installing Angular IDE in: D:\Material\Angular IDE\~\Development\angular-ide
    C:\Users\subrat.dash\AppData\Roaming\npm\node_modules\angular-ide\node_modules\rx\dist\rx.js:77
    throw e;
    Error: getaddrinfo EAI_AGAIN http://www.genuitec.com:443
    at Object.exports._errnoException (util.js:1050:11)
    at errnoException (dns.js:33:15)
    at GetAddrInfoReqWrap.onlookup [as oncomplete] (dns.js:73:26)

    #523931 Reply

    support-swapna
    Moderator

    Subratdash,

    Sorry that you are seeing this issue.

    Can you please clarify if you are behind a firewall or proxy? If yes then currently there’s no proxy support when installing Angular IDE via angular-ide package.

    Please install Angular IDE from the Downloads page : https://www.genuitec.com/products/angular-ide/download/

    Let us know how it works for you.

    –Swapna
    MyEclipse Support

Viewing 15 posts - 16 through 30 (of 50 total)
Reply To: Angular IDE – problem starting 'Angular CLI' server

This topic is marked as closed to new replies, however your posting capabilities still allow you to do so.

You must be logged in to post in the forum log in