Bright Background on Folders not under version control

This topic contains 4 replies, has 3 voices, and was last updated by  catscratch 2 months, 3 weeks ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #596569 Reply

    catscratch
    Participant

    Folders under git version control got a bright background if:
    – in gitignore
    – got changes

    Unchanged folders are ok.

    Workaround is to use Eclipse File – Restart. This problem only occurs on first Eclipse start (every first start).

    Windows 10 1803 Build 17134.228
    Eclipse Photon: 4.8.0
    DevStyle: 1.11.0.201808131409
    Git Integration for Eclipse: 5.0.2.201807311906-r

    DevStyle Configuration:
    – Use enhanced DevStyle Themes on
    – Use the Startup Experience on
    – Workbench Theme: Deep Black
    – Icon Colors: Primary Colors
    – Editor Theme: Darkest Dark
    – Styling Shortcode: Cf7-Aw

    • This topic was modified 3 months ago by  catscratch.
    Attachments:
    You must be logged in to view attached files.
    #596584 Reply

    support-swapna
    Moderator

    catscratch,

    Sorry that you are seeing this issue. Thank you for the details and the screenshot.
    I tried to replicate the problem at my end but do not see it.
    I have filed a bug for the dev team to look into it. We will get back to you in case we need any additional details.

    Apologies for inconvenience caused.

    –Swapna
    Genuitec Support

    #596626 Reply

    hgabreu
    Participant

    I have this very same issue and most of the versions are an exact match from OP.
    But I’m running on Linux build id 20180619-1200. Style shortcode is Af7-Aw

    Btw, thanks for the restart tip.

    #597073 Reply

    support-swapna
    Moderator

    It looks like the styling preferences are being overridden due to Oomph.
    Please go to Window > Preferences > General > Appearance > Colors and Fonts preferences page, expand Git and confirm it has good colors for Uncommitted Changes (Foreground and background). If no, then please click Edit and set a good color. Attached is the screenshot for your reference.

    Hope this helps. Please let us know if you see any issues.

    –Swapna
    Genuitec Support

    Attachments:
    You must be logged in to view attached files.
    #597136 Reply

    catscratch
    Participant

    Thanks. It helped!

    I set uncommitted changed and ignored resources to black background.

Viewing 5 posts - 1 through 5 (of 5 total)
Reply To: Bright Background on Folders not under version control