Cannot start eclipse after installing Darkest Dark Mode Theme

  1. DevStyle
  2.  > 
  3. Getting Help


Viewing 1 post (of 1 total)
  • Author
  • #697159 Reply


    A couple of days ago out of the blue, I became unable to launch eclipse. I’m not sure what changed, but the problem only seems to appear with the Darkest Dark Mode Theme plugin installed.

    When I attempt to open Eclipse, it will show the splash screen and then the DevStyle workspace selection dialog. After I select a workspace it will show the launch progress bar with the fun little phrase and then it closes and a dialog with the title “Eclipse” pops up and says “An error has occurred. See the log file <my workspace directory>\.metadata.log.

    The log file shows the following:

    !SESSION 2023-06-28 12:21:03.152 -----------------------------------------------
    java.vendor=Eclipse Adoptium
    BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US
    Framework arguments:  -product org.eclipse.epp.package.java.product
    Command-line arguments:  -os win32 -ws win32 -arch x86_64 -product org.eclipse.epp.package.java.product
    !ENTRY org.eclipse.e4.ui.workbench.swt 4 2 2023-06-28 12:21:54.883
    !MESSAGE Problems occurred when invoking code from plug-in: "org.eclipse.e4.ui.workbench.swt".
    !STACK 0
    java.lang.IllegalAccessError: class org.eclipse.swt.widgets.ToolBar tried to access private method 'void org.eclipse.swt.widgets.ToolBar$ToolBarPainter2.<init>(org.eclipse.swt.widgets.ToolBar)' (org.eclipse.swt.widgets.ToolBar and org.eclipse.swt.widgets.ToolBar$ToolBarPainter2 are in unnamed module of loader org.eclipse.osgi.internal.loader.EquinoxClassLoader @6e564312), (Type org.eclipse.swt.widgets.ToolBar$ToolBarPainter2 (loader: org.eclipse.osgi.internal.loader.EquinoxClassLoader @6e564312) is not a nest member of type org.eclipse.swt.widgets.ToolBar (loader: org.eclipse.osgi.internal.loader.EquinoxClassLoader @6e564312): current type is not listed as a nest member)
    	at org.eclipse.swt.widgets.ToolBar.<init>(ToolBar.java:180)
    	at org.eclipse.e4.ui.workbench.renderers.swt.StackRenderer.addTopRight(StackRenderer.java:655)
    	at org.eclipse.e4.ui.workbench.renderers.swt.StackRenderer.createWidget(StackRenderer.java:621)

    I see the same error regardless of what JRE I use and what workspace I try to open.

    In this example, I’m using Eclipse Temurin JDK 17.0.1.
    Operating system: Wndows 10 Enterprise build 19045.3086
    Eclipse Version: 2021-06 (4.20.0.I20210611-1600)

    After spending a couple of days trying to hunt this down, I decided to reinstall eclipse (using 2021-06 again because my company is picky about only using versions that the security and legal team have vetted so we don’t get updates often, I know its dumb). My workspace loaded up just fine. Then I installed Darkest Dark Mode Theme and I started seeing the same errors.

Viewing 1 post (of 1 total)
Reply To: Cannot start eclipse after installing Darkest Dark Mode Theme

You must be logged in to post in the forum log in