facebook

Code Composer 10, having problem with Darkest Dark Theme.

  1. DevStyle
  2.  > 
  3. Getting Help
Viewing 15 posts - 1 through 15 (of 17 total)
  • Author
    Posts
  • #647490 Reply

    riscy00
    Participant

    Cannot complete the install because one or more required items could not be found. This is code composer 10 from TI.

    Software being installed: DevStyle (includes Darkest Dark Theme) 1.11.0.201909171704 (com.genuitec.eclipse.theming.feature.feature.group 1.11.0.201909171704)
    Missing requirement: Startup 1.11.0.201909171704 (com.genuitec.eclipse.startup 1.11.0.201909171704) requires ‘osgi.bundle; org.eclipse.wst.common.frameworks 0.0.0’ but it could not be found
    Cannot satisfy dependency:
    From: DevStyle (includes Darkest Dark Theme) 1.11.0.201909171704 (com.genuitec.eclipse.theming.feature.feature.group 1.11.0.201909171704)
    To: org.eclipse.equinox.p2.iu; com.genuitec.eclipse.startup [1.11.0.201909171704,1.11.0.201909171704]

    I have follow similar topic and made link but it does not work, see attached and advise.

    Installed

    Attachments:
    You must be logged in to view attached files.
    #647496 Reply

    riscy00
    Participant

    I have switched to https://download.eclipse.org/eclipse/updates/4.14/ from previous 4.8 and it does not solve problem.

    #648091 Reply

    support-swapna
    Moderator

    riscy00,

    Sorry that you are seeing issues with installing DevStyle to CCS 10. It looks like a known issue with newer versions of CCS including 9.2.
    We are looking into it and will keep you posted about our findings.

    Apologies for inconvenience caused.

    –Swapna
    Genuitec Support

    #649236 Reply

    support-swapna
    Moderator

    riscy00,

    I could get DevStyle installed to Code Composer Studio 10 after adding the below two sites (in addition to the earlier site for 4.14 : https://download.eclipse.org/eclipse/updates/4.14/ ) to the Window > Preferences > Install/Update > Available Software Sites :

    1. Orbit repo : https://download.eclipse.org/tools/orbit/downloads/drops/R20191126223242/repository
    2. Webtools repo : https://download.eclipse.org/webtools/repository/2019-12/

    Add the above sites, click on the ‘Reload’ button for each site, ensure they are enabled and then try installing DevStyle from the Eclipse Marketplace.

    Hope these steps help. Please let us know how this works for you.

    –Swapna
    Genuitec Support

    #676113 Reply

    riscy00
    Participant

    Success for CCS 10.4

    #676122 Reply

    support-swapna
    Moderator

    riscy00,

    Glad that it works in CCS 10.4. Thank you for letting us know.

    –Swapna
    Genuitec Support

    #677421 Reply

    riscy00
    Participant

    I now on CCS11 on new laptop, I followed the step but it popup up error

    HTTP Server ‘Internal Error’
    http://www.genuite.com/update/devstyle/ci/compositecontent.jar

    HttpComponent connection error response code 500

    Suggestion?

    #695162 Reply

    maodd
    Participant

    @support-swapna

    Adding the two repos you suggested (orbit and webtools) also helped me getting devstyle installed in CCS 12.2 đŸ™‚

    As much as I appreciate your solution, I am also tired that each time i update CCS i have to fiddle with adding software sites to install Devstyle.
    I don’t know the inner workings of eclipse marketplace. But it is not possible to ensure/add the needed dependency repos from the installer, as a minimum provide an error message saying “Devstyle misses xyz component please add http….. to your software sites”?
    If not, would it be possible to build the Devstyle in a “static linked” manner to it contains all its own dependencies?

    Regards Martin, a fan of Devstyle.

    #695215 Reply

    riscy00
    Participant

    It would be great for all eclipse based IDE not only from CCS but STM32-Cube and many other variants. The devstyle is the best theme.

    Because of the security change/upgrades, the devstyle is no longer listed in marketplace since it filtered out unsecured plugin.

    In addition, I also would like to see under a dark theme to have red (error) and orange (warning) from compiler activity within the console sub-window, how to enable that?, or is there other dark theme which do that?

    #695222 Reply

    support-swapna
    Moderator

    Martin,

    The problem is with some of the Eclipse dependencies that are missing in Code Composer Studio which is why we suggest to add the appropriate Eclipse Orbit sites to pull them while installing DevStyle. I have escalated your concern to the dev team. They will get back to you.

    Apologies for inconvenience caused.

    –Swapna
    Genuitec Support

    #695223 Reply

    support-swapna
    Moderator

    riscy00,

    I do see DevStyle/Darkest Dark listed in the Eclipse Marketplace in Code Composer Studio 12.x and STMCubeIDE as well.
    Can you please clarify which version of CCS are you working with? What happens if you type ‘DevStyle’ in the Search bar of Eclipse Marketplace?
    Are there any security changes specific to your network?
    Regarding the font colors for errors and warnings, please share a screenshot of the Compiler activity to help us get a visual.

    Apologies for inconvenience caused.

    –Swapna
    Genuitec Support

    #695399 Reply

    riscy00
    Participant

    Hi
    I moved to new laptop and struggle to get DevStyle installed into CCS 12.2. The old solution does not work anymore and I do not have software download option from the eclipse marketplace as they removed that feature. It need missing stuff to install and webtool/orbit is not listed in the ellipse marketplace. Thanks

    Reported error…..

    Cannot complete the install because one or more required items could not be found.
    Software being installed: DevStyle (includes Darkest Dark Theme) 1.11.0.202206271604 (com.genuitec.eclipse.theming.core.feature.feature.group 1.11.0.202206271604)
    Missing requirement: Webclipse UDM 13.0.0.202206271604 (com.genuitec.eclipse.monitor 13.0.0.202206271604) requires ‘java.package; org.apache.commons.lang3 3.1.0’ but it could not be found
    Cannot satisfy dependency:
    From: EditorMinimap 1.11.0.202206271604 (com.genuitec.eclipse.inlinesearch 1.11.0.202206271604)
    To: osgi.bundle; com.genuitec.eclipse.monitor 0.0.0
    Cannot satisfy dependency:
    From: DevStyle (includes Darkest Dark Theme) 1.11.0.202206271604 (com.genuitec.eclipse.theming.core.feature.feature.group 1.11.0.202206271604)
    To: org.eclipse.equinox.p2.iu; com.genuitec.eclipse.inlinesearch [1.11.0.202206271604,1.11.0.202206271604]

    #695419 Reply

    support-swapna
    Moderator

    riscy00,

    CCS 12.2 is based on Eclipse 2022-03. So you have to add the orbit and webtools repo for Eclipse 2022-03. I could install DevStyle successfully to CCS 12.2 using the below sites.

    1. Orbit repo : https://download.eclipse.org/tools/orbit/downloads/drops/R20220302172233/repository
    2. Webtools repo : https://download.eclipse.org/webtools/repository/2022-03/

    Add the above sites to Window > Preferences > Install/Update > Available Software Sites, click on the ‘Reload’ button for each site, ensure they are enabled and then try installing DevStyle from the Eclipse Marketplace.

    Do let us know how this works for you.

    –Swapna
    Genuitec Support

    #695463 Reply

    riscy00
    Participant

    Okay I get it now, add these two to register table so that Devstyle install should automatically select needed module and install. Thank.

    • This reply was modified 1 year ago by riscy00.
    #695465 Reply

    support-swapna
    Moderator

    riscy00,

    Right, adding those two repos will resolve the dependency issues and DevStyle will install successfully.
    Attached is the screenshot for your reference.

    –Swapna
    Genuitec Support

    Attachments:
    You must be logged in to view attached files.
Viewing 15 posts - 1 through 15 (of 17 total)
Reply To: Code Composer 10, having problem with Darkest Dark Theme.

You must be logged in to post in the forum log in