Stuck on “Waiting for Copilot4Eclpse initialization” [Resolved]

  1. Copilot4Eclipse – GitHub Copilot on Eclipse
  2.  > 
  3. General Discussion
Viewing 5 posts - 16 through 20 (of 20 total)
  • Author
  • #699970 Reply


    Apologies Wayne, I lost track of this thread last month and just checked back. I just now reinstalled the plugin and it appears to be working as expected. Thanks. I’m looking forward to testing it out.

    #700009 Reply


    Thanks for sharing your experience. This is good news.

    #700014 Reply

    Mukesh Kumar

    I have setup copilot4eclpse plugin for Eclipse version Version: 2023-12 (4.30.0). However am getting below error while it’s trying get auto completions. Any suggestions are appreciated.

    [2024-02-14T17:15:43.993628500+05:30] LANGUAGE_SERVER_TO_LSP4E com.genuitec.copilot4eclipse.copilot:
    {“jsonrpc”:”2.0″,”method”:”LogMessage”,”params”:{“level”:1,”message”:”[INFO] [default] [2024-02-14T11:45:43.990Z] [fetchCompletions] engine https://copilot-proxy.githubusercontent.com/v1/engines/copilot-codex”,”metadataStr”:”[INFO] [default] [2024-02-14T11:45:43.990Z]”,”extra”:[“[fetchCompletions] engine https://copilot-proxy.githubusercontent.com/v1/engines/copilot-codex”%5D}}

    [2024-02-14T17:15:44.393502800+05:30] LANGUAGE_SERVER_TO_LSP4E com.genuitec.copilot4eclipse.copilot:
    {“jsonrpc”:”2.0″,”method”:”statusNotification”,”params”:{“status”:”Warning”,”message”:”self-signed certificate in certificate chain”}}

    [2024-02-14T17:15:44.394494900+05:30] LANGUAGE_SERVER_TO_LSP4E com.genuitec.copilot4eclipse.copilot:
    {“jsonrpc”:”2.0″,”method”:”LogMessage”,”params”:{“level”:3,”message”:”[ERROR] [ghostText] [2024-02-14T11:45:44.391Z] Error on ghost text request: (FetchError) self-signed certificate in certificate chain”,”metadataStr”:”[ERROR] [ghostText] [2024-02-14T11:45:44.391Z]”,”extra”:[“Error on ghost text request: (FetchError) self-signed certificate in certificate chain”]}}

    #700017 Reply


    The log info is very helpful.

    Question-1: what OS platform are you on, e.g., Win, Mac, Linux, other?

    Tip-1: try disabling strict SSL certificate checking
    a) Open preferences from Copilot menu > Preferences
    b) From the Preferences Dialog expand Copiloe4Eclipse > Network & Monitoring
    c) Uncheck “Strict SSL certificate checking from GitHub Copilot proxy connections
    d) Restart eclipse and check for Copilot completions in an active editor. Monitor the LSP log for the self-signed issue.

    If you experience the same error “(FetchError) self-signed certificate in certificate chain” then I suspect the root certificate is not accessible to Copilot4Eclipse. In such cases you can either install the self-signed root certificate to your system’s trust store or provide the root certificate file available to Copilot4Eclipse using the NODE_EXTRA_CA_CERTS environment variable.
    See https://nodejs.org/api/cli.html#node_extra_ca_certsfile

    Here is a helpful thread from a user that uses the NODE_EXTRA_CA_CERTS environment variable approach: https://www.genuitec.com/forums/topic/copilot4eclipse-1-0-0-ssl-certificate-issues-in-corporate-proxy/

    Let us know if this helps resolve the issue.

    #700040 Reply

    Mukesh Kumar

    Hi Wayne,

    Sorry for delayed response.
    Yes, i have eclipse running on Windows environment behind a corporate proxy.
    I did try both solution you suggested but still getting same error message.


Viewing 5 posts - 16 through 20 (of 20 total)
Reply To: Stuck on “Waiting for Copilot4Eclpse initialization” [Resolved]

You must be logged in to post in the forum log in