Create angular project problems

This topic contains 3 replies, has 3 voices, and was last updated by  support-swapna 7 months, 2 weeks ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #557858 Reply

    Hi, when i create a new angular project follow this message is displayed:

    Downloading and extracting Node 9.5.0…
    Downloading and extracting NPM 5.6.0…
    Node.js version: v9.5.0
    NPM version: 5.6.0
    npm install @angular/cli@1.7.1

    > fsevents@1.1.3 install /Users/familyimac/eclipse-js/workspace/myProject/node_modules/fsevents
    > node install

    [fsevents] Success: “/Users/familyimac/eclipse-js/workspace/myProject/node_modules/fsevents/lib/binding/Release/node-v59-darwin-x64/fse.node” is installed via remote

    > node-sass@4.7.2 install /Users/familyimac/eclipse-js/workspace/myProject/node_modules/node-sass
    > node scripts/install.js

    Downloading binary from https://github.com/sass/node-sass/releases/download/v4.7.2/darwin-x64-59_binding.node
    Download complete ] – :
    Binary saved to /Users/familyimac/eclipse-js/workspace/myProject/node_modules/node-sass/vendor/darwin-x64-59/binding.node
    Caching binary to /Users/familyimac/.npm/node-sass/4.7.2/darwin-x64-59_binding.node

    > uglifyjs-webpack-plugin@0.4.6 postinstall /Users/familyimac/eclipse-js/workspace/myProject/node_modules/webpack/node_modules/uglifyjs-webpack-plugin
    > node lib/post_install.js

    > node-sass@4.7.2 postinstall /Users/familyimac/eclipse-js/workspace/myProject/node_modules/node-sass
    > node scripts/build.js

    Binary found at /Users/familyimac/eclipse-js/workspace/myProject/node_modules/node-sass/vendor/darwin-x64-59/binding.node
    Testing binary
    Binary is fine
    npm WARN saveError ENOENT: no such file or directory, open ‘/Users/familyimac/eclipse-js/workspace/myProject/package.json’
    npm notice created a lockfile as package-lock.json. You should commit this file.
    npm WARN enoent ENOENT: no such file or directory, open ‘/Users/familyimac/eclipse-js/workspace/myProject/package.json’
    npm WARN myProject No description
    npm WARN myProject No repository field.
    npm WARN myProject No README data
    npm WARN myProject No license field.

    + @angular/cli@1.7.1
    added 1035 packages in 238.136s
    Node.js version: v9.5.0
    NPM version: 5.6.0
    node_modules/.bin/ng version && ng new myProject –directory ./ –skip-git

    _ _ ____ _ ___
    / \ _ __ __ _ _ _| | __ _ _ __ / ___| | |_ _|
    / △ \ | ‘_ \ / _| | | | |/ _ | ‘__| | | | | | |
    / ___ \| | | | (_| | |_| | | (_| | | | |___| |___ | |
    /_/ \_\_| |_|\__, |\__,_|_|\__,_|_| \____|_____|___|
    |___/

    Angular CLI: 1.7.1
    Node: 9.5.0
    OS: darwin x64
    Angular:

    Error: Schematic input does not validate against the Schema: {“directory”:”./”,”skipGit”:true,”name”:”myProject”,”style”:”css”,”version”:”1.7.1″,”commit”:{“message”:”chore: initial commit from @angular/cli\n\n _ _ ____ _ ___\n / \\ _ __ __ _ _ _| | __ _ _ __ / ___| | |_ _|\n / △ \\ | ‘_ \\ / _\\| | | | |/ _\\ | ‘__| | | | | | |\n / ___ \\| | | | (_| | |_| | | (_| | | | |___| |___ | |\n/_/ \\_\\_| |_|\\__, |\\__,_|_|\\__,_|_| \\____|_____|___|\n |___/\n”,”name”:”Angular CLI”,”email”:”angular-cli@angular.io”},”path”:”app”,”sourceDir”:”src”,”inlineStyle”:false,”inlineTemplate”:false,”routing”:false,”prefix”:”app”,”skipTests”:false,”skipInstall”:false,”linkCli”:false,”minimal”:false,”serviceWorker”:false}
    Errors:
    .directory should match format “path”
    Schematic input does not validate against the Schema: {“directory”:”./”,”skipGit”:true,”name”:”myProject”,”style”:”css”,”version”:”1.7.1″,”commit”:{“message”:”chore: initial commit from @angular/cli\n\n _ _ ____ _ ___\n / \\ _ __ __ _ _ _| | __ _ _ __ / ___| | |_ _|\n / △ \\ | ‘_ \\ / _\\| | | | |/ _\\ | ‘__| | | | | | |\n / ___ \\| | | | (_| | |_| | | (_| | | | |___| |___ | |\n/_/ \\_\\_| |_|\\__, |\\__,_|_|\\__,_|_| \\____|_____|___|\n |___/\n”,”name”:”Angular CLI”,”email”:”angular-cli@angular.io”},”path”:”app”,”sourceDir”:”src”,”inlineStyle”:false,”inlineTemplate”:false,”routing”:false,”prefix”:”app”,”skipTests”:false,”skipInstall”:false,”linkCli”:false,”minimal”:false,”serviceWorker”:false}
    Errors:
    .directory should match format “path”

    #557904 Reply

    Brian Fernandes
    Moderator

    Unfortunately there seems to be an issue with the 1.7 series of CLIs as detailed here. We’re working on releasing a fix for this.

    The workarounds I can provide for now are
    a) Use a 1.6 series CLI, if possible
    b) At the end of the above commend (after it fails) choose to keep the directory, do not delete it. Then in the Terminal+ view, select the project and type in the following command:
    ng new myProject –skip-git which should have the same effect as the command above.

    Apologies for the inconvenience caused – we will let you know when a fix is available.

    #558079 Reply

    Thanks, now work fine!
    Another question: is possible add Ionic nature to Angular project?
    If this is possible, How add ionic components from palette or other?
    Thanks

    #559379 Reply

    support-swapna
    Moderator

    Apologies for missing out your query about Ionic support to Angular projects.
    We currently do not support any wizards to add Ionic support but you can install Ionic packages to your angular projects from the Terminal+ view by running this command : npm install -g ionic@latest. For further help with Ionic integration you can check in development forums or look up tutorials related to Ionic + Angular development.

    We put out a pre release containing the fix for angular project creation problem with CLI 1.7.x
    Do give it a try and let us know if the issue is fixed.

    Instructions on getting the PR stream are here:
    https://www.genuitec.com/forums/topic/webclipse-angular-ide-prerelease-stream/

    –Swapna
    MyEclipse Support

Viewing 4 posts - 1 through 4 (of 4 total)
Reply To: Create angular project problems