Dashboard error and errors on startup after update.

  1. MyEclipse IDE > Spring Development

This topic contains 3 replies, has 2 voices, and was last updated by  support-shalini 10 years, 5 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #306440 Reply

    Dennis
    Participant

    I chose to update the only update available; I believe for Database Explorer or something as part of the DB tools.

    Initially, the Workspace Launcher no longer displayed, even though it was configured to.
    I then restarted with -clean and then the launcher displayed.

    I’m getting the following worrisome error when clicking on Manage Plugins from the startup page:

    java.lang.ClassNotFoundException: com.genuitec.eclipse.dashboard.actions.DashboardAction
    at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:494)
    at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:410)
    at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:398)
    at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:105)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
    at org.eclipse.osgi.internal.loader.BundleLoader.loadClass(BundleLoader.java:326)
    at org.eclipse.osgi.framework.internal.core.BundleHost.loadClass(BundleHost.java:231)
    at org.eclipse.osgi.framework.internal.core.AbstractBundle.loadClass(AbstractBundle.java:1193)
    at org.eclipse.ui.internal.intro.impl.model.loader.ModelLoaderUtil.createClassInstance(ModelLoaderUtil.java:146)
    at com.genuitec.eclipse.intro.StartPageURL.runAction(StartPageURL.java:275)
    at com.genuitec.eclipse.intro.StartPageURL.doExecute(StartPageURL.java:193)
    at com.genuitec.eclipse.intro.StartPageURL$1.run(StartPageURL.java:144)
    at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:70)
    at com.genuitec.eclipse.intro.StartPageURL.execute(StartPageURL.java:141)
    at com.genuitec.eclipse.intro.StartPageEditor.changing(StartPageEditor.java:236)
    at org.eclipse.swt.browser.IE$6.handleEvent(IE.java:356)
    at org.eclipse.swt.ole.win32.OleEventTable.sendEvent(OleEventTable.java:55)
    at org.eclipse.swt.ole.win32.OleEventSink.notifyListener(OleEventSink.java:145)
    at org.eclipse.swt.ole.win32.OleEventSink.Invoke(OleEventSink.java:120)
    at org.eclipse.swt.ole.win32.OleEventSink.access$1(OleEventSink.java:97)
    at org.eclipse.swt.ole.win32.OleEventSink$1.method6(OleEventSink.java:71)
    at org.eclipse.swt.internal.ole.win32.COMObject.callback6(COMObject.java:119)
    at org.eclipse.swt.internal.win32.OS.DispatchMessageW(Native Method)
    at org.eclipse.swt.internal.win32.OS.DispatchMessage(OS.java:2410)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3471)
    at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2405)
    at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2369)
    at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2221)
    at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:500)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
    at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:493)
    at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
    at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:113)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:194)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:368)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:559)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:514)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1311)

    Here is my Install Summary:

    *** Date:
    Monday, March 1, 2010 4:09:46 PM CST

    ** System properties:
    OS=WindowsXP
    OS version=5.1.0
    Java version=1.6.0_13

    *** MyEclipse details:
    MyEclipse Enterprise Workbench
    Version: 8.0
    Build id: 8.0-20091120

    *** Eclipse details:
    MyEclipse Enterprise Workbench

    Version: 8.0
    Build id: 8.0-20091120

    Eclipse startup command=-os
    win32
    -ws
    win32
    -arch
    x86
    -showsplash
    -launcher
    C:\Program Files\Genuitec\MyEclipse 8.x Latest\myeclipse.exe
    -name
    Myeclipse
    –launcher.library
    C:\Program Files\Genuitec\MyEclipse 8.x Latest\../Common/plugins/org.eclipse.equinox.launcher.win32.win32.x86_1.0.200.v20090519\eclipse_1206.dll
    -startup
    C:\Program Files\Genuitec\MyEclipse 8.x Latest\../Common/plugins/org.eclipse.equinox.launcher_1.0.201.R35x_v20090715.jar
    -install
    C:/Program Files/Genuitec/MyEclipse 8.x Latest
    -configuration
    configuration
    -vm
    C:/Program Files/Genuitec/Common/binary/com.sun.java.jdk.win32.x86_1.6.0.013/jre/bin/client/jvm.dll

    #306449 Reply

    djwaters,
    I am sorry that you are running into this issue. Can you try pulse for a quick fix?
    The following are the steps.
    1. Download pulse from poweredbypulse.com
    2. Open pulse explorer and log in anonymously.
    3. From the top left corner, select “Eclipse Galileo”. Your profile should be listed under “MyProfile”
    4. Select your profile, right click on it and from the context menu select “Re-install and Run”
    Let me know if that works for you.

    #306480 Reply

    Dennis
    Participant

    Thanks. I had already re-installed earlier today, as I had not seen your reply. Working now.

    #306510 Reply

    djwaters,

    Working now.

    Good to know that you are all set. do let us know if you have any issues

Viewing 4 posts - 1 through 4 (of 4 total)
Reply To: Dashboard error and errors on startup after update.

You must be logged in to post in the forum log in