Devstyle erased the format setting in syntaxColoring

  1. DevStyle > Theme Problems

Tagged: ,

This topic contains 20 replies, has 5 voices, and was last updated by  support-swapna 1 year, 5 months ago.

Viewing 6 posts - 16 through 21 (of 21 total)
  • Author
    Posts
  • #600350 Reply

    support-swapna
    Moderator

    Luuk,

    Sorry that you are seeing this problem. Thank you for the screenshots and the log file.
    It looks like a problem with Oomph. Oomph attempts to track and reapply preferences saved into a directory under User Home. This can cause fighting with styling preferences that our theme sets.

    Can you please shut down Eclipse, go to your user home/.eclipse folder, remove folders that have oomph in their name, start Eclipse, then set the syntax highlighting color and see if it is retained.

    The errors in the log are most likely caused due to our plugins not having full write access to your workspace. If possible, please switch to a new workspace and check if the reported issues persist.

    Apologies for inconvenience caused. Please let us know how the above suggestion works for you.

    –Swapna
    Genuitec Support

    #600355 Reply

    luuk80
    Participant

    Swapna,

    I have switched to a new workspace, on a different physical disk. This does seem to solve the problem and the syntax is retained after restarts! Thank you.

    Is there any way that I can give the plugins full write access to my workspace? I would love to keep my workspace in my C:/Users/Luuk/Documents/Development folder, in stead of moving it to a different disk.

    Before switching to a new workspace, I have tried the steps of your first suggestion. This did not work for me. I have removed the directories indicated in the picture. The directories reappear after restarting Eclipse btw.

    Thanks again for your help.
    Best,
    Luuk

    Attachments:
    You must be logged in to view attached files.
    #600357 Reply

    luuk80
    Participant

    I managed to give the plugins full write access to my workspace by right clicking the workspace directory, and deselecting ‘Read-only’. I then applied this to all subfolders and files within this directory. Now I have fully retained syntax using my original workspace.

    Thank you so much for your support!

    EDIT: I spoke too soon. Using only the original workspace does not allow me to retain the syntax coloring. Any suggestions how I can give Eclipse plugins full access to my original workspace?

    Best,
    Luuk

    • This reply was modified 1 year, 7 months ago by  luuk80.
    #600413 Reply

    support-swapna
    Moderator

    Luuk,

    To guarantee that Eclipse has full access to the workspace, you could specify a non-existent directory when starting Eclipse and Eclipse would create the workspace folder and everything in it which would mean it has full access. If Eclipse doesn’t start up, then there is likely a problem with the folder access.

    So what you can do is point Eclipse to a non existent folder under C:/Users/Luuk/Documents/ (let Eclipse create it and do not create the folder yourself outside of Eclipse) when starting Eclipse and then see if the syntax coloring changes are retained in the said workspace.

    Please let us know how it works for you.

    –Swapna
    Genuitec Support

    #605949 Reply

    patchouli
    Participant

    I’m having the same problem. However disabling the DevStyle Startup Experience seems to fix the problem for me.

    #606040 Reply

    support-swapna
    Moderator

    patchouli,

    Thank you for posting the workaround details.
    Can you please clarify if you are seeing the same problem in a new workspace (pointing to a non existent folder) as well when the DevStyle Startup experience enabled?

    Apologies for inconvenience caused.

    –Swapna
    Genuitec Support

Viewing 6 posts - 16 through 21 (of 21 total)
Reply To: Devstyle erased the format setting in syntaxColoring

You must be logged in to post in the forum log in