facebook

DevStyle not installing in STM32CubeIDE

  1. DevStyle
  2.  > 
  3. Theme Problems
Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #694572 Reply

    jaza_tom
    Participant

    I have two other computers with relatively fresh windows installs in which everything worked fine. The third computer on the other hand…

    After a fresh install of STM32CubeIDE_v1.11.0_13638_20221122_1308, here is the error I get when trying to install DevStyle:

        Cannot complete the install because one or more required items could not be found.
          Software being installed: DevStyle with CodeTogether Bundle 1.11.0.202206271604 (com.genuitec.eclipse.theming.feature.feature.group 1.11.0.202206271604)
          Missing requirement: DevStyle with CodeTogether Bundle 1.11.0.202206271604 (com.genuitec.eclipse.theming.feature.feature.group 1.11.0.202206271604) requires 'org.eclipse.equinox.p2.iu; com.genuitec.eclipse.codetogether.feature.feature.group 1.0.0' but it could not be found

     
    If I proceed and just install DevStyle on its own (without the “DevStyle with CodeTogether Bundle” module), it seems to break the IDE (many views/panes show error messages and project no longer initiates build.
    If I then select “show original error and build my own solution” and select Install fewer items than originally requested then it appears to break the IDE because I can no longer build my project after the IDE restarts following the partial install

     

    Attachments:
    You must be logged in to view attached files.
    #694579 Reply

    support-swapna
    Moderator

    Hi,

    Sorry that you are seeing this issue with DevStyle. Looks like there is a dependency issue with the CodeTogether bundle, but the DevStyle Darkest Dark should install fine without breaking the IDE. I just tested it at my end and see no breaks with the views/panes.

    Can you please share with us the screenshots of the views/panes that are broken at your end? Please switch to a new workspace and check if the issue persists. If yes, then share with us the below details :
    1. .log file located at workspace dir/.metadata/.log (rename the extension to .txt and attach it here)
    2. OS and version details.
    3. Exact build error you are seeing with the projects.

    Apologies for the inconvenience caused.

    –Swapna
    Genuitec Support

    #694591 Reply

    jaza_tom
    Participant

    OK, here is the process I followed and the results/logs:

    1. Uninstall STM32CubeIDE
    2. Install st-stm32cubeide_1.11.0_13638_20221122_1308_x86_64
    3. Click Help -> Eclipse MarketPlace ->
    4. Search of “Darkest Dark” theme, click install
    5. Select only “Darkest Dark theme with DevStyle” module and click “install”
    6. Wait while the updater installs DevStyle in the background
    7. Click “restart IDE” when prompted after install is finished
    8. Select “Skip” when DevStyle offers to add IDE folders to Windows Defender exception folders to speed up build time
    9. When the “Tweak the workbench” Devstyel dialogue appears, I notice already that there are panes that are broken in the background
    10. Click continue
    11. Notice upon initial inspection at least 3 views that are broken: Information Center, Build Analyzer, Static Stack Analyzer

    Error log from the new workspace is attached, as well as a screenshot of the software sites configured in settings

    I am not seeing any build errors when I try to build a project; nothing happens when I right/click a project and click “Build project”

    Here is the OS and version details:

    Device name xxxxxxxxxxxxxxxxxx
    Processor Intel(R) Core(TM) i7-7700 CPU @ 3.60GHz 3.60 GHz
    Installed RAM 16.0 GB (15.9 GB usable)
    Device ID xxxxxxxxxxxxxxxxxx
    Product ID xxxxxxxxxxxxxxxxxxxx
    System type 64-bit operating system, x64-based processor
    Pen and touch No pen or touch input is available for this display

    Edition Windows 10 Pro
    Version 21H2
    Installed on ‎2022-‎12-‎06
    OS build 19044.2251
    Experience Windows Feature Experience Pack 120.2212.4180.0

    • This reply was modified 1 year, 7 months ago by jaza_tom.
    Attachments:
    You must be logged in to view attached files.
    #694601 Reply

    jfb
    Participant

    I have the exact same problem but with a fresh new install of STM32CubeIDE version 1.10.1.
    I attached a before and after DevStyle install screenshot plus its log file.
    I installed DevStyle and DevStyle-Icon designer, not the bundle.

    I have the same problem with my computer at work.
    Note that on my work computer, I did install it in July of this year and it worked fine.

    Here is my information:

    System:
    Device name ———-
    Processor Intel(R) Xeon(R) CPU E5-2643 v4 @ 3.40GHz 3.40 GHz
    Installed RAM 16.0 GB (15.9 GB usable)
    Device ID ———-
    Product ID ———-
    System type 64-bit operating system, x64-based processor
    Pen and touch No pen or touch input is available for this display

    OS:
    Edition Windows 10 Pro
    Version 22H2
    Installed on ‎2020-‎11-‎30
    OS build 19045.2251
    Serial number ———-
    Experience Windows Feature Experience Pack 120.2212.4180.0

    Thank you

    Attachments:
    You must be logged in to view attached files.
    #694605 Reply

    jfb
    Participant

    I have the exact same problem but with a fresh new install of STM32CubeIDE version 1.10.1.
    I attached a before and after DevStyle install screenshot plus its log file.
    I installed DevStyle and DevStyle-Icon designer, not the bundle.

    I have the same problem with my computer at work.
    Note that on my work computer, I did install it in July of this year and it worked fine.

    Here is my information:

    System:
    Device name ———-
    Processor Intel(R) Xeon(R) CPU E5-2643 v4 @ 3.40GHz 3.40 GHz
    Installed RAM 16.0 GB (15.9 GB usable)
    Device ID ———-
    Product ID ———-
    System type 64-bit operating system, x64-based processor
    Pen and touch No pen or touch input is available for this display

    OS:
    Edition Windows 10 Pro
    Version 22H2
    Installed on ‎2020-‎11-‎30
    OS build 19045.2251
    Serial number ———-
    Experience Windows Feature Experience Pack 120.2212.4180.0

    Thank you

    Attachments:
    You must be logged in to view attached files.
    #694611 Reply

    Fuuzz
    Participant

    Exact same problem as described here

    Fresh install of STM32 Cube IDE 1.11.0 , new workspace
    Windows 11 x64

    #694617 Reply

    support-swapna
    Moderator

    Hi,

    Thank you all for the details and the screenshots. We managed to replicate the problem at our end.
    We are looking into it and we will get back to you soon.

    –Swapna
    Genuitec Support

    #694670 Reply

    jaza_tom
    Participant

    The problem has a workaround which was found by an employee over at ST:

    https://community.st.com/s/feed/0D53W00001zNKigSAG

    Basically:

    To get it to work, do a fresh install of the IDE, untick the CDT site in “Available Software Sites” (Help->Install New Software then “Manage”), and then install DevStyle from marketplace

    #694685 Reply

    support-swapna
    Moderator

    Tom,

    Great! Thank you for letting us know about the workaround. It would surely help other CubeIDE users reporting the same problem.

    –Swapna
    Genuitec Support

Viewing 9 posts - 1 through 9 (of 9 total)
Reply To: DevStyle not installing in STM32CubeIDE

You must be logged in to post in the forum log in