Exlipse 2020-12 + Poject Users Filters + Darkest Theme

Genuitec :: Driving Development for Leading Organizations Support Forums DevStyle Theme Problems Exlipse 2020-12 + Poject Users Filters + Darkest Theme

This topic contains 6 replies, has 2 voices, and was last updated by  wbritton 4 days, 8 hours ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #672097 Reply

    wbritton
    Participant

    Good day, there is a problem with being able to manage user filters under filters and customization in the project explorer. You can see the entries but have no access to edit, add or delete them. I’ve verified it’s the theme since i can do it when I remove it. Screenshot included. Please advise. Thanks.

    Attachments:
    You must be logged in to view attached files.
    #672102 Reply

    aaronlonin
    Moderator

    Hello @wbritton! I’m sorry you are having issues with DevStyle. I have tried the filters and customization dialog myself in both Eclipse 2020-12 and 2021-03 (latest) in Windows 10 and it does display all elements here. So I wonder if something is failing in your particular installation. Can you please share your error log? Also, can you provide more details about your install?
    – OS (and version)
    – Eclipse package (JEE, for web, for c++, etc)
    – Any other third party plugin installed

    Cheers!
    Aaron Lara

    #672490 Reply

    wbritton
    Participant

    Thanks for the response. For some crazy reason I didn’t get an email notification once you posted the reply, will have to look into this on my end.

    I’m Running Windows 10, with eclipse package for Enterprise Java and Web Developers (eclipse-inst-2020-12-jre-win64.exe). I have the jdk-11.0.10.9-hotspot installed as well. To make sure the plugins were not I use were not causing the issue I ran this with clean install and got the above result. It seems that this affects other tables in the system as well but since i have headers I can resize the columns. Under VERSION CONTROL > SSH2 on the Known Hosts tab the table columns compress to single character.

    I’ve reinstalled the IDE a few times rebooting in between to make sure I’m not doing anything wrong on my end and I always get the same problem once I install the DevStyle plugin. Please advise since the filters help keep my system files from being scanned or modified by the team.

    Attachments:
    You must be logged in to view attached files.
    #672498 Reply

    wbritton
    Participant

    I also forgot to mention that the first tab (Pre-set filters) and the third tab (content) work just fine. It’s the second tab (User filters) tab I’m having an issue with. Thanks

    #672499 Reply

    aaronlonin
    Moderator

    @wbritton, let’s try something to know if it’s certain customization that’s causing this oddity.

    1. Shut down your eclipse
    2. Open your eclipse.ini (located at the eclipse installation directory)
    3. Add this line after -vmargs
    -Ddevstyle.enable.themedScrollbar=false
    4. Save the file and re-run Eclipse.

    Note that this will disable our flat scrollbars and things will look a little weird. Can you check if this solves the issue? If it does, then it’s something we can easily fix in DevStyle.

    Thanks!

    #672500 Reply

    wbritton
    Participant

    Yes, it did correct the problem to include the Known Host tab in SSH2.

    #672589 Reply

    wbritton
    Participant

    Any news on the next step to correct this issue or do I leave the entry in the INI file. Thanks for the help with this.

Viewing 7 posts - 1 through 7 (of 7 total)
Reply To: Exlipse 2020-12 + Poject Users Filters + Darkest Theme

You must be logged in to post in the forum log in