folder icons keep reverting to eclipse icons

This topic contains 30 replies, has 3 voices, and was last updated by  aaronlonin 3 months, 4 weeks ago.

Viewing 15 posts - 16 through 30 (of 31 total)
  • Author
    Posts
  • #617562 Reply

    aaronlonin
    Moderator

    Thanks for the logs! Sorry, it was my bad. I didn’t see the attached log the first time (I just missed it). I can’t see anything obvious right now. Your installation is a pretty standard one. I also work with a similar installation every day (including the use of git repositories) and icons look always just fine to me. We will keep investigating this issue.

    One thought I have is: The images definitions are stored in a file under your home directory at <user home>/.webclipse/replacement-images.json, is there any chance that directory gets reset by software you have in your system?

    #617594 Reply

    Alan
    Participant

    Hi Aaron,
    I can’t think of anything that would be doing that. The timestamp on that file (<home>/.webclipse/replacement-images.json) is March 9th, 2019, so I don’t think it is getting reset.

    #617950 Reply

    Alan
    Participant

    I have a screenshot (attached) of the issue showing up on another installation, on another machine, with another operating system:
    This is on an Amazon Workspaces Linux machine — the output of uname -a is
    Linux a-3qo5tec3wnuxz 4.14.123-111.109.amzn2.x86_64 #1 SMP Mon Jun 10 19:37:57 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

    The eclipse is jee 2019-06, no additional plugins added other than DevStyle and CodeMix

    It looks like eGit (part of the JEE package) may be interfering with DevStyle. The change in color background on things ignored in Git is particularly jarring in the “Dark Gray (Darkest Dark)” theme.

    Attachments:
    You must be logged in to view attached files.
    #617952 Reply

    Alan
    Participant

    I just made a new discovery — if I turn off the default workspace, I don’t get the issue. In other words, if the DevStyle workspace dialog appears, I don’t get the issue. If I set a default workspace so the workspace dialog does NOT appear, then I DO get the issue.

    • This reply was modified 4 months ago by  Alan.
    #617954 Reply

    aaronlonin
    Moderator

    That’s actually a great lead Alan. Thank you so much for the help investigating it. Then there might be an initialization issue. I will try to replicate right now at my end and see.

    Thanks!
    Aaron Lara

    #617957 Reply

    aaronlonin
    Moderator

    Alan, a quick question. Where did you turn off the default workspace from? From Preferences > General > Startup > Workspace Page or somewhere else?

    #617958 Reply

    Alan
    Participant

    Yes, that is where I turned off the default

    #617959 Reply

    aaronlonin
    Moderator

    Thanks, Alan! I was able to replicate the issue by doing that. We’ll keep investigating and hopefully get a fix soon.

    Cheers!

    #617969 Reply

    aaronlonin
    Moderator

    Alan, we already figured out the issue and we’ve got a fix for our next release. Would you be so kind of trying it out for us? Just to make sure it solves your issues.

    To do so:
    0. Shut down eclipse.
    1. Download and extract the attached plugins.zip file.
    2. Copy over the jar file into your eclipse/plugins/ directory and make sure you override the other one with the same name.
    3. Start eclipse and make sure the icons are correctly replaced and the white background color in eclipse explorer is also gone.

    Please let me know the results.

    NOTE: I was not able to replicate the white background color but the fix will potentially work for that issue as well.

    Thanks!
    Aaron Lara

    Attachments:
    You must be logged in to view attached files.
    #617983 Reply

    Alan
    Participant

    Hi Aaron,

    I’m afraid that does not fix it for me.
    1. placed com.genuitec.eclipse.startup_1.11.0.201906171242.jar into <eclipse base>/eclipse/plugins
    2. there was no existing com.genuitec…jar to replace — only an org.eclipse.equinox…jar
    3. starting eclipse after setting a default workspace still shows the same issue
    4. I tested on both OSes

    icons still revert to the standard eclipse icons if there is a default workspace

    #617985 Reply

    aaronlonin
    Moderator

    Alan, if there was no existing jar with the same name the patch won’t work. If you installed Eclipse using the Eclipse Installer (oomph), the plugins folder is located in a shared directory defined by oomph.

    If you are using a downloaded package (no eclipse installer) the location you mentioned is the right one but DevStyle might not be up to date. Can you check if you have more than one jar with name com.genuitec.eclipse.startup*?

    #618017 Reply

    aaronlonin
    Moderator

    Alan, if you are using the oomph installer the default location for the plugins folder is <home>/.p2/pool/plugins/.

    Cheers!

    #618024 Reply

    Alan
    Participant

    That works, on both machines – thanks!

    #618025 Reply

    aaronlonin
    Moderator

    Awesome! Was the white background issue solved too?

    #618028 Reply

    Alan
    Participant

    Yes, it was. thanks!

Viewing 15 posts - 16 through 30 (of 31 total)
Reply To: folder icons keep reverting to eclipse icons

You must be logged in to post in the forum log in