Git Authentication Issue – 2017 CI 1

This topic contains 4 replies, has 4 voices, and was last updated by Profile photo of support-swapna support-swapna 2 months, 1 week ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #508331 Reply
    Profile photo of VEGAS.com
    VEGAS.com
    Participant

    We upgraded from 2016 CI to 2017 CI and discovered an issue with authentication and git. There are 2 distinct login prompts that popup when trying to connect to a git repository that requires authentication. One has a checkbox asking whether to save the credentials and the second one does not. The 1st one actually functions correctly and after checking the box, it won’t show up again. The 2nd popup keeps showing up and entering credentials results in a 401 error. Simply hitting escape or cancelling out of the popup will allow access to the git repository. I believe that the issue stems from this bug that has already been fixed in Eclipse…

    https://bugs.eclipse.org/bugs/show_bug.cgi?id=501000

    Can it be fixed in CI 2 (if not sooner)?

    #508413 Reply
    Profile photo of support-swapna
    support-swapna
    Moderator

    VEGAS.com,

    Thank you for trying MyEclipse 2017. I could replicate the issue at my end. The fix will be part of the MyEclipse 2017 release when we update the base Eclipse version. We will keep you posted about the update schedule.

    Sorry for inconvenience caused.Please let us know if you see any issues.

    –Swapna
    MyEclipse Support

    #508596 Reply
    Profile photo of Tony Herstell
    Tony Herstell
    Participant

    Also affected.

    #508672 Reply
    Profile photo of Brian Fernandes
    Brian Fernandes
    Moderator

    We did identify the cause of this issue; as the original poster reported, it is indeed caused by the referenced bug. Due to an unfortunately misconfiguration, our builds did not include this fix.

    2017 CI 2 is due within the next couple of weeks and will include this fix.

    Apologies for the inconvenience caused.

    #511815 Reply
    Profile photo of support-swapna
    support-swapna
    Moderator

    MyEclipse 2017 CI 2 is out and it includes the fix for the Git authentication issue.
    Please update to CI 2 from menu Help > Check for Updates and let us know how it works for you.

    –Swapna
    MyEclipse Support

Viewing 5 posts - 1 through 5 (of 5 total)
Reply To: Git Authentication Issue – 2017 CI 1