initializing java tooling…… and then off to vapor space.

This topic contains 37 replies, has 17 voices, and was last updated by  support-joy 7 years, 11 months ago.

Viewing 15 posts - 1 through 15 (of 38 total)
  • Author
    Posts
  • #258762 Reply

    lee
    Member

    I start MyEclipse. IDE comes up. in lower right hand corner a message is displayed “initializing java tooling”. I click on detail button to monitor, it never shows any progress and just hangs.

    I also noticed that when I go into the prefereneces for a project, if I click on the build path button, the entire project will hang and I have to kill the java process to escape.

    How do I diagnose this problem. Everything was working fine this morning.

    I’m running version 3.2 of eclipse and 5.0 GA of MyEclipse.

    I’ve tried rebooting the machine but that didn’t help. I am able to recreate the problem everytime I start the IDE.

    lee

    #258814 Reply

    Riyad Kalla
    Member

    Lee,
    The first thing to do is to restart using the -clean option as outlined here:
    http://www.myeclipseide.com/PNphpBB2+file-viewtopic-t-10280.html

    see if that helps, if it doesn’t, try a new workspace:
    File > Switch Workspace > C;\tempworkspace, hit OK to restart.

    Now try those operations again, are they working?

    #294253 Reply

    I’m an IntelliJ user, unfortunately using myeclipse 7 since that is the default tool that our client uses. I’ve used myeclipse for a few days, although terribly slow I was able to setup my webapps and use it. However since the last 3 hours (that’s a 360$ billing rate to the client), I’ve been stuck with this problem.

    I tried “-clean” option and rebooted atleast eight times today.

    I can’t imagine that my client has purchased this software that doesnt even know how to start on its own. A pity, that I’m actually spending time in a forum to beg for help. (on how to start myeclipse without hanging)

    #294255 Reply

    Deleted entire workspace, works now. Takes another half hour hr to
    “setup” the workspace, perspective, server settings

    #294353 Reply

    Riyad Kalla
    Member

    infinity2heaven,

    Was the workbench locking up on startup like clockwork — in exactly the same spot every time? How long did you let it sit before killing the process and trying again?

    #296858 Reply

    I can’t believe I have the same problem again, and on searching on google, I revert back to this same forum!

    I think myeclipse completely goes for a toss when you add plugins in the dropin folder. It opens up and hangs forever at “Initializing Java Tooling ….” (30%) and that’s it.

    Do I want to delete my workspace? No.

    I’m forwarding this case study to my manager to convince them to use IntelliJ or atleast the default eclipse since this is unacceptable.

    #297201 Reply

    Sirron Davis
    Member

    I have the same problem. I try to start MyEclipse and it freezes at “Initializing Java Tooling” Always at 59%. The behavior is always the same, as soon as it gets to 59% the window showing memory jumps from around 300M to over 500M. And then the system freezes.

    As a test I modified my myeclipse.ini from “…. -Xms512M -Xmx512M …” to “… -Xms1024M -Xmx1024M …”

    That seemed to allow me to get past the problem. However, I do not know why all of a sudden I need to dedicate so much memory for this IDE. Also, after starting and getting past the Initializing Java Tooling, memory used drops back to the normal 300M range.

    What is happening in “Initializing Java Tooling” and why does it all of a sudden need so much extra memory?

    #297202 Reply

    I stopped using myeclipse. (Use core eclipse instead). It’s not worth fighting for

    #298008 Reply

    Sirron Davis
    Member

    ok, I found one very ugly work-around for this.

    The work-around is to move the .project file from my largest project (move to some other location outside of workspaces). This allows myeclipse to start. Of course that project will show in the Navigator, but not operate. After eclipse finishes with “Initializing Java Tooling”, then move the .project file back to its correct location, and open the project.

    MyEclipse is doing some large task with the project. And another large task with initializing java tooling. Together these chew up all memory.

    I don’t know what it is doing with the project, and I cannot find any options or preferences to stop it from doing whatever it is doing. But removing the .project file stops it.

    Also, note, after you move the project file back, you will need to wait as it does whatever it is doing before you try to do anything inside. (I usually try to wait 5-10 minutes – get morning coffee or tea during this time or catch up on net surfing.

    In my case the projects are PHP projects, so there is no compiling. And the .project file contains only the name of the project within the xml body. So I don’t know why it has to work so hard, but it does.

    One very frustrating thing I have found with eclipse.
    There is no way to see what is running in the background. So no way for an end-user of the application to address any problems. There is a “Progress” window which on occasion shows some titles, but it does not show most things (for example it does not show that eclipse is working with project at all)

    #298148 Reply

    Riyad Kalla
    Member

    SirronD,

    Can you paste the contents of the .project file as well as the .classpath file here of the offending project?

    Also can you give me a quick overview of what you have in /dropins, as well as what 3rd party plugins you have installed into MyEclipse?

    #298156 Reply

    Sirron Davis
    Member

    ~/eclipse/dropins is empty. I don’t know if there is another specific to MyEclipase. If so, tell me where to look.

    here is the project file (although there is really not much to see).

    
    <?xml version="1.0" encoding="UTF-8"?>
    <projectDescription>
            <name>includes</name>
            <comment></comment>
            <projects>
            </projects>
            <buildSpec>
            </buildSpec>
            <natures>
            </natures>
    </projectDescription>
    

    I have the following (according to the “Add/Remove Software”)
    Scala Eclipse Plugin
    Spring AJDT Extension
    Spring Mylyn Extension
    MyEclipse UML2
    SFTP Plug-in
    PHPeclipse
    Visualiser Plug-in
    Cross Reference Core Plugin
    Cross Reference UI Plugin
    MyLyn Task List (Required)
    Remote System Explorer End-User Runtime
    Eclipse FTP and WebDAV Support
    Subversion Client Adapter – Required
    Subversion Native Library Adapter (JavaHL) – Strongly Re….
    Subclipse – Required

    My projects are all PHP code, and I use Subversion/Subclipes to checkout/update/commit regularly in my project.

    #298204 Reply

    Riyad Kalla
    Member

    SirronD, thanks for the info. Given the project I have no idea what’s happening during the “Java Tooling” Stage that is taking so long — could be any one of those plugins. We’ll try and reproduce/investigate this on our end.

    #298207 Reply

    Sirron Davis
    Member

    Thanks.

    Also, I don’t think it is “Java Tooling” (or at least not java tooling by itself). I think it is something else going on with the project. So removing the project allows eclipse to start, and java tooling to run. Then moving the project file back causes whatever happens there. It is when both try to occur at the same time that the memory gets chewed up.

    Also If I remember to “Close ALL” before I exit eclipse, it will start up OK. But that is an extra step that really should not be required (or if it is required, there should be a “close all on exit” preference.

    #298562 Reply

    gbrinkmann
    Member

    @sirrond wrote:

    Also If I remember to “Close ALL” before I exit eclipse, it will start up OK. But that is an extra step that really should not be required (or if it is required, there should be a “close all on exit” preference.

    Thanks for the workaround hint (closing projects on exit)

    It would be cool if the devs could wrap some major exception catching and timeout handling around startup and project initialization…

    #302298 Reply

    I found that this problem can be solved by deleting (or renaming) the following directory:

    WORKSPACE_HOME/.metadata/.plugins/org.eclipse.core.resources/.projects

    This doesn’t seem to have effected my workspace adversely.

Viewing 15 posts - 1 through 15 (of 38 total)
Reply To: initializing java tooling…… and then off to vapor space.