JSP Validation issues in MyEclipse2017CI

This topic contains 4 replies, has 3 voices, and was last updated by Profile photo of Brian Fernandes Brian Fernandes 1 week, 3 days ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #542263 Reply
    Profile photo of B.Kaatz
    B.Kaatz
    Participant

    Well, I am not sure where exactly the problem lies in this case, but when I loaded my existing projects from Git into MyEclipse2017CI, I am getting a number of JSP Validation errors that I did not get from MyEclipse2015CI.

    Errors are things like “Syntax error on token “)”, try expected after this token” for the last closing paren of the ‘if’ in following block of code:

    Now, from the digging I have done on the Eclipse website, it seems there may be an issue with the JSP Validation from WTP within Eclipse. So, how does one go about resolving this?

    TIA for the assistance.

    #542419 Reply
    Profile photo of support-swapna
    support-swapna
    Moderator

    B.Kaatz,

    Sorry that you are seeing this issue. I could replicate the problem at my end. A bug is filed for the dev team to work on it. We will keep you posted about the fix.

    Apologies for inconvenience caused.

    –Swapna
    MyEclipse Support

    #542430 Reply
    Profile photo of Brian Fernandes
    Brian Fernandes
    Moderator

    I wanted to add a quick follow up to Swapna’s response. We’re going to prioritize this fix for the 2017 CI 10 release, CI 9 is due in a few days and it’s unfortunately a bit too late to put the fix in.

    If you happen to have the Eclipse bugs covering this issue handy, could you please pass them our way?

    Again, I realize how frustrating errors like this can be – apologies.

    #542448 Reply
    Profile photo of B.Kaatz
    B.Kaatz
    Participant

    Greetings and thank you both for your replies and attention to this matter.

    For examples of the same and/or similar problems with WTP validation in Eclipse, I found the following bug reports on https://bugs.eclipse.org/:

    So those are just a few of the bugs that come up for “JSP Validation” on Eclipse’s Bugzilla, and going through the StackExchange boards paints a picture that seems to be even worse with regards to WTP. So much so that many of the users on the StackExchange forums are looking at other plugins for JSP validation to bypass WTP’s JSP validation. (e.g. From the following page https://stackoverflow.com/questions/211841/is-there-a-good-jsp-editor-for-eclipse which, BTW, also gives a nod to MyEclipse for surpassing Eclipse’s capability for the same thing back in 2008.)

    So, I look forward to hearing from you soon and hope for a speedy resolution.

    Thanks again.

    • This reply was modified 1 week, 4 days ago by Profile photo of B.Kaatz B.Kaatz. Reason: Readjusting bug title to reflect properly
    • This reply was modified 1 week, 4 days ago by Profile photo of B.Kaatz B.Kaatz.
    #542503 Reply
    Profile photo of Brian Fernandes
    Brian Fernandes
    Moderator

    I was asking about the Eclipse bugs in case you had located one that corresponded exactly to the issue you were facing – thanks for the list.

    We do the JSP validation differently from Eclipse, which is why we are typically free from such issues, and in a much better state than Eclipse – unfortunately this case seems to have slipped through.

    We will keep this issue at high priority for the CI 10 release and I will let you know when a fix is available. Thanks!

Viewing 5 posts - 1 through 5 (of 5 total)
Reply To: JSP Validation issues in MyEclipse2017CI