myeclipse 2023.1 Offline Installer Error and Log File

  1. MyEclipse IDE
  2.  > 
  3. Installation, Configuration & Updates
Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #696908 Reply


    I have Windows 11 installed on my machine. I’m not sure if that is the issue but I have had success with the windows installer on my Windows 10 machine. This is the one I downloaded:


    When running this exe I get a loading bar which results in the following message:

    An error has occurred. See the log file [location redacted]

    It seems like the installer is somehow using Java 1.7 to start but it requires at least 1.8. I have Java 17 installed and my PATH variable is set to Java 1.8 so that when I do java -version I get 1.8.

    What does the installer use to configure the version of Java to use? How can I get the installer to find Java 8 or 17?

    Here is the top portion of the log file:

    !SESSION 2023-06-08 10:23:11.050 ———————————————–
    java.vendor=Sun Microsystems Inc.
    BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US
    Framework arguments: [redacted]
    Command-line arguments: -os win32 -ws win32 -arch x86_64 [redacted]

    !ENTRY com.genuitec.pulse.installer.common 4 0 2023-06-08 10:23:11.894
    !MESSAGE FrameworkEvent ERROR
    !STACK 0
    org.osgi.framework.BundleException: Could not resolve module: com.genuitec.pulse.installer.common [3]
    Unresolved requirement: Require-Bundle: com.genuitec.pulse.client.common.widgets; bundle-version=”4.0.0″; visibility:=”reexport”
    -> Bundle-SymbolicName: com.genuitec.pulse.client.common.widgets; bundle-version=”5.4.2.v201706081620″
    com.genuitec.pulse.client.common.widgets [21]
    Unresolved requirement: Require-Bundle: com.genuitec.pulse2.common
    -> Bundle-SymbolicName: com.genuitec.pulse2.common; bundle-version=”5.4.1.v201705111300″; singleton:=”true”
    com.genuitec.pulse2.common [23]
    Unresolved requirement: Import-Package: com.genuitec.pulse.compatibility
    -> Export-Package: com.genuitec.pulse.compatibility; bundle-version=”5.4.1.v201705111300″; bundle-symbolic-name=”com.genuitec.pulse.compatibility.e36″; version=”5.4.1″
    com.genuitec.pulse.compatibility.e36 [34]
    Unresolved requirement: Require-Bundle: org.eclipse.core.net; bundle-version=”1.2.0″
    -> Bundle-SymbolicName: org.eclipse.core.net; bundle-version=”1.3.0.v20160418-1534″; singleton:=”true”
    org.eclipse.core.net [26]
    Unresolved requirement: Require-Capability: osgi.ee; filter:=”(&(osgi.ee=JavaSE)(version=1.8))”

    #696909 Reply


    I solved my own problem. It wasn’t Windows 11 related.

    I used the advice from this other post: https://www.genuitec.com/forums/topic/myeclipse-and-jdk-9/#post-538337

    Which was to run the installer from the command line (in my case PowerShell) and use the -vm argument with the location of the bin directory of jdk 1.8 that I have installed as the argument parameter.

    The Installer worked after that and bypassed the Java 1.7 issue which can be recognized by the error log stating the following:



    Unresolved requirement: Require-Capability: osgi.ee; filter:=”(&(osgi.ee=JavaSE)(version=1.8))”

    #696924 Reply

    Brian Fernandes

    Glad you were able to proceed with the installation. As you noticed, the installer does need Java 8, and we embed a JRE in the installer in case your system doesn’t have a compatible Java. However, it looks like it doesn’t perform this check correctly, so this is something we will fix in a future release.

    Apologies for the inconvenience caused and thank you for the report!

Viewing 3 posts - 1 through 3 (of 3 total)
Reply To: myeclipse 2023.1 Offline Installer Error and Log File

You must be logged in to post in the forum log in