MyEclipse not responding after installing CodeMix

This topic contains 14 replies, has 6 voices, and was last updated by  Brian Fernandes 2 months, 2 weeks ago.

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #586351 Reply

    Mike_mikekonikoff
    Participant

    Editing files (java, jsp, js, xml) that I have had no problem editing before using default MyEclipse editors. Now when I type anything – code, space, or a comment – I get a spinning blue progress wheel and MyEclipse is Not Responding for a long time (dozens of seconds or longer). This only started happening after installing CodeMix. I have 64-bit MyEclipse 2017 CI latest and latest CodeMix, on Windows 7 pro 64-bit, java 8, 32 GB RAM and 2 quad-core i7 CPU @ 2.7 GHz. MyEclipse and computer have been restarted.

    Maybe it is https://www.genuitec.com/issue-tracker/33081/, but I can’t see any details there so it’s hard to say. Whatever it is, it is making this IDE unusable.

    #586352 Reply

    timwebb
    Keymaster

    Ouch! First off, I’m not aware of a specific issue like this lingering in the product but definitely want to get to the bottom of it!

    To disable CodeMix temporarily, you can go to the Preferences > CodeMix area and check [ ] Temporarily disable CodeMix functionality.

    That said, I’d really like to be able to get to the bottom of this. Two questions – bottom left, do you see CodeMix with a blue checkmark in your status bar? If it shows connected, if it freezes long enough to run a command, getting a jstack dump at the same time as it is frozen would be invaluable.

    https://helpx.adobe.com/in/experience-manager/kb/TakeThreadDump.html
    has some pointers on how to use jstack. In short, it is jstack -p <pid> with the PID of the MyEclipse process.

    Thanks and sorry you are hitting this!

    #599793 Reply

    Mike_mikekonikoff
    Participant

    This issue went away for a while, thankfully. I could not debug it, and I assumed it was something fixed in a later update. Now I’ve updated to CodeMix 2 and … after an hour I’m still waiting for CodeMix Validation task to complete, while editors are either very slow or unresponsive. Project has thousands of files, a huge legacy project with mixture of html, js, java, jsp, xml, etc … Can this be fixed apart from turning off validation? Like run validation separately and at a lower priority than UI responsiveness.

    #599794 Reply

    timwebb
    Keymaster

    Can you grab a quick screenshot of the validators that are running in the Progress view? CodeMix’s validators by default do not do (or should not do) any validation until you opt-in to run them in CodeMix 2. A screenshot will help confirm what validator(s) are impacting your workspace.

    #599805 Reply

    Mike_mikekonikoff
    Participant

    It finally finished and things are back to normal after a couple hours of validation. I do have CodeMix Project Validation enabled…do you want screen captures of all those settings? The progress view just said CodeMix Validation, and then something like 1,975 of 3,995 files… The problems view is showing 56,643 errors, most of which are in old JSP code that we are in process of refactoring / purging. I will try turning off JSP validation and see if that helps.

    Bottom line for me is: validation is great, but shouldn’t come at expense of rest of IDE. Editors, search, team synchronization, just about everything I use regularly was painfully slow while validation was running. It’s back to normal now, which is great <whew!>, but I’d like to avoid this when I open up other projects that are currently closed (and are branches of the project I’m working on).

    #599806 Reply

    timwebb
    Keymaster

    Absolutely agree that validation shouldn’t be so exhausting (by any measure). I don’t believe CodeMix Validation should have been running on JSP code, though you can configure in CodeMix > Languages area what is validated of course. The other thing that may prove useful is if you have a bunch of static old libraries, you can configure exclude rules for directories that should never be validated. My guess would be that it was validating a bunch of old JavaScript, though we do have default patterns to skip validation of minified and other traditional formats for JavaScript.

    Most interesting would be a quick check if HTML+JS might have equaled the 3,995 files you saw validating? If the only file pattern is JSP, then screenshots of the different pages under Validation would be helpful, including the disabled validators area and the Languages section that controls file extensions around JSP (it should be unchecked by default).

    Thanks for all the details.

    #599809 Reply

    Mike_mikekonikoff
    Participant

    Off topic kinda, but there are tons of js validation errors like:

    Cannot find name ‘jQuery’

    Cannot find name ‘ko’

    Is there a way I can tell the validator, “there’s a thing in my project called jQuery (you might know it as $), and there’s another thing called ko (also known as knockout).”

    #599810 Reply

    timwebb
    Keymaster

    The easiest may be to just turn off stricter JavaScript validation by changing the javascript.implicitProjectConfig.checkJs which gives validation more like you would expect with TypeScript.

    I’ll ask the gurus about your Q though regarding mapping names like that during validation.

    #599811 Reply

    Mike_mikekonikoff
    Participant

    I looked through the validation config and I believe it’s all the defaults with *.jsp excluded, as you said. Exception I think is Velocity from the eclipse marketplace vscode extension.

    With all that I get in the neighborhood of 3,995:

    1979 *.js*
    450 *.htm*
    346 *.xml
    289 *.css
    14 *.less
    1246 *.vm
    9 *.xsl
    4 *.sql
    3 *.sh

    I also put the javascript.implicitProjectConfig.checkJs = false and those jQuery and ko errors are gone. Thanks for that! BTW I saw this mentioned in the sticky post Troubleshooting CodeMix 2 (READ FIRST) but it has a typo there javascript.implementProjectConfig.checkJs so I was confused.

    #605942 Reply

    jeffreyblyseth
    Participant

    Hi, jumping in to add a voice/experience on this. I installed CodeMix in Eclipse last week to work on a VueJS project. It progressively gets so slow that it becomes unusable. Exactly the experience that Mike reported. The difference is that there is no validation going on in the background. In fact, the progress console shows no activity. This morning I temporarily disabled CodeMix and the IDE is back to normal. But now I REALLY miss it and didn’t even realize how helpful it was on .vue files. Has there been any more progress on this kind of behavior?

    #605950 Reply

    jeffreyblyseth
    Participant

    I thought I would try to re-enable CodeMix. After it was re-enabled it is much faster. In the interim I had modified the settings json to include a path to php7. Not sure if that was related, I doubt it. I’ll keep you posted if it slows down again.

    #606026 Reply

    support-tony
    Keymaster

    Jeffrey,

    Thanks for your observations and will let the development team know. Please do let us know if you start to see the problem again, and please include as much information about your set-up and scenario as possible, to help us investigate.

    Thanks also for your comments on what CodeMix gives you, it’s great to get confirmation that we’re making a difference!

    #606089 Reply

    jeffreyblyseth
    Participant

    Hey Guys,
    Back again. So it’s been about 2 days of dev since my last post, about 20 hours of work in total, no shutdowns or restarts. Today the same thing started happening. Getting SUPER slow, to the point that I can type “console.log(“, go get a cup of coffee, and come back to watch it type onto the screen. This time, rather than disabling CodeMix, I just restarted Eclipse and boom, back in business. Fast again. I’m running:
    Eclipse IDE for PHP Developers
    Version: Photon Release (4.8.0)
    Build id: 20180619-1200
    on MacOS 10.11.6

    This won’t stop me from using the product, but it definitely impacts my workflow negatively. Let me know if I can provide any system vars or other info. I’ll be curious to see if my work computer which is running High Sierra and is newer will have the same issues when I get back to the office in 2 days.

    #606151 Reply

    support-swapna
    Moderator

    Jeffrey,

    Thank you for the details and sorry about the negative experience.

    If you could get 3-4 thread dumps during the period of slowness, that would help us figure out what process is running. To take a thread dump, you will need to run
    jstack -l 9000 > dump1.txt
    Please replace 9000 with the PID of the Eclipse process, the jstack program can be found in the bin directory of any JDK installation. If you can generate 3-4 dumps (sent to different files, of course) during the period of slowness, and attach those files here, that could help a great deal.

    Apologies for inconvenience caused.

    –Swapna
    Genuitec Support

    #606177 Reply

    Brian Fernandes
    Moderator

    Jeffrey,

    1) If you can catch us on Live Chat, we have some diagnostic tools that would make it easier for us to figure out what is going on with your installation. You do need CodeMix installed, and you can get into Live Chat from Help > CodeMix > Live Chat.

    2) We’ve recently noticed a few users experiencing performance issues with the TypeScript Hero extension. If you go to Help > codeMix Extensions, can you see if you have this installed? If yes, uncheck the box next to the extension to disable it. Please let us know if this fixes your performance issues.

Viewing 15 posts - 1 through 15 (of 15 total)
Reply To: MyEclipse not responding after installing CodeMix