openSuse and error "Failed to get tabs for debugging Connection refused"

Tagged: ,

This topic contains 5 replies, has 3 voices, and was last updated by  support-tony 4 months, 1 week ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #547225

    Petr
    Participant

    I tried openSuse and Fedora with KDE or GNOME.

    I installed the chrome and I set it as a default browser.
    I created a Angular project from menu and I don’t changed it.
    I tried debug the project and the error is displayed each time.

    I start the chrome from the menu and I entered url http://localhost:4200/. The index page is displayed. The debugging does not work.

    #547296 Reply

    support-swapna
    Moderator

    Petr,

    Sorry that you are seeing this issue. We could not replicate the debugging problem at our end on OpenSUSE.

    Can you please give us some more details?

    1. Are you behind a firewall or proxy?

    2. Can you please let us know if you have changed any preferences in the workspace?

    3. How exactly are you debugging the project? Is it using Debug As > Angular Web Application or are you using a custom Debug launch? If you are using a custom launch, then please share with us the screenshot of the launch window.

    4. Please share with us the Node.js, NPM and Angular CLI versions of the project you created. Also share with us the .log file located at workspace dir/.metadata/.log to help us get the complete error details.

    Apologies for inconvenience caused.

    –Swapna
    MyEclipse Support

    #547435 Reply

    Petr
    Participant

    add 1)
    I installed pure system on virtualBox. I did not change any parameters of proxy or firewall.

    add 2)
    I set path for Google chrome, picture 02-launchProperties.

    add 3)
    I describe it in the picture 01-debug.

    add 4)
    Java: java-1.8.0-openjdk-1.8.0
    NPM version: 5.5.1
    Angular CLI: 1.6.3
    Node: 8.9.3
    OS: linux x64
    Angular: 5.1.2
    typescript: 2.4.2
    webpack: 3.10.0

    file with log: log.txt

    Thank you
    Petr

    Attachments:
    You must be logged in to view attached files.
    #547493 Reply

    support-tony
    Keymaster

    Petr,

    Thanks for the information. As yet, we’ve been unable to replicate the problem but there’s a way to collect more information about the debugging session which may help.

    Right click on your server (“TestAng”, in the Servers view) and select Properties. Now click the Browser tab and select the options “Show Chrome process console” and “Show remote debugger connection console” as shown the attached image. You might also want to deselect the “Enable Live Reload” option as CodeLive and this option can interfere in debug mode (or else, deselect COdeLive on the server). Click OK. Start the server and then attempt to start a debugging session. If may see up to 3 consoles in the Console view. Click on the “Display Selected Console” icon (highlighted in the second image) to cycle through the consoles. For each console, use Ctrl+A to select the text then copy and paste it into a file. Attach the files here.

    In addition, please let us know the version of Chrome that you are using.

    It’s possible that, with the issue you’re seeing, you won’t get any console output but it’s worth a shot, as we try to figure this out.

    Attachments:
    You must be logged in to view attached files.
    #547586 Reply

    Petr
    Participant

    Problem solved.

    Chrome console prints:
    [6006:6006:0109/192628.163663:ERROR:zygote_host_impl_linux.cc(88)] Running as root without –no-sandbox is not supported. See https://crbug.com/638180.

    I set property “Custom arguments” to “–no-sandbox” and it works.

    Thank you for help.

    Petr

    #547610 Reply

    support-tony
    Keymaster

    Petr,

    Thanks for letting us know. It’s odd that running as root doesn’t work but, as we don’t recommend doing that, we don’t do specific testing for that situation.

    I’m glad you got it working.

Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘openSuse and error "Failed to get tabs for debugging Connection refused"’ is closed to new replies.