facebook

Problem starting Vue development server

  1. CodeMix & Angular IDE > Getting Help
Viewing 1 post (of 1 total)
  • Author
    Posts
  • #671986 Reply

    truantkernel
    Participant

    Hello,

    I’ve been working with CodeMix Release CI 2020.7.22 on Eclipse IDE for Enterprise Java Developers 2020-09 (4.17.0), and for the most part, everything has been well; the Vue development server launches successfully. However, upon configuring Vue’s development server for https by adding ‘https: true’ to the vue config file, attempting to launch the embedded node server results in a successful deployment that’s navigable on the browser, however the server crashes within minutes. After starting the server, its listing in the Server panel displays the ‘[Starting]’ and the Progress panel a ~70% progress bar for starting the server, with the status “Preparing launch delegate…: waiting for the server to start…”.

    Eventually the server crashes and a Server Start Timed Out prompt is displayed, with a button to Configure URL. I have tried the automatic detection option, and I have tried explicitly configuring the URL with the ‘Use this URL’ option. Node reports that the app is running at https://localhost:443/ and I have attempted to use this url as is as well as with other modifications such as without the trailing slash, without the port, and without the protocol – to no avail. If automatic detection of the URL is used, then the exclusion of “https: true” in the Vue config allows the server to remain up without this problem manifesting, but once it’s added, CodeMix does not allow the server to stay online. The server can be started via command line with no problem, however it would be nice if I could use the server controls in eclipse’s Servers panel but this apparent bug is preventing me from doing so.

    The dialog message:
    CodeMix has been unable to connect to the URL that has been configured on the server. This is done by attempting to connect the configured https://localhost:443

    The logs show one relevant exception that repeats:

    java.lang.Exception: Timed out waiting for server to start. Please ensure you have run npm install command.
    	at com.genuitec.eclipse.code.core.common.GenuitecCoreException.(GenuitecCoreException.java:89)
    	at com.genuitec.eclipse.code.core.common.GenuitecCoreException.(GenuitecCoreException.java:57)
    	at com.genuitec.eclipse.code.npm.server.NpmServeProjectServerLaunchConfigDelegate.lambda$0(NpmServeProjectServerLaunchConfigDelegate.java:263)
    	at com.genuitec.eclipse.code.npm.server.NpmServeProjectServerLaunchConfigDelegate$$Lambda$1350/0000000000000000.run(Unknown Source)
    	at com.genuitec.eclipse.code.vU.AS__11116alk23n42cana(Unknown Source)
    	at com.genuitec.eclipse.code.npm.server.NpmServeProjectServerLaunchConfigDelegate.launch(NpmServeProjectServerLaunchConfigDelegate.java:145)
    	at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:807)
    	at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:718)
    	at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:713)
    	at com.genuitec.eclipse.code.npm.server.NpmServeProjectServerDelegate$2.run(NpmServeProjectServerDelegate.java:168)
    	at com.genuitec.eclipse.code.common.core.node.server.delegate.NodejsProjectServerDelegate$ServerTasksJob.run(NodejsProjectServerDelegate.java:123)
    	at org.eclipse.core.internal.jobs.Worker.run(Worker.java:63)

    A somewhat similar topic was found here, but offered little help in my case
    https://www.genuitec.com/forums/topic/angular-ide-problem-starting-angular-cli-server/

    My operating system is windows 7 professional SP1

    Is there some sort of work around so that I can start the server and still use HTTPS?

    • This topic was modified 7 months, 2 weeks ago by truantkernel.
    • This topic was modified 7 months, 2 weeks ago by truantkernel.
    • This topic was modified 7 months, 2 weeks ago by truantkernel.
    Attachments:
    You must be logged in to view attached files.
Viewing 1 post (of 1 total)
Reply To: Problem starting Vue development server

You must be logged in to post in the forum log in