Wildfly 18

This topic contains 12 replies, has 3 voices, and was last updated by  Brian Fernandes 2 days, 1 hour ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #627288 Reply
    Tony Herstell
    Tony Herstell
    Participant

    Hi Team,
    Wildfly 18 has just been released with various goodies.
    Please, can you push an update for this server connecter; thx.
    Should be similar to 16 connector…

    #627490 Reply

    support-swapna
    Moderator

    Tony,

    Thank you for the heads-up. I have filed an ER to support WildFly 18 in MyEclipse.

    –Swapna
    Genuitec Support

    #628307 Reply
    Tony Herstell
    Tony Herstell
    Participant

    I am using the wildfly16 connector but pointing at Wildfly18 and it seems to work ok (for now).
    I did try JSF 2.3 but not supported (probably as not supported in Wildfly 16) – keen to explore the new HTML5 server push capability.
    I also tried Java 13; but it seems the facet only goes up to Java 11.

    • This reply was modified 1 month, 3 weeks ago by Tony Herstell Tony Herstell.
    #628350 Reply

    support-swapna
    Moderator

    Tony,

    Thank you for reporting your findings. The dev team has targeted WildFly 18 support for the next MyEclipse release.
    We will keep you posted when it is out.

    –Swapna
    Genuitec Support

    #629998 Reply
    Tony Herstell
    Tony Herstell
    Participant

    Any update team?

    I am trying to go with Wildfly 18, Java 13.

    #630181 Reply

    Brian Fernandes
    Moderator

    Tony,

    Sorry for the delayed response. We’re working on the MyEclipse release right now, I believe the WF 18 connector is already in place. However, there are many other changes to include and it will be at least another month until available. We will be doing a base Eclipse update to pick up support for Java 13 as well.

    #632754 Reply
    Tony Herstell
    Tony Herstell
    Participant

    > be at least another month until available
    > We will be doing a base Eclipse update to pick up support for Java 13 as well
    Any update?

    #632990 Reply

    Brian Fernandes
    Moderator

    Tony,

    The next release of MyEclipse is in its final stages of development and testing. We hope to have a release next week. Java 13 support is in as well (we’re going to base it on Eclipse 4.13/2019-09). Thank you for your patience, we’re almost there!

    #633704 Reply
    Tony Herstell
    Tony Herstell
    Participant

    Great the new versions is out.
    I got this pop up (investigating) – see image.
    I don’t use Spring (have not used Spring for years).

    FOUND…
    It was pulled in via a 3rd party part of the pom.. I have stopped that and the problem has gone.

    Attachments:
    You must be logged in to view attached files.
    #633707 Reply
    Tony Herstell
    Tony Herstell
    Participant

    A little confused
    I cannot set the JDK compliance level to 13
    Still trying to set things up…

    Attachments:
    You must be logged in to view attached files.
    #633709 Reply
    Tony Herstell
    Tony Herstell
    Participant

    I cannot select 13 for runtime environment…

    Attachments:
    You must be logged in to view attached files.
    #633728 Reply
    Tony Herstell
    Tony Herstell
    Participant

    I have totally re-installed MyEclipse (cleaned out everything I could find).
    Set up servers and java again.
    Imported projects… (I did notice they don’t seem to be well faceted now)
    Attached is the showstopper when I gave up for now.
    Java 13
    Wildfly 18.0.1

    Attachments:
    You must be logged in to view attached files.
    #633782 Reply

    Brian Fernandes
    Moderator

    Tony,

    Please download and install this package for Java 13 support – it can be installed alongside your existing MyEclipse installation.

    The Java 13 support in Eclipse is actually still in Preview mode (until the Eclipse update in a couple of weeks AFAIK), and we’ll be formally including it in a MyEclipse release next year. Due to internal miscommunication, I had assumed this support was still making it to the release we put out yesterday, which was not the case. Hopefully the above package, which does include the preview support for Java 13, will keep you going until the formal release.

    Apologies for the inconvenience caused, please let us know if this works for you.

Viewing 13 posts - 1 through 13 (of 13 total)
Reply To: Wildfly 18

You must be logged in to post in the forum log in