Buildship gradle plugin failed to import projects

This topic contains 1 reply, has 2 voices, and was last updated by  support-swapna 12 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #534573 Reply

    kmdhali
    Participant

    I have a gradle project, I wanted to import the project in MyEclipse . I installed Buildship plugin (version 2.x , e45) for importing the project. After importing, I got the error “No project modules assigned to enterprise project”. What modules it is trying to refer ? I tried –>https://www.genuitec.com/forums/topic/no-project-modules-assigned-to-enterprise-project-2/ . But that did not resolve the issue . I also tried add/remove modules. Also tried to create a project first before importing into MyEclipse using command line ($gradle eclipse eclipsewtp ).

    Import method : File->Import->”Importing Existing gradle Project”
    Eclipse version MyEclipse 2015 , Gradle version – 3.2 .

    Any body faced the issue already? Any ideas / suggestion will be highly appreciated .

    #534588 Reply

    support-swapna
    Moderator

    kmdhali,

    MyEclipse 2015 is based on Eclipse 4.4.x. The plugins you are installing to MyEclipse 2015 must be compatible with Eclipse 4.4.x. So please use the Buildship update site for Eclipse 4.4.

    If you are importing an EAR project, then the project must be associated with Web/EJB/Connector modules/projects. If there are no associated modules imported along with the EAR project, then you should create them in the workspace and add to the project.

    If the issue with import persists even after installing Buildship for Eclipse 4.4, then please check if these suggestions help :

    1. Right click on the project > Properties > MyEclipse > Deployment Assembly. Check if the modules are listed here. If none of the modules are listed in this window, then click ‘Add’, select ‘Project’ and choose the required modules. Please refer to this link for more details about MyEclipse Deployment Assembly : https://www.genuitec.com/docs/servers/deployment-assembly/

    2. If the Deployment Assembly is configured correctly and if the modules are selected in the Project References property page (right click on the project > Properties > Project References), then clean build the projects from menu Project > Clean and check.

    3. Right click on the project > Gradle > Refresh Gradle Project and check if it helps fix the issue.

    If none of the suggestions help, then please send us the zipped Gradle project along with MyEclipse Build Id and Version details from Help > About MyEclipse section to help us replicate the problem at our end. I also suggest you check with Gradle/Eclipse forums for any suggestions about EAR project import.

    Please also note that versions earlier than MyEclipse 2016 are no longer fully supported. We try and assist licensed users working with previous versions but no fixes will be made to those versions. If possible, upgrade to MyEclipse 2017, our latest version based on Eclipse Neon. You can install MyEclipse 2017 alongside your existing MyEclipse 2015 install and use your current license.

    –Swapna
    MyEclipse Support

Viewing 2 posts - 1 through 2 (of 2 total)
Reply To: Buildship gradle plugin failed to import projects