MyEclipse – very slow startup

This topic contains 12 replies, has 3 voices, and was last updated by  lainhart 1 week ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #621554 Reply

    lainhart
    Participant

    As of late, MyEclipse takes 5-10 minutes to go from the splash screen to the IDE opened on the workspace. The process consumes 50-75% of the CPU and power. I don’t know what I could have done of late that would cause this to occur. CodeMix is disabled.

    I’ve run jstack against the process’ PID and have attached the results here.

    Thanks for your suggestions. I’ll be out for around a week and will check in later.

    — Todd

    Attachments:
    You must be logged in to view attached files.
    #621664 Reply

    afxgroup
    Participant

    Same here.. is a pain now. Using Windows 10 and JDK8

    #621736 Reply

    Brian Fernandes
    Moderator

    Sorry to hear you are running into this; 5-10 minutes to start is definitely not expected.

    First, just to get something obvious out of the way, If you haven’t read our post on Windows Defender causing slow starts, do read and see if making the changes suggested helps: https://www.genuitec.com/stop-slow-eclipse-myeclipse-startups/

    Todd – thanks for taking the trouble to send us the dump, unfortunately nothing obvious in there.

    afxgroup – I know we discussed this before, where you said the latest version of MyEclipse made it fast again. I’m guessing you are now using 2019.4 and this is no longer true? Any changes since our previous discussion?

    1) If you shut down MyEclipse and start again in the same session, does it still take the same amount of time?
    2) Can you both try switching to a blank workspace to see if the workspace and/or the set of projects you’re working with is causing the slowdown?
    3) Any additional plugins added to the installation?

    #622142 Reply

    Brian Fernandes
    Moderator

    afxgroup,

    Just checking in – were you able to try any of the steps I mentioned above? Would be happy to look deeper into this as required.

    #622911 Reply

    lainhart
    Participant

    Hi Brian –

    Some feedback on my end. After being away for a week, I restarted my machine and saw a quick startup for MyEclipse – < 1 min. I then ran a CodeMix update (I have CodeMix disabled) and I’m back to seeing slow startups. Not as slow as before, but in the range of 3 minutes.

    I tried opening MyEclipse on an empty workspace, and see the same startup time.

    Installation details below:

    #622914 Reply

    Brian Fernandes
    Moderator

    lainhart,

    Some really quick questions:
    1) Did you re-enable CodeMix to take the update? Or did the update take place automatically? Is CodeMix now enabled after the update?
    2) If CodeMix is enabled, does disabling it make any difference?
    3) Can you please see my post here about uninstalling the Icon Designer if you have DevStyle installed? If you do have it installed, please follow the steps mentioned in this thread and let us know if it makes a difference.

    #622952 Reply

    lainhart
    Participant

    Hi Brian –

    Responses to your questions:

    1) I did not re-enabled CodeMix – the update happened automatically (or at least, after I selected “review” and update). After the update/restart, CodeMix was not re-enabled.
    2) As in above, CodeMix was not enabled, and has not been enabled for a while.
    3) I read the post you referenced. I disabled “Startup Experience” in the DevStyle preferences, and that made no difference in reducing startup time. I looked in the installed software (“Help/Install from site…”), and I do not have the Icon Designer installed.

    I continue to see ~3-4 minute startup times.

    — Todd

    #623178 Reply

    Brian Fernandes
    Moderator

    Todd,

    Did you read the Windows Defender blog post I referenced at the start of this thread?
    https://www.genuitec.com/stop-slow-eclipse-myeclipse-startups/

    Sorry I have to explicitly ask about this because it would explain why you see increased startup time, only after taking the most recent CodeMix update. We now pack the CodeMix engine into the CodeMix plugins, because of which Windows Defender, if enabled, has even more to scan in your MyEclipse installation and could adversely affect startup time.

    If it’s not Windows Defender, can you turn on the workspace selection prompt (if not already on) and let us know if you see most of the time taken to get to the prompt or post the prompt, after a workspace is selected?

    #623270 Reply

    lainhart
    Participant

    Hi Brian –

    I did see that reference. I’m not running Windows defender – our shop uses “AVG Business” (I posted in another thread – https://www.genuitec.com/forums/topic/latest-myeclipse-updates-triggers-anti-virus-block-2 – about an issue I found there).

    I normally start MyEclipse from a shortcut, with the target looking something like this: “C:\MyEclipseCI\myeclipse.exe -data c:\eclipseWorkspaces\testWorkspace -showLocation”

    Just now I started MyEclipse via double-click in the Windows Explorer. Almost all of the wait time was in the splash dialog, waiting for the workspace selection dialog to open. About 2-3 minutes. Once I selected a workspace, I waited ~20 seconds for the IDE to open and settle.

    #623763 Reply

    afxgroup
    Participant

    No way.
    I’ve disabled everything you advice, added the exception on windows defender. It takes 5-6 minutes to start. It is really a pain

    #623780 Reply

    Brian Fernandes
    Moderator

    afxgroup,

    a) We’re actively researching this issue based on your reports. Apparently a recent change to Windows / Windows Defender seems to have made the process exclusion outlined in the article ineffective.
    The working solution right now appears to be excluding the folder in which MyEclipse is installed from Windows Defender, as opposed to a process exclusion. Can you please try this instead and let us know if it helps?
    I want to reiterate that we’re still looking into what is going on with Windows Defender and will update this thread accordingly.
    b) I’ve asked a couple of additional questions in my post which you haven’t answered, would appreciate some explicit answers because we’ve been unable to replicate issues beyond Windows Defender so far.

    1) If you shut down MyEclipse and start again in the same session, does it still take the same amount of time?
    2) Can you both try switching to a blank workspace to see if the workspace and/or the set of projects you’re working with is causing the slowdown? – I’m assuming this did not make a difference.
    3) Any additional plugins added to the installation?

    #623783 Reply

    Brian Fernandes
    Moderator

    Todd,

    Just now I started MyEclipse via double-click in the Windows Explorer. Almost all of the wait time was in the splash dialog, waiting for the workspace selection dialog to open. About 2-3 minutes. Once I selected a workspace, I waited ~20 seconds for the IDE to open and settle.

    This sounds just like what Windows Defender does, it’s likely that AVG is doing something similar, scanning the installation before allowing it to execute. You may have already tried this, but if not, would it be possible to temporarily disable AVG and see if/how that affects startup speed?

    We’re getting set up here to start testing with AVG and a few other A/V solutions as well.

    #623826 Reply

    lainhart
    Participant

    Brian –

    I disabled AVG, and saw 2.5 minutes from splash screen to IDE/workspace. So no change.

    I forgot to mention that I placed the c:\MyEclipseCI directory in the scan exception list a while ago, to apparently no affect.

    — Todd

Viewing 13 posts - 1 through 13 (of 13 total)
Reply To: MyEclipse – very slow startup

You must be logged in to post in the forum log in