No startup experience again

  1. DevStyle
  2.  > 
  3. Getting Help
Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #681612 Reply


    Previous messages indicated that sometimes the startup experience fails to, well, start. This has happened on my install now as well. It used to be working just fine and then it just stopped. Please note that I have this installed on STM32CubeIDE, which is just an Eclipse IDE. What I’ve tried:

    1. Verified that the General->Startup and Shutdown->Workspaces->”Prompt for workspace on startup” option is CHECKED
    2. Verified that the DevStyle->”Use the Startup Experience” option is CHECKED
    3. Unchecked, applied, and restarted the IDE and then checked, applied, and restarted the IDE
    4. Starting the IDE with the -clean option
    5. Uninstalling DevStyle and reinstalling
    6. Uninstalling the IDE, deleting all IDE-related folders and preferences, and reinstalling

    So far, nothing has worked.

    The Eclipse built-in workspace selection dialog works if DevStyle is not installed. The frustrating thing is that even if there’s a default workspace selected, it won’t open it, and starts the IDE with no workspace active.

    Any clues or other things I can try?

    #681613 Reply


    Thanks for sharing all the details of what you have attempted.

    The only ‘interesting’ change in the most recent release of DevStyle was related to adjusting a dependency to Apache HttpClient, specifically migrating from an older one to a more recent. We do not bundle the library as it is available in older and newer versions of Eclipse.

    What appears to be happening on first investigation is that the dependency change is causing one of STM32CubeIDE’s plugins to get activated early, and that plugin has a dependency to the Resources plugin in Eclipse which triggers the workspace to be initialized. As an example if a “STM Foo” fictitious plugin had some core logic for STM and exported packages containing Apache HttpClient, we can get wired into that. When we initialize classes that depend on HttpClient, it triggers activation of Foo in this example. Currently we haven’t had an opportunity to track down if this is exactly what is happening but based on an initial investigation it appears to be the case.

    Have you tried passing in -data on the command line to tell Eclipse preemptively what workspace to use, bypassing the prompt?

    #681614 Reply



    In addition to the -data args, the other workaround is to install a previous version of DevStyle. Please see this thread for workaround suggestions.

    Apologies for inconvenience caused.

    Genuitec Support

    #681616 Reply


    Thanks for the response. I had missed that post since it was in the “Theme Problems” forum, and I didn’t really think to look there for a general problem with the plugin.

    In any event, yes, the -data argument works, which I know can be used to force the workspace selection. So, for the time being I can use the Switch Workspace command, and if necessary, install the previous version of DevStyle as indicated in the linked thread.

    #681745 Reply

    Brian Fernandes

    Please update your DevStyle installations for the fix.

    We just released DevStyle 2022.6.13a with a fix for this issue. Once you apply the update and restart, all should be well, and you should see the workspace prompt or the DevStyle Startup Experience again. Thank you for your support and patience in working with us on this fix.

    If you still experience the issue post update, please let us know.

Viewing 5 posts - 1 through 5 (of 5 total)
Reply To: No startup experience again

You must be logged in to post in the forum log in