Workspace selection on startup broken after recent update.

  1. DevStyle
  2.  > 
  3. Theme Problems
Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
  • #681489 Reply


    After an update 2 days ago my STM32CubeIDE always starts with an empty workspace, not even the last one I’ve used. The dialog to select the workspace also doesn’t appear on startup. The workspace can be switched later.

    I tried to disable the custom workspace selector option and then enable it again. It just doesn’t work either way. Totally broken.

    However, when I select “Switch workspace” from the menu, the custom dialog appears and works correctly, it just doesn’t work on startup.

    #681503 Reply



    I got the latest DevStyle Update yesterday and can confirm the issue, HTD reported. I also use the latest STM32CubeIDE 1.9.0 on a actual Windows 10 Enterprise 20H2. HTD did mention it but probably not clear enough, if the Startup Experience is deactivated, it is expected to see the native Eclipse workspace selection dialog at startup. Neither the native nor the DevStyle Dialog appears at startup.

    Thanks a lot in investigating and repairing this issue.

    Best regards!

    #681508 Reply

    Brian Fernandes

    Thank you for your reports – we have been able to replicate the issue with the latest DevStyle release and STM32CubeIDE 1.9.0 as well. Due to the nature of the problem, the preference to disable the custom startup doesn’t have any effect either, unfortunately. We’ve run several additional tests, and the issue appears to be specific to this version of STM32CubeIDE.

    For now, we’d like to recommend either of the following workarounds:

    1) Use the -data argument to hard-code the workspace you really want to use. You can add the -data switch to your stm32cubeide.ini file, (anywhere before the -vmargs section)

    -data c:\workspaces\myworkspace

    Or use it as a command line argument when starting the IDE: stm32cubeide.exe -data c:\workspaces\myworkspace


    2) Uninstall DevStyle, and install the prior version.

    First, you will need to turn of the DevStyle auto-update. With the IDE shut down, create this file if it doesn’t exist:
    [STM IDE]/configuration/.settings/com.genuitec.eclipse.webclipse.evergreen.prefs
    and add this property

    Next, uninstall DevStyle and install the prior version from this update site: http://downloads.genuitec.com/downloads/products/devstyle/updates/ds20210526

    Apologies for the inconvenience caused, do let us know if these instructions do not work for you.

    #681676 Reply


    I uninstalled previous version.
    I installed the version from the provided link: http://downloads.genuitec.com/downloads/products/devstyle/updates/ds20210526.
    I changed com.genuitec.eclipse.webclipse.evergreen.prefs file, added autoUpdateEnabled=false.

    After restarting IDE the startup experience appeared.

    I got following error message when trying to start my workspace:

    An error has occurred. See the log file

    !ENTRY org.eclipse.osgi 4 0 2022-06-23 20:15:26.757
    !MESSAGE Application error
    !STACK 1
    at com.genuitec.eclipse.theming.core.workbenchcolor.WorkbenchColorService.isCustom(WorkbenchColorService.java:121)
    at com.genuitec.eclipse.theming.core.workbenchcolor.WorkbenchColorService.<init>(WorkbenchColorService.java:58)
    at com.genuitec.eclipse.theming.core.workbenchcolor.WorkbenchColorService.getInstance(WorkbenchColorService.java:69)
    at com.genuitec.eclipse.theming.ui.internal.DevStyleCSSURLHandler.openConnection(DevStyleCSSURLHandler.java:56)
    at org.eclipse.osgi.internal.url.URLStreamHandlerProxy.openConnection(URLStreamHandlerProxy.java:123)
    at java.base/java.net.URL.openConnection(URL.java:1099)
    at java.base/java.net.URL.openStream(URL.java:1165)
    at org.eclipse.e4.ui.css.swt.internal.theme.ThemeEngine.setTheme(ThemeEngine.java:469)
    at org.eclipse.e4.ui.css.swt.internal.theme.ThemeEngine.setTheme(ThemeEngine.java:434)
    at org.eclipse.e4.ui.css.swt.internal.theme.ThemeEngine.restore(ThemeEngine.java:605)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.setCSSTheme(PartRenderingEngine.java:1416)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.initializeStyling(PartRenderingEngine.java:1323)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$5.run(PartRenderingEngine.java:1049)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:338)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1045)
    at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:155)
    at org.eclipse.ui.internal.Workbench.lambda$3(Workbench.java:644)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:338)
    at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:551)
    at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:156)
    at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:152)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:203)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:136)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:401)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:255)
    at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.base/java.lang.reflect.Method.invoke(Method.java:566)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:659)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:596)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1467)

    I guess it’s because I used the new themes not available in old version. I think the software should just reset the settings to default, not crash.

    Still, I created a new workspace and imported the project I was working on. Now I just have to spend some time on restoring my previous settings by copying all directories from the .settings directory of my backup except the DevStyle settings and it should work.

    What I suspect about the startup issue – it might be a dependency on the new version of the Marketplace Client that is incompatible with STM32CubeIDE 1.9.0, that is my current and latest available version.

    Can we expect a new version with those issues fixed in the nearest future?

    • This reply was modified 1 year, 8 months ago by HTD.
    #681680 Reply


    BTW, the update thing… It failed completely. The extension was constantly nagging about updates, despite the change in the configuration I made. Eventually – it updated itself forcibly, despite me explicitly cancelled it and disabled update site in option. On the next start of STM32CubeIDE I got a message telling me the DevStyle was updated! So much time wasted, I got back to square one, so now I will try to use second workaround with a command shortcut for opening my project, this should probably work for now.

    #681690 Reply


    Me and several others on my team also received the automatic update a few days ago which caused the same issue. This issue isn’t isolated to STM32CubeIDE. We are running SpringToolSuite4 for Eclipse and this update broke us as well. Please look into this and advise. Very frustrating to say the least.

    #681691 Reply


    Thanks for confirming the broader scope. We will work on an update to fix this. Definitely not an intended behavior.

    #681698 Reply


    Thanks for confirming, I was pretty tired yesterday and I wasn’t completely sure whether I accidentally triggered the update somehow, also too tired to doublecheck, but it seems like I didn’t. Well, so far I found only 1 major issue with the current version, the command line workaround should probably work (I’ll try to test it when I’ll be back later today), and we can relax and wait for the next update 😉 The “Windows 11” theme from the current version is cool, matches the Windows 11 dark theme pretty seamless. There’s still one minor issue left: when the code completion suggestion appear – the background for the selection is probably not set by the theme so it’s nearly invisible. (Probably applies to all dark themes). It was in both previous and current version. My workaround for it is to just type more characters to make the completion list shorter. Also, I avoid to have mouse pointer over the completion list, because it highlights the item under mouse cursor with a clearly visible color so it seems selected, since in fact it isn’t. The actual selected item is highlighted in virtually invisible background.

    #681721 Reply



    Same problem on Eclipse Oxygen.3a Release (4.7.3a).

    Thank you.

    #681729 Reply


    @HTD : Can you please share a screenshot of the code completion suggestions box to help us get a visual?

    : I am assuming you are also seeing a break in the workspace prompt functionality. Is this a new install of DevStyle or an update?
    We are actively investigating it right now.

    Apologies for inconvenience caused.

    Genuitec Support

    #681738 Reply



    Yes, the problem is related to the workspace prompt functionality. I guess it’s related to the latest update because it was working fine until now. I also reinstalled DevStyle but the problem persists.

    If this helps, I also use this other Eclipse version on the same computer and DevStyle (same version 2022.6.16) works fine there:
    Version: 2022-03 (4.23.0)
    Build id: 20220310-1457


    #681746 Reply

    Brian Fernandes

    @HTD @rocotocloc please update your DevStyle installations for the startup issue fix. Details here. We appreciate the time taken to send in reports, and the testing details from different Eclipse installations – thanks!

    #681758 Reply



    It works now. Thanks for the quick support.

    #681759 Reply


    @roctocloc – Glad that it works. Thank you for confirming.
    Do let us know if you see any further issues with DevStyle.

    Genuitec Support

Viewing 14 posts - 1 through 14 (of 14 total)
Reply To: Workspace selection on startup broken after recent update.

You must be logged in to post in the forum log in