Problems with HTML Editor

  1. MyEclipse Archived
  2.  > 
  3. Web Development (HTML, CSS, etc.)
Viewing 15 posts - 46 through 60 (of 62 total)
  • Author
  • #225287 Reply

    Riyad Kalla

    Also note, you did not ask me to install into a *clean* environment

    My mistake, sometimes it is hard to keep track of all the currently open threads and what we have/haven’t tried.

    There are two more things to try that we haven’t:
    1) Try a new workspace, completely new, and reimport your project(s)
    2) Try a clean install of Eclipse 3.0.1 SDk and MyEclipse 3.8.4 (which will include QF1 and 2 if you redownload it from the site). Then if that works, to slowly move over your plugins to the new install.

    I have a feeling that #1 would do the trick as a new workspace is a lot like reinstalling since Eclipse stores everything in the workspace, so even if -clean isn’t cleaning out stray or inconsistent information, a new workspace definately would.

    And if that didn’t work, then a combination of #1 and #2 (meaning do the new install, create new workspace and import projects) would do it.

    To say that I need a separate “clean” environment to use your product breaks the philosophy of a modular environment.

    I didn’t and wouldn’t, but I understand you are probably at wits end right now with MyEclipse, so I won’t ask you to do anymore with your setup; I have just posted the last two things I can think of above, give them a try if you have time this week or weekend or stick with 3.8.3 if that is working as it should until 3.9 comes out (end of March).

    then it is safe to say that there is something with 3.8.4 that is preventing this from operating properly.

    I wasn’t contesting this, my job is to get you up and running with MyEclipse, if in the process I can discern a reproducable test case then I can file it and the developers job is to fix it. We have been unable to accomplish either here and I really feel badly about that… at the least now I just want to get you setup with a working environment so you can get your work done as I imagine you are ready to kill somebody let alone want to take more time out of your day troubleshooting what is going on.

    #225295 Reply


    I will do as instructed above as soon as I can and will report back. Thanks.

    #225362 Reply


    Well….bad news.

    I went ahead and did #1 above by doing the following steps:

    1. Removed the workspace
    2. Upraded to 3.8.4 via software update
    3. Imported my old project and tested

    After about 10-15 minutes, I got the error again. So, I did #2 following the steps below:

    1. Uninstalled MyEclipse completely
    2. Renamed my existing directory for eclipse to eclipse_old
    3. Installed a fresh copy of eclipse 3.0.1
    4. Downloaded and installed 3.8.4 from the download section of your website
    5. Created my project
    6. Added STRUTS 1.1 to the project
    7. Copied only the webfiles that I needed (web.xml, struts-config.xml, ALL html/jsps, etc.)

    After about 10 minutes of constant editing/previewing I got the error.

    #225373 Reply

    Riyad Kalla

    After a lengthy discussion with our lead developer we suggest that you downgrade to 3.8.3 and use that for the time being. Aparently the HTML editor(editing) is being totally rewritten for our next release; we would encourage you to try it when it is released near the end of March.

    Again we appologize for not being able to solve this problem you were having.

    #225383 Reply


    Ok, will do. Hopefully 3.9 will correct this issue.

    #228028 Reply


    I am so glad to have found this thread!! Phew! I was having the same problem. I uninstalled MyEclipse 3.8.4 and reverted to 3.8.3 … and so far so good!! 😀

    I’ll be interested to try MyEclipse 3.9 when it is released to see if the problem is gone.

    Thanks very much!

    #228102 Reply


    I’m using Eclipse 3.0.2 with MyEclipse 3.8.4

    FWIW, I can reproduce this error easily as follows:

    * I have MyEclipse HTML editor set as default editor for HTML files.
    1) Create a new HTML file, e.g. “test.html”
    2) Enter some text, e.g. “This is a test”
    3) Save it
    4) Click on the “Design” tab at the bottom.
    5) I get a “Microsoft Installer Warning” dialog, click No to dismiss it and proceed to the Design view
    6) Click back on the Source tab
    7) Close the editor
    8) Double-click on the html file to open it again
    ==> Now start typing: the text will go backwards <==
    ==> If you try and paste some text, you get the error message “The command for the key you pressed failed” <==

    Nothing you type from here on will flag the editor as modified, so you can’t save it. If you open the html file in another editor (e.g. Text Editor) you can continue to edit successfully. You can’t edit it in MyEclipse HTML editor again.


    #228118 Reply

    Riyad Kalla

    Tim I could kiss you right now, I was able to reproduce this easily with your steps! Adding to report.

    #228776 Reply


    I read carefully the whole thread. Is there a fix available for that problem of reverse characters?.

    Kind Regards

    #228781 Reply

    Riyad Kalla

    Actually no and it doesn’t seem to be a MyEclipse-only problem, it seems to be an issue in Eclipse’s editor framewokr, please take a look at Thoras’s post here: https://www.genuitec.com/forums/topic/odd-jsp-editor-problems/#post-228775&sid=d6f572932742992738c219c86803984c

    We are still looking into this and trying to coordinate efforts with others.

    #231058 Reply


    Has there been any new developments on this problem? It’s driving me crazy; is the advice of down-grading to MyEclipse 3.8.3 still the best advice?


    #231060 Reply

    Riyad Kalla

    BC we drilled down and found the problem and “fixed it” in 4.0 Milestone 1, however we had a user report recently that it is still happening so we are asking them for details on reproducing the issue and also looking into more code on our end. This bug is very high priority for us.

    #231123 Reply


    @support-rkalla wrote:

    BC we drilled down…

    Okay, thanks for the info. You guys do a great job of supporting this tool, and it’s a huge asset to have this support forum. Thanks again.

    #233601 Reply

    I am seeing this issue as well.

    “fixed it” in 4.0 Milestone 1, however we had a user report recently that it is still happening

    Is this issue fixed in 4.0?

    #233602 Reply

    Riyad Kalla

    Update as of 30mins ago: We think we finally fixed this for real. Aparently there is a very fuzzy gray area in the Eclipse platform between what it should be doing and what it is actually doing, this bug wasn’t a straight forward “woops” by any stretch of the imagination. So far testing of the new fix internally seems to show that all the SSE based editors (JSP, HTML, XML, etc.) are all working fine, this will go into M3 and then you guys can let us know.

Viewing 15 posts - 46 through 60 (of 62 total)
Reply To: Problems with HTML Editor

You must be logged in to post in the forum log in