White background in package explorer on startup

This topic contains 11 replies, has 5 voices, and was last updated by  denieru 4 months, 2 weeks ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #589980 Reply

    denieru
    Participant

    Just installed Darkest dark theme, and it looks great. one small problem.
    When I start eclipse my “package explorer” has white background instead of black (pics)
    I can fix the “package explorer” go in to eclipse -> preferences -> Appearance and push “apply”, then the background loads in black. But next time i start eclipse it is white again.
    i have it installed on 2 computeres with the same result

    Eclipse IDE for Java Developers
    Version: Oxygen.3a Release (4.7.3a)
    Build id: 20180405-1200
    os: Windows 10

    Attachments:
    You must be logged in to view attached files.
    #589985 Reply

    aaronlonin
    Moderator

    @denieru, Can you try the following?
    1. Go to Preferences > DevStyle > Color Themes
    2. Check “Force Colors”
    3. Apply and Close

    Let me know if that does the trick.

    Cheers!
    Aaron Lara

    #590026 Reply

    denieru
    Participant

    Sorry that dosen’t work. checking the “force colors” option on, then “apply” and then “apply and close”, the background is still white. When i go to the “force colors” option again after, the “force colors” is unchecked again. it’s the same if I restart eclipse right after the option change

    #590035 Reply

    aaronlonin
    Moderator

    Thanks for trying that out, “Force colors” is a one time application, it being unchecked afterwards is expected (we don’t want to keep forcing colors every time).

    It’s also possible that a third party plugin is forcing a preference in for the project explorer background, do you have any other outstanding plugin installed?

    #590093 Reply

    denieru
    Participant

    Your welcome 🙂

    Here is a list of what i have installed on eclipse ad this moment.

    If there is something more specific you want, I’ve be happy to help

    Attachments:
    You must be logged in to view attached files.
    #590388 Reply

    synatrin
    Participant

    For me it’s the Package Explorer view (only when it is placed on the top left of the left-most screen, i.e. the first view generated). When I minimize and restore the view (i.e. not the containing window), the style is applied (even with the force colors enabled). When I moved the Package Explorer view to a different location, the style is applied on startup. Hopefully this helps raise visibility to the issue. By the way, I also have a similar list of plugins as denieru.

    #590390 Reply

    aaronlonin
    Moderator

    @synatrin, @denieru, Thanks for the details provided! We are investigating the cause of this issue!

    #590524 Reply

    michaelu
    Participant

    Pic1.
    I installed the eclipse photon and changed theme to the dark. Background is dark.

    Pic2.
    But when I installed devstyle and changed theme on the darkest, I got a white background in some form fields.

    Pic3.
    In Oxygen.3a (3.4.7) is all right.

    I use Ubuntu 16.04 LTS

    • This reply was modified 5 months, 1 week ago by  michaelu.
    Attachments:
    You must be logged in to view attached files.
    #590680 Reply

    michaelu
    Participant

    In addition to the previous post.

    Pic4
    White buttons and white selected strings.

    Attachments:
    You must be logged in to view attached files.
    #592680 Reply

    andymyersau
    Participant

    The only plugins I have installed since downloading the IDE for JavaScript and Web Developers bundle from eclipse.org are Codemix (0.9.0) and DevStyle (1.11.0)

    For me the issue is that in the file tree any files or directories which have been changed since the last git pull are highlighted white when I’m in the dark theme. I can correct this by going to Window -> Preferences -> General -> Appearance -> Colors and Fonts and under Git reset “Uncommitted Change (Background)” and “Ignored Resource (Background) however those changes only last until next time I restart Eclipse.

    (Is there any way to take “Ooomph” out of the equation – I feel a bit uncertain how that works across the various eclipse installs I have)

    • This reply was modified 4 months, 2 weeks ago by  andymyersau.
    • This reply was modified 4 months, 2 weeks ago by  andymyersau.
    Attachments:
    You must be logged in to view attached files.
    #592747 Reply

    aaronlonin
    Moderator

    @andymyersau, We know oomph sometimes messes with our preferences in way we do not expect. One thing you can try is:

    1. Close eclipse
    2. Go to the .eclipse folder in your home directory. Example: c:\users\andy\.eclipse
    3. Remove all directories starting with org.eclipse.oomph.*
    4. Start eclipse again

    That should at least reset oomph stored preferences.

    Please let us know if that works.

    Thanks!
    Aaron Lara

    • This reply was modified 4 months, 2 weeks ago by  aaronlonin.
    #592754 Reply

    denieru
    Participant

    Moving the package explorer from the leftmost part of my view work, thanks

Viewing 12 posts - 1 through 12 (of 12 total)
Reply To: White background in package explorer on startup