Navigating Code 

Whether navigating between files or to code within a file, numerous navigation tools are available to speed your workflow. 

These navigation tools are available in MyEclipseCodeMix, and Angular IDE.

Use any combination of the following navigation tools and watch your productivity soar. 

Quick File Navigation

Press Ctrl+P to use Quick Open to open any file by its name.



You can use Alt+Left and Alt+Right to navigate between files and edit locations. If you are jumping around between different lines of the same file, these shortcuts allow you to navigate between those locations easily.

Note: To include this feature in MyEclipse, install the CodeMix plugin. 

You can also use Ctrl+E to see a list of open editors and select an editor from the list. 

Go to Definition

If a language supports it, you can press Ctrl+Click or F3 to go to the definition of a symbol.

If you press Ctrl and hover over a symbol, a preview of the declaration appears.

Note: To include the sneak peek on hover in MyEclipse, install the CodeMix plugin. 

Go to Symbol

To navigate symbols inside a file, press Ctrl+P, and then type @ to access the symbol palette. You can type a colon (:) to group the symbols by category. Select a symbol from the list to navigate to it in your code. 

Note: To include this feature in MyEclipse, install the CodeMix plugin. 

Open Symbol by Name

Some languages support jumping to a symbol across files with Ctrl+Shift+T. Type the first letter of a type you want to navigate to, regardless of which file contains it, and then select the symbol from the list.

Note: To include this feature in MyEclipse, install the CodeMix plugin. 

Bracket Matching

Click a bracket in the editor and the matching bracket is highlighted.

Outline View

The ability to easily visualize elements in your code provides a nice way to navigate your project. Use the Outline view to clearly see the structure of a file in its entirety. Simply click an element in the outline to jump to that section in your code. You can also press Ctrl+O to bring up the quick outline. 

Word Highlighting

Word highlighting (aka occurrence highlighting) helps you understand the role of particular methods and variables in your code. Click a variable or method in a file to view all occurrences of the selected item within the file. Combine this feature with the Outline view for a nice way to visualize and navigate code.

Minimap View

Use the Minimap view as an easy way to quickly jump to a specific section of code.  A condensed version of the code displays in the view. As you scroll through the minimap, the corresponding code displays in the editor.

Show the Minimap view—Select Window>Show View>Other>General>Minimap from the menu bar.

MiniMap

Breadcrumb Navigation

A Breadcrumb is available with the DevStyle plugin. The Breadcrumb toolbar allows you to quickly navigate through your workspace and open files for editing. The crumb trail that led to the file displayed in the Source Editor is shown in the Breadcrumb toolbar. Click on any crumb in the trail to navigate to a different resource in your project. For example, if you are editing a Java class, it’s very easy to open other classes or packages within the project. Or, for web projects, quickly jump between the various folders and html files in the project.  

Showing the Breadcrumb toolbar—Click the ddbreadcrumbbutton Breadcrumb Toggle button on the main toolbar. This button toggles the Breadcrumb toolbar to show or hide.

Hiding the Breadcrumb toolbar—Click the ddbreadcrumbbutton Breadcrumb Toggle button on the main toolbar or right-click from the Breadcrumb toolbar and select Hide Breadcrumb.

Breadcrumb toolbar

MyEclipse Explorer

MyEclipse includes an advanced explorer. MyEclipse Explorer provides an easy way to quickly locate files and resources. Use this view as an alternative to the Project Explorer view to take advantage of advanced search capabilities. Type filter text and specify whether the search is a regular expression, a filename, file content, and if the search text is case sensitive.

The filter drop-down retains your search history and remembers your filter tool settings for previous searches.

To show this view, select Windows>Show View>General>MyEclipse Explorer.

Project Explorer+

Navigation Demo

Watch the following demo to see some navigation tools in action. This video shows how to navigate an Angular project while in MyEclipse.

Documentation is licensed under the Creative Commons Attribution 3.0 United States License. Original work from vscode-docs GitHub repository has been modified.