Configuring Add-ons for Eclipse-Based Software

If your teams have existing installations of Eclipse-based software, such as Eclipse or IBM RAD, you can deliver software add-ons, secure software catalogs, and security settings to existing installations. This type of delivery to IDE installations not managed by SDC is called On-Demand Delivery. In this tutorial, you will learn how to:

  • Create a basic on-demand package
  • Select target IDE versions

Duration Time: 10 Minutes

Start Tutorial Now

Don't have SDC? Download Now

1. Create a Basic On-Demand Package

  1. In the Secure Packages list in the Admin Console navigation, click On-Demand Secure Delivery.
    on_demand_nav
    Creating an On-Demand package
  2. In the Packages section, click addIcon to add a new package, or duplicate_pkg_icon to duplicate an existing package, i.e. use an existing package as a template for a new one.
  3. Enter a title for the package. This title will be displayed on the portal web page. Choose one or more delivery groups for the package. If no groups are selected, the package appears on the portal home page, if using the default access policy. Click Next.
    create_on_demand_pkg
    Naming the new package
  4. Choose from a list of marketplace catalogs if you want to make a secure catalog available. This list contains the catalogs created in the Secure Marketplaces software collection.
    on_demand_marketplace
    Specifying a secure marketplace

The Package Details page opens to the Overview tab. The status of capabilities that can be defined for the package displays in the Capabilities section. The first four are set up by default. You can tailor these to fit your needs by clicking the Configuration tab or the corresponding items in the Admin Console navigation. You can also view usage metrics for this package.

on_demand_overview
Package overview

At this point, the package is created with default access, environment, and security policies.

2. Select Target IDE Versions

With on-demand delivery packages, you can indicate which versions of Eclipse software are allowed to use this package. If you are unsure which versions of Eclipse your users will be using, choose all available versions to be supported providing broad support for your user base. If you do not provide support for an Eclipse version, users attempting to install from an unsupported version will receive a problem message. It is recommended to select all versions of Eclipse that might likely be used.

  1. Click the Software tab.
  2. In the Eclipse Targets section, select the Eclipse versions you want to support with this package. All are selected by default.
    on-demand_package_software_tab
    On-demand delivery package Software tab
  3. Use the drag-to-install toggle to enable/disable this feature.

    Note: You are restricted to enabling this feature to only one on-demand package. Otherwise, users can install the package by adding an update site to their Eclipse-based software version. The update site URL appears on the package portal page.

    Eclipse's Drag-to-Install feature needs to know how to contact your company's SDC delivery hub in order to install the on-demand package. See Setting up Drag-To-Install for On-Demand Packages for setup information.